yj turn signal and brake light problems - JeepForum.com

Reply
 
LinkBack Thread Tools
post #1 of 20 Old 03-27-2010, 05:53 PM Thread Starter
mannyj
Registered User
1993 YJ Wrangler 
 
Join Date: Mar 2010
Location: nebraska
Posts: 40
yj turn signal and brake light problems

i bought a used yj with low miles and no rust with a ton of extras cheap. drove it home and found that my drivers side turn signal wasnt working, so i checked lights and all were fine, heck even the hazards work. i then replaced the turn signal switch and nothing. when i tap on the tail light housing it works til i need to use it then it stops, now i got the same thing happening to the right side. any one have any clues as to what this could be?

mannyj is offline  
Sponsored Links
Advertisement
 
post #2 of 20 Old 03-27-2010, 07:46 PM
dodger889
Registered User
1989 YJ Wrangler 
 
Join Date: Jan 2009
Location: mi
Posts: 4,160
Exercise the hazard switch. a little more. on off on off on off check them if working fixed if not repeat they have something build up on the contacts.

A 89 yj with a 4.0 aw4 sye out of an 92xj. Now the hard part is done time to get it up in the air just a bit. Working on 8.8 with 3.73 and lsd for the rear. and new D30 hp with 3.73 .
For those who have not figured this out I'm old school but can handle the new too.
Quote:
Originally Posted by bigsquat View Post
im just cheap, and cheap makes you creative.
dodger889 is offline  
post #3 of 20 Old 03-27-2010, 07:56 PM
ZillaKing
Registered User
1993 YJ Wrangler 
 
Join Date: Feb 2010
Location: Hartville, OH
Posts: 49
The rear light's ground is the bolts holding it to the tub. Take em out and clean everything up well. Put them back in snug and see what happens.
ZillaKing is offline  
post #4 of 20 Old 03-28-2010, 01:11 AM
Lambo3244
Registered User
1993 YJ Wrangler 
 
Join Date: Dec 2008
Location: Brush Prarie
Posts: 285
REPLACE the two front amber lights in the grill! Don't just replace the one side, but do it to both. That should solve your issue. When you pull out those lights, the assembly that they twist in and out of is pretty funky so make sure that you put them in the way you took them out. Check the ground wire also for those parking lights as well, make sure that has a good metal-to-metal contact. Good luck.
Lambo3244 is offline  
post #5 of 20 Old 03-28-2010, 04:07 AM
lclark2074
Registered User
1990 YJ Wrangler 
 
Join Date: Nov 2008
Location: RI
Posts: 709
Quote:
Originally Posted by ZillaKing View Post
The rear light's ground is the bolts holding it to the tub. Take em out and clean everything up well. Put them back in snug and see what happens.
I agree but you should put cunducive neverseive on threds before reinstall
lclark2074 is offline  
post #6 of 20 Old 03-28-2010, 08:43 PM Thread Starter
mannyj
Registered User
1993 YJ Wrangler 
 
Join Date: Mar 2010
Location: nebraska
Posts: 40
thanks guys for the help i will try it all till i get it figured out and let you know what it was
mannyj is offline  
post #7 of 20 Old 03-28-2010, 08:51 PM
dprg644
Registered User
1993 YJ Wrangler 
 
Join Date: Apr 2009
Location: Oklahoma
Posts: 10
Quote:
Originally Posted by ZillaKing View Post
The rear light's ground is the bolts holding it to the tub. Take em out and clean everything up well. Put them back in snug and see what happens.
Mine did the same thing and this fixed it. Good Luck
dprg644 is offline  
post #8 of 20 Old 04-03-2010, 08:58 AM Thread Starter
mannyj
Registered User
1993 YJ Wrangler 
 
Join Date: Mar 2010
Location: nebraska
Posts: 40
pulled the bolts and cleaned everything up left signal works great but right one still does the same thing and wont flash. worked over the hazard switch real good and that didnt help. could it be the socket the bulds are all good from front to back
mannyj is offline  
post #9 of 20 Old 04-03-2010, 10:36 AM Thread Starter
mannyj
Registered User
1993 YJ Wrangler 
 
Join Date: Mar 2010
Location: nebraska
Posts: 40
i think i got it figured out after i cleaned the bolts and the bolt holes on the tub and work the hazard switch and checked bulbs and sockets. i got back on here and read other posts for tjs and found that it may be the flasher for the turn signals i pulled the one for my hazards and tried it to find that it worked fine so i figured for 3 bux its worth a shot put it in and the turn signals didnt miss a blink
thanks much for the help
sorry for the repeat message i just got a lil xcited after a year of tapping the tail light housing
mannyj is offline  
post #10 of 20 Old 07-20-2011, 05:37 PM
rttg
Registered User
1990 YJ Wrangler 
 
Join Date: Jul 2011
Location: Lake Stevens
Posts: 2
I'm new to jeeps. Where is the flasher? My right turn signal is not working, just comes on solid. I've changed all of the bulbs, same thing, I've played with hazard lights (of which are working fine). I've made sure I have a good ground. I've even replaced the entire rear tail light housing... still not work. HELP!
rttg is offline  
post #11 of 20 Old 07-20-2011, 09:31 PM
dodger889
Registered User
1989 YJ Wrangler 
 
Join Date: Jan 2009
Location: mi
Posts: 4,160
Are both lighting up front and back?? Need to know this because if the left side is working then you either have a bad ground one the on that is not working or a bad socket. For testing a ground use a jumper wire to the outside of the socket to a known good grounding point like the battery negative side.

more than likely you do not have a bad flasher. but since you asked it under the dash up by the p-brake mounting point.

A 89 yj with a 4.0 aw4 sye out of an 92xj. Now the hard part is done time to get it up in the air just a bit. Working on 8.8 with 3.73 and lsd for the rear. and new D30 hp with 3.73 .
For those who have not figured this out I'm old school but can handle the new too.
Quote:
Originally Posted by bigsquat View Post
im just cheap, and cheap makes you creative.
dodger889 is offline  
post #12 of 20 Old 07-21-2011, 07:20 PM
rttg
Registered User
1990 YJ Wrangler 
 
Join Date: Jul 2011
Location: Lake Stevens
Posts: 2
My problem has been solved. Not exactly sure what it was but the only thing I can point to is that when I finally replaced the entire tail light housing and tested it, it didn't work... because it wasn't ground. It was cracked anyway so I did replace. After putting everything back together, my son tells me it is working. Thanks!
rttg is offline  
post #13 of 20 Old 08-05-2011, 09:12 AM
Idared
Registered User
1995 YJ Wrangler 
 
Join Date: Jul 2011
Location: Dolores
Posts: 116
Ok On my 95 yj I cannot get the drivers Front Turn signal to blink. It will come on when the park lights are on and when the lights are on. I replaced all the bulbs on both sides and the flasher. The rear ones blink just fine. and so does the light inside. Just the front drivers turn signal will not blink or even come on when turn signal is on.

Never drop your gun to hug a grizzly.

As a matter of fact I do Jeep like a girl. :-)
Red Jeep Club #635 Colorado Jeep Club #550
Idared is offline  
post #14 of 20 Old 09-22-2014, 02:59 PM
kelownadude
Registered User
1988 YJ Wrangler 
 
Join Date: Sep 2014
Location: kelowna
Posts: 1
lights and brake issue

i recently purchased an 88 yj.
i had the strange issues as othersdo on forums.. turn signal lights one fast ,one slow. step on brakes: lights would freeze.turn on head lights ;turn signals froze;step on brakes ,dash lights came on!!! wtf
well i solved it!!!
started with the rear lights check the gounding, removed the spliced wiring harness,but by fluke i desided to replace the rear bulbs with normal 1157 bulbs and what do you know everything works again!!!
hope this may help someone else
kelownadude is offline  
post #15 of 20 Old 05-05-2015, 05:18 PM
grethel88
Registered User
1993 YJ Wrangler 
 
Join Date: Nov 2013
Posts: 4
1993 jeep wrangler

All lights work, except turn signals and also dash board turn signals indicators. Any suggestions. Turn signal fuse is good. All other lights on dash board work as well
grethel88 is offline  
Reply

Tags
brake lights , turn signal , wiring

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
turn signal/brake light problems m1kemcc TJ Wrangler Technical Forum 3 06-20-2009 07:51 PM
right turn signal and brake light not working DMC0627 TJ Wrangler Technical Forum 4 05-20-2009 04:23 PM
turn signal/ brake light problem pipelineaudio TJ Wrangler Technical Forum 2 06-06-2008 11:59 PM
RT Turn Signal/Brake light tjtone TJ Wrangler Technical Forum 2 03-30-2007 12:27 PM
Turn Signal and Brake Light Jeep_Grrl TJ Wrangler Technical Forum 8 08-13-2005 03:24 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome