YJ not starting - JeepForum.com

 
LinkBack Thread Tools
post #1 of 8 Old 05-21-2013, 07:28 PM Thread Starter
k_linx
Registered User
1986 CJ7 
 
Join Date: Oct 2010
Location: Edinburg
Posts: 44
YJ not starting

I have an 89 Jeep Wrangler that will not start. It will crank for about a second but then everything turns off. I have checked the fuel pump, ignition switch, relay, and fuses. If I put gas in the carb it will crank. Any suggestions on what next to look at?

Thanks

k_linx is offline  
Sponsored Links
Advertisement
 
post #2 of 8 Old 05-21-2013, 07:36 PM
Cashcrazy
Registered User
1983 CJ7 
 
Join Date: May 2013
Location: Tyler
Posts: 683
What engine? The engine will actually turn over (not just clicking) and then everything shuts as if someone yankee the battery?
Cashcrazy is offline  
post #3 of 8 Old 05-21-2013, 07:47 PM
JCashen
Registered User
1990 YJ Wrangler 
 
Join Date: Jan 2013
Location: Fort Worth
Posts: 228
Was it running previously to this problem? Have you change anything recently? What engine as well?

"Drippy"

90 YJ 5.2 Magnum, 4.10 LSD 8.8
JCashen is offline  
post #4 of 8 Old 05-21-2013, 07:51 PM
rambo3489
Registered User
1989 YJ Wrangler 
 
Join Date: Feb 2011
Location: Phoenix
Posts: 1,704
I say something electrical regardless. If it just stops cranking something is going on with the starter the battery or the wires between them all the way up to the key.

89 YJ.. My first jeep and I won't let it go. ▀||||▀

Current Project: None... I disgust myself.

<a href="http://www.jeepforum.com/forum/f22/my-yj-build-adventures-thread-1356941">BUILDING THE YJ MY WAY</a>
rambo3489 is offline  
post #5 of 8 Old 05-22-2013, 08:35 AM Thread Starter
k_linx
Registered User
1986 CJ7 
 
Join Date: Oct 2010
Location: Edinburg
Posts: 44
Quote:
Originally Posted by Cashcrazy View Post
What engine? The engine will actually turn over (not just clicking) and then everything shuts as if someone yankee the battery?
Yes you are correct it cranks but then everything turns off. The engine is a 2.5L.
k_linx is offline  
post #6 of 8 Old 05-22-2013, 08:56 AM
EABiker
Registered User
1989 YJ Wrangler 
 
Join Date: Dec 2004
Location: Frederick, MD
Posts: 1,721
I think the OP means the engine fires then shuts off; is that correct? That seems to point to a fuel deliver/pressure issue.
EABiker is offline  
post #7 of 8 Old 05-22-2013, 09:05 AM
TexasYJ
Registered User
1995 YJ Wrangler 
 
Join Date: Aug 2010
Location: South Texas
Posts: 201
when you turn the key to the on position, not start, does the check engine light come on?
TexasYJ is offline  
post #8 of 8 Old 05-30-2013, 12:51 PM Thread Starter
k_linx
Registered User
1986 CJ7 
 
Join Date: Oct 2010
Location: Edinburg
Posts: 44
Well we finally found out the problems. One the computer had to be replaced, once that was fixed we found out that the fuel relay did not have sufficient ground. After replacing the ground on the relay the jeep started right up.
k_linx is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome