YJ Idle problem - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Wrangler Forums > YJ Wrangler Technical Forum > YJ Idle problem

Introducing MONSTALINER™ UV Permanent DIY Roll On Bed LineOfficial Chassis Saver Rust Preventive Truck & Auto UnFS: 2007-2013 Jeep Wrangler "HALO" Angel Eye Kit

Reply
Unread 06-22-2002, 11:40 AM   #1
YJ Dude
Registered User
 
Join Date: Nov 2001
Location: Denver, CO
Posts: 14
YJ Idle problem

Hello All. I have a problem with my 94 YJ with the 2.5L that has me baffled! The problem is that it idles anywhere from 1600 RPM – 2600 RPM. Here is a list of the components that I have changed so far: AIS Motor, Throttle Positioning Sensor, Oxygen Sensor, Distributor cap, Rotor, Plugs, Plug wires. I have also removed the Throttle Body and cleaned it thoroughly. It now runs very very well but still idles way too fast. I have also checked for Vacuum leaks but can’t find any. Throttle linkage is working fine also. Does anyone have any suggestions?? Thanks much! John

__________________
94 YJ, 2.5, 4" ProComp Lift, 33's,
EZ Locker, Warn M8000 winch, Home made tire/jack carrier, nurf bars.
YJ Dude is offline   Reply With Quote
Unread 06-24-2002, 12:32 PM   #2
SnowMan
Registered User
 
Join Date: Apr 2002
Location: Ottawa, Canada
Posts: 46
I have the same engine, but the opposite problem. Mine idles to low and jumps, but in my dwelving on this problem I was told that a high RPM is usually a sign of a vacuum leak. If you haven't already I would zip tie all the vac connections, it might help. Just a suggestion
__________________
Is that you John Wayne, is this me!
SnowMan is offline   Reply With Quote
Unread 06-24-2002, 07:20 PM   #3
my litte red yj
Registered User
 
Join Date: Aug 2001
Location: Conn
Posts: 114
hey snow man i also have the same low idle as you as soon as my jeep warms up it is better but at a cold start rough!! i replaced tps,ais,dist,cat,muffler,plug's,cap,rotor the next thing i am replacing is there is a ambuent temp sensor on left side near fire wall
my litte red yj is offline   Reply With Quote
Reply
Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.