YJ Engine Issue - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Wrangler Forums > YJ Wrangler Technical Forum > YJ Engine Issue

2014 Spartan Locker Special - While Supplies Last! Dana 3The Original 3/8" Ruffstuff Diff Cover!The RuffStuff "I can't go to EJS" Sale!

Reply
Unread 08-11-2011, 11:39 AM   #1
mbgencon
Registered User
1994 YJ Wrangler 
 
Join Date: Aug 2011
Location: Myrtle Beach, SC
Posts: 2
YJ Engine Issue

This is a strange problem that I can't seem to fix. When I am driving for about 45min to an hour, if i give the engine any more than 1/4 throttle it will hesitate, sputter, backfire, etc. It does not do this under the time stated above. If I turn the engine off for a few seconds then turn it back on, it runs fine for about 10-15min then it acts up all over again. I have changed the fuel filter, throttle position sensor, cap & rotor, plugs, plug wires, and O2 sensor.

Any insight anyone may have is appreciated.

1994 YJ
2.5L

mbgencon is offline   Reply With Quote
Unread 08-11-2011, 11:57 AM   #2
Xpress
Not enough Lumens...
 
Xpress's Avatar
1989 YJ Wrangler 
 
Join Date: Dec 2010
Location: The Great Big Box, California
Posts: 5,664
Could be a few things... Might want to start with your fuel pump...
__________________
My 5.2L Build thread
-1989 Jeep Wrangler 2.5L, soon to be 5.2L
-1996 Jeep Grand Cherokar 5.2L, donor and rainy day driver
-2004 Kawasaki KLR650 sunny day driver
Quote:
Originally Posted by mudsweatNgearz View Post
Leave em off and weld an I beam on. Bumperetts just scream homo.
"A well regulated Militia, being necessary to the security of a free State, the RIGHT of the people to keep and bear Arms, SHALL NOT BE INFRINGED."
Xpress is offline   Reply With Quote
Unread 08-11-2011, 12:10 PM   #3
Matt24138
Registered User
1993 YJ Wrangler 
 
Join Date: Apr 2010
Location: Bethany Beach, Delaware
Posts: 259
Vacuum leaks are also known to open up and close with heat. Check when the issue occurs.
Matt24138 is offline   Reply With Quote
Unread 08-11-2011, 12:34 PM   #4
Que89YJ
Web Wheeler
1989 YJ Wrangler 
 
Join Date: Apr 2008
Location: Detroit, Michigan
Posts: 13,700
Welcome to the forum. Start by checking for fault codes:
Read this post:
http://www.jeepforum.com/forum/f12/1...issue-1251610/
Que89YJ is offline   Reply With Quote
Unread 08-12-2011, 05:31 PM   #5
mbgencon
Registered User
1994 YJ Wrangler 
 
Join Date: Aug 2011
Location: Myrtle Beach, SC
Posts: 2
Thanks guys, I'll try those.
mbgencon is offline   Reply With Quote
Unread 08-12-2011, 05:38 PM   #6
Darold
Registered User
1988 YJ Wrangler 
 
Join Date: May 2007
Location: Moscow , Maine
Posts: 68
Quote:
Originally Posted by mbgencon View Post
This is a strange problem that I can't seem to fix. When I am driving for about 45min to an hour, if i give the engine any more than 1/4 throttle it will hesitate, sputter, backfire, etc. It does not do this under the time stated above. If I turn the engine off for a few seconds then turn it back on, it runs fine for about 10-15min then it acts up all over again. I have changed the fuel filter, throttle position sensor, cap & rotor, plugs, plug wires, and O2 sensor.

Any insight anyone may have is appreciated.

1994 YJ
2.5L
Check sparkplug gaps, set to .035.
Darold is offline   Reply With Quote
Reply
Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.