post #1 of Old 06-01-2013, 11:13 AM Thread Starter
FUBAR86
Registered User
 
Join Date: Apr 2012
Posts: 2
Yj clutch problems

Ok so I have a 95 yj 4.0, the other day I was
Driving and noticed the clutch was acting different, I noticed because I stalled , but what I experienced or seams like what is going on is when I hold the pedal down for a long periods of time( such as reversing out a parking space) when I put it back in 1st it seams different. I guess the beat way I can diacribe it is, most the time the clutch disengages about a inch or two from the top of the pedal and with what I have been experiencing web holding the clutch down it seams to engage at the bottom of the pedal.. Witch is not normal. I had a clutch replaced about 3000 miles ago and have not had a problem untill the other day. If you have other questions I will be happy to try and answer them for you. Thanx in advance!

FUBAR86 is offline  
post #2 of Old 06-01-2013, 12:49 PM
Mark05059
Registered User
1989 YJ Wrangler 
 
Join Date: Mar 2009
Location: quechee Vermont
Posts: 4,687
check the fluid level in your clutch master.

1998 ZJ 5.2 Auto

1989 Wrangler Black Bone Stock 2.5l 5spd
/l , [____],
|---L--[]lllllll[]-
()_) ()_)==O=)_)
Mark05059 is offline  
post #3 of Old 06-01-2013, 01:10 PM Thread Starter
FUBAR86
Registered User
 
Join Date: Apr 2012
Posts: 2
Fluid was full. I already suspected the master cylinder was going bad because of some other stuff I had read. So I replaced it this morning and seams to have fixed the problem. Thank you for the reply..
FUBAR86 is offline  
Reply

Tags
clutch , YJ


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome