JeepForum.com

JeepForum.com (http://www.jeepforum.com/forum/)
-   YJ Wrangler Technical Forum (http://www.jeepforum.com/forum/f12/)
-   -   wont start (http://www.jeepforum.com/forum/f12/wont-start-1347726/)

godzilla89 03-24-2012 10:07 PM

wont start
 
I have a 89 YJ with a 93 Grand Cherokee 4.0 inline 6. It was running perfect the other day, now it wont start, the battery is brand new, the alternator is good. But there is no power getting pasted the starter solenoid on the firewall. I can not find the engine fuse box and I have looked everywhere in the jeep (not many places to hide it). This is my last effort before I take it to a shop and have them fix it. I'm open to any ideas

mangoman123 03-25-2012 12:40 AM

Put the original motor back in it lmao. The 4.2l is alright

brentd711 03-25-2012 06:02 AM

From your profile it looks like you put a '93 motor in it. Did you just use the '93 block and keep the '89 wiring?

I think they had fusible links in the engine bay wiring in both the early and later models.

kdub2886 03-25-2012 06:38 AM

Neutral safety switch ?

Mark05059 03-25-2012 08:25 AM

Quote:

Originally Posted by kdub2886 (Post 13298726)
Neutral safety switch ?

not with a manual trans.

inlinerubi 03-25-2012 09:20 AM

I did a similar thing to my yj but I put a 327 small block in it

godzilla89 03-25-2012 08:36 PM

Quote:

Originally Posted by mangoman123 (Post 13298434)
Put the original motor back in it lmao. The 4.2l is alright

i bought it this way, if I had down an engine swap it would have a V8 in it now.

mangoman123 03-25-2012 09:45 PM

That's the whole problem lmao. No, check your flux capasitor under your driver side fuse panel. If that's not it make sure your radiator belt is tight but not too tight. May just need some muffler bearings

Que89YJ 03-26-2012 07:44 AM

It came stock with fuseable links so there is no fusebox under the hood. They look like wires and there are 5 or 6 under the hood if you have the stock wiring. You will see them coming off the starter relay on the firewall. Check the fuses in the fuse box at the drivers feet too. There is an ignition fuse there.

godzilla89 03-26-2012 09:25 AM

Quote:

Originally Posted by Que89YJ (Post 13304475)
It came stock with fuseable links so there is no fusebox under the hood. They look like wires and there are 5 or 6 under the hood if you have the stock wiring. You will see them coming off the starter relay on the firewall. Check the fuses in the fuse box at the drivers feet too. There is an ignition fuse there.

is there gonna be fuseable links even with the engine swap? All the fuses in the fusebox there are good.

Que89YJ 03-26-2012 09:31 AM

The engine might have been swapped but they kept the original setup. If it has a carburator then the sytem was left original with just swapping the block.

brentd711 03-26-2012 09:53 AM

I thought a saw fusible links in my '93 YJ engine harness, was I seeing things?

Que89YJ 03-26-2012 11:20 AM

You are seeing things:eyebulge:. Fuseable links went away with the PDC in 91. Fuseable links were replaced with fuses.

godzilla89 03-26-2012 01:35 PM

Quote:

Originally Posted by Que89YJ (Post 13305638)
You are seeing things:eyebulge:. Fuseable links went away with the PDC in 91. Fuseable links were replaced with fuses.

its a 93 grand cherokee engine so why does it have fuseable links if its a 93?

jaycal3 03-26-2012 01:45 PM

I'm coming into this a bit late, but are you getting spark? Have you checked the ignition module?


The time now is 10:50 AM.

Powered by vBulletin Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.