wont fire up after i Changead TPS and crank sensor on 4.0l - JeepForum.com

 
LinkBack Thread Tools
post #1 of 3 Old 05-21-2010, 09:49 AM Thread Starter
evan422
Registered User
1993 YJ Wrangler 
 
Join Date: May 2010
Location: Calgary,AB
Posts: 2
wont fire up after i Changead TPS and crank sensor on 4.0l

I had codes for tps and crank sensor flashing, so I replaced them. The codes for them cleared and it ran alright for about 20km, then started to sputter and died. Getting started was tricky, I ended up pulling a plug to check my spark and then it started on 5 cyls. It missed even with the plug back in and now I get a 54 code which to my knowledge is cam sensor or distributor timing. Is there a way I caused this? Or coincidence?

evan422 is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old 05-21-2010, 10:02 AM
Que89YJ
Web Wheeler
1989 YJ Wrangler 
 
Join Date: Apr 2008
Location: Detroit
Posts: 22,190
Are you still missing? The code is correct. Clear the codes by disconnecting the battery and see if the fault reoccurs. If it does then its time to replace the distributor pickup sensor.
Que89YJ is offline  
post #3 of 3 Old 05-21-2010, 10:49 AM Thread Starter
evan422
Registered User
1993 YJ Wrangler 
 
Join Date: May 2010
Location: Calgary,AB
Posts: 2
Yeah I had the battery disconnected over night, it started right up, still missed. Then turned it off and it didn't start again. Yeah I'll go pick up a new sensor. I've been trying to clear up my rough idle and its starting to feel like I'm creating problems. Thanks for the advice.
evan422 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
91 yj 4.0, crank,crank,crank wont turn over hasher09 YJ Wrangler Technical Forum 20 08-04-2010 11:43 PM
4.2 will crank but wont fire 89yjmudman YJ Wrangler Technical Forum 6 04-13-2009 08:33 PM
Desperation, 1993 Jeep will not fire..replaced brain, crank sensor, ignition coil... amsgwp YJ Wrangler Technical Forum 3 03-24-2009 12:15 PM
wont run......? crank fire and air but wont run Eric93 YJ Wrangler Technical Forum 14 08-06-2008 08:12 AM
clutch wont engage and jeep wont fire natehate TJ Wrangler Technical Forum 4 04-19-2007 07:10 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome