Won't start after warm up - JeepForum.com

 
LinkBack Thread Tools
post #1 of 9 Old 03-25-2007, 07:28 PM Thread Starter
starkey
Registered User
 
Join Date: Jan 2006
Posts: 6
Won't start after warm up

Got a 90' yj and after a few miles then shut engine off for few minutes it won't start. Any ideas? I thought I had fixed the problem but didn't test it long enough.

starkey is offline  
Sponsored Links
Advertisement
 
post #2 of 9 Old 03-25-2007, 10:21 PM
pyro9862
Registered User
 
Join Date: Mar 2004
Location: Long Island, NY
Posts: 1,543
Quote:
Originally Posted by starkey
Got a 90' yj and after a few miles then shut engine off for few minutes it won't start. Any ideas? I thought I had fixed the problem but didn't test it long enough.
Perhaps the motor is flooding?
My Jeep does the same thing. When cold it will start up fine, shut it off and it starts back up fine, shut it off and let it sit five minutes and it won't. Trick in mine is to hold the pedal down to the floor. Probably not good for it but until I figure out the problem (I think I need a fuel pressure reg with my MC2100) it's going to have to do.
pyro9862 is offline  
post #3 of 9 Old 03-25-2007, 11:50 PM
sofixj
Registered User
 
sofixj's Avatar
2006 TJ Wrangler 
 
Join Date: Sep 2005
Location: NJ
Posts: 359
i had a similiar problem in my 89 it was an ASD relay auto shutdown relay

,=====o00o
//___l__,\____\,___
l_--- \___l---[]lllllll[] _
_(o)_)___(o)_)--o-)_) only in a JEEP
sofixj is offline  
post #4 of 9 Old 03-26-2007, 06:22 AM
paintguy
Registered User
 
Join Date: Apr 2005
Location: Castleton, NY
Posts: 1,267
could be the coil is going bad -- usually when a coil is crapping the bed, it runs and starts when it is cold and once the coil heats-up it shuts down and you have to wait for it to cool-off before it will refire. Also, the ignition module (under the coolant overflow bottle) can cause it to not start. Keep us posted

Pray For World Peace and Love -- This is all the World Needs, and ever needed -- Everything else will follow...
paintguy is offline  
post #5 of 9 Old 03-26-2007, 07:00 AM
the dit
Registered User
1989 YJ Wrangler 
 
Join Date: Dec 2006
Location: Longs, SC
Posts: 261
could be vapor lock. Try adding some sort of heat sink to the metal fuel line, like a bunch of aluminum foil.

89 Yj Sahara, 4.2L, 31X10.5 MT's, Weber carb, nuttered, Mustang Seats, 6" Xenon flares
2004 Dodge Ram 1500 4x4 Hemi
83 Mustang vert
the dit is offline  
post #6 of 9 Old 03-27-2007, 11:32 PM Thread Starter
starkey
Registered User
 
Join Date: Jan 2006
Posts: 6
I took it to the jeep dealership in Glendale AZ to have it tested and they say the fuel pressure regulator is leaking. I thought I heard a little hissing when I shut the truck off. I had replaced that about six months ago, they said don't buy the Checker Auto parts. Now I'm waiting on a regulator to come in, it will take five days to get. $109.99.
starkey is offline  
post #7 of 9 Old 03-28-2007, 07:30 AM
paintguy
Registered User
 
Join Date: Apr 2005
Location: Castleton, NY
Posts: 1,267
Quote:
Originally Posted by starkey
I took it to the jeep dealership in Glendale AZ to have it tested and they say the fuel pressure regulator is leaking. I thought I heard a little hissing when I shut the truck off. I had replaced that about six months ago, they said don't buy the Checker Auto parts. Now I'm waiting on a regulator to come in, it will take five days to get. $109.99.
that must mean you have a 4 banger with the tbi -- in the mean time while waiting for your fpr to arrive, if you want to start her and it doesn't want to start, turn the key 'on, 'off', 'on', 'off', 'on' and then try to fire her -- this will send more fuel and may help it start until you fix it. Keep us posted on your progress.

Pray For World Peace and Love -- This is all the World Needs, and ever needed -- Everything else will follow...
paintguy is offline  
post #8 of 9 Old 03-28-2007, 07:33 AM
paintguy
Registered User
 
Join Date: Apr 2005
Location: Castleton, NY
Posts: 1,267
Quote:
Originally Posted by starkey
I took it to the jeep dealership in Glendale AZ to have it tested and they say the fuel pressure regulator is leaking. I thought I heard a little hissing when I shut the truck off. I had replaced that about six months ago, they said don't buy the Checker Auto parts. Now I'm waiting on a regulator to come in, it will take five days to get. $109.99.
that must mean you have a 4 banger with the tbi -- in the mean time while waiting for your fpr to arrive, if you want to start her and it doesn't want to start, turn the key 'on, 'off', 'on', 'off', 'on' and then try to fire her -- this will send more fuel and may help it start until you fix it. Keep us posted on your progress.

(I used to live in Peoria -- Peoria and 77th Ave).

Pray For World Peace and Love -- This is all the World Needs, and ever needed -- Everything else will follow...
paintguy is offline  
post #9 of 9 Old 03-28-2007, 07:34 AM
ramburger
Member
 
Join Date: Jan 2006
Location: Southington, CT
Posts: 449
whaen its warmed up and wont start, just put the skinny pedal to the floor until it turns over.
ramburger is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
Won't start when warm HolidayJeep TJ Wrangler Technical Forum 25 01-05-2014 05:20 PM
90' YJ 2.5lt won't start after warm up starkey YJ Wrangler Technical Forum 5 06-29-2012 05:51 AM
won't start when warm/hot ksjohn YJ Wrangler Technical Forum 1 06-02-2008 04:24 AM
Will not start when engine is warm wjgrant YJ Wrangler Technical Forum 5 02-23-2006 09:38 AM
Pre-start warm up? anmal592 YJ Wrangler Technical Forum 4 02-15-2004 05:02 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome