Windshield wipers making noise and stopping - JeepForum.com

 
LinkBack Thread Tools
post #1 of 4 Old 08-24-2013, 01:12 AM Thread Starter
glturner39
Registered User
1993 YJ Wrangler 
 
Join Date: Mar 2013
Location: Oxford
Posts: 26
Windshield wipers making noise and stopping

Ok. First I have searched and can't find an answer to my question. A couple of weeks ago I lost low speed on my wipers. I pullthecwiper delay module and that gave me low and high, however today I turned the wipers on and suddenly they started making this terrible noise like something was slipping and popping loose. Then the wipers quit mid windshield. I got out and twisted them by hand and they started working again, but still sounds like something is loose. Do I need to drop the windshield to see if something is loose? Any suggestions? Thanks!

glturner39 is offline  
Sponsored Links
Advertisement
 
post #2 of 4 Old 08-24-2013, 01:38 AM Thread Starter
glturner39
Registered User
1993 YJ Wrangler 
 
Join Date: Mar 2013
Location: Oxford
Posts: 26
Update- just went outside and tried them again and everything seems fine? WTF? Can the linkage come loose and then pop back on?
glturner39 is offline  
post #3 of 4 Old 08-24-2013, 11:46 AM
dancytron
Registered User
1990 YJ Wrangler 
 
Join Date: Jun 2008
Location: st. louis
Posts: 1,913
Could be the motor is going out. If it was me I'd drop the windshield and see what is going on instead of waiting for it to fail again in the rain.
dancytron is online now  
post #4 of 4 Old 08-24-2013, 12:07 PM
XJ93
Registered User
1993 ZJ 
 
Join Date: Apr 2009
Location: Michigan
Posts: 1,539
Quote:
Originally Posted by dancytron View Post
Could be the motor is going out. If it was me I'd drop the windshield and see what is going on instead of waiting for it to fail again in the rain.
This ^. It definitely sounds like the motor is on it's way out. I have replaced many a wiper motor on my many different vehicles through out the years, most of them started acting this way shortly before death.
XJ93 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome