Windshield Wiper Problem - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Wrangler Forums > YJ Wrangler Technical Forum > Windshield Wiper Problem

Introducing MONSTALINER™ UV Permanent DIY Roll On Bed LineNEW JK WRANGLER GRAB BARS NOW at ROCKRIDGE4WDSPARTAN LOCKERS are on sale BIG TIME at ROCKRIDGE 4WD!

Reply
Unread 09-30-2014, 07:57 AM   #1
flcracker
Registered User
1992 YJ Wrangler 
 
Join Date: Jun 2012
Location: Naples, FL
Posts: 606
Windshield Wiper Problem

I searched and couldn't find a problem like mine so here goes.... Wipers come on and work fine for a few minutes then gradually slow to nearly nothing. Am I looking at a ground problem or a wiper motor problem?? Something else??

__________________
Not the sharpest bulb in the box....

My Jeep is possessed with the goal of making me lose my religion....
flcracker is offline   Reply With Quote Quick reply to this message
Unread 09-30-2014, 08:52 AM   #2
Mike Romain
Registered User
1986 CJ7 
 
Join Date: Nov 2007
Location: Off the Grid in Chester Grant, Nova Scotia, Canada
Posts: 13,553
I use a booster cable from the battery negative to the motor case to verify grounds. The motor uses the hinges for a ground so adding a dedicated ground isn't a bad idea. On most, that even speeds them up.
__________________
Mike
86/00 CJ7 Laredo, 33x9.5 BFG AT's, 'glass nose to tail in '00, 'New' frame,wires and plumbing in '09. Carter BBD Carbed 4.0 HO in '10.
89 YJ Renegade. BBD Carbed 4.0 HO. Locked front and rear with 33x9.5 BFG AT's
Some Canadian Bush Jeep Runs and Build Photos: http://mikeromainjeeptrips.shutterfly.com (10 new albums added Sept 16/10)
Mike Romain is online now   Reply With Quote Quick reply to this message
Unread 09-30-2014, 10:33 AM   #3
superj
Registered User
1987 YJ Wrangler 
 
Join Date: Mar 2008
Location: corpus christi, texas
Posts: 6,594
do you have intermittent on yours, flcracker? if so, the little black box under the dash, above your left knee, could be giving you trouble also. its the control box for intermittent wipers and you can take it off and open it up and clean everything, or just take it out and connect the plugs that go into each end of it together to remove the intermittent feature
__________________
Slow ride, take it easy
superj is offline   Reply With Quote Quick reply to this message
Unread 09-30-2014, 10:34 AM   #4
flcracker
Registered User
1992 YJ Wrangler 
 
Join Date: Jun 2012
Location: Naples, FL
Posts: 606
Pulled the box out a while ago with no change.... I do need to take that thing apart and clean it up inside though... nice to have
__________________
Not the sharpest bulb in the box....

My Jeep is possessed with the goal of making me lose my religion....
flcracker is offline   Reply With Quote Quick reply to this message
Unread 09-30-2014, 05:45 PM   #5
JMickey
Registered User
1990 YJ Wrangler 
 
Join Date: Jun 2014
Location: Souderton, Pennsylvania
Posts: 74
The wiper delay box under the dash most likely has nothing to do with the problem you described. Either the ground is bad or the motor is going bad. As the motor is running heat and resistance increase on a motor that is failing, hence it slows down as it runs. Could also be lack of lubrication in the motor itself. However lubing it at this point is only delaying the inevitable if lubrication is the issue. Check the grounds.
JMickey is offline   Reply With Quote Quick reply to this message
Unread 10-01-2014, 07:23 AM   #6
JeeperDon
Patience, Grasshopper
 
JeeperDon's Avatar
1993 YJ Wrangler 
 
Join Date: Jan 2005
Location: Albuquerque, NM
Posts: 6,547
Quote:
Originally Posted by Mike Romain View Post
The motor uses the hinges for a ground so adding a dedicated ground isn't a bad idea.
That may be for a CJ Mike, but the YJ harness has a ground wire on its plug under the dash.
__________________
'93 YJ, '02 GM 4.3 Vortec V6, SOA, dual ARB's, 8.8+D30(w/WarnHubs), 4.88 gears, 35" BFG KM2's, AX15, 15x7 wheels, NP231+4:1+SYE+2LO, York OBA, Warn M8000, no top or doors Apr-Oct.
Member and Web guy: New Mexico 4 Wheelers My Truck Page on NM4W Site
JeeperDon is offline   Reply With Quote Quick reply to this message
Unread 10-01-2014, 08:45 AM   #7
Que89YJ
Web Wheeler
1989 YJ Wrangler 
 
Join Date: Apr 2008
Location: Detroit, Michigan
Posts: 15,406
Your wiper motor is going bad. There is no point in playing around, it needs to be replaced.
Que89YJ is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools






Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.