post #1 of Old 12-20-2001, 03:08 PM Thread Starter
Tony & his 91' YJ
Registered User
 
Join Date: May 2001
Location: San Antonio, TX
Posts: 31
Why ohh why did my YJ die????

Last night I was wheelin and out of nowhere my baby just died. I crank it and it does crank. Just not catching. All hoses etc. seem to be connected. Plenty of gas. After cranking for a while my battery died. Can a dead battery cause your Jeep to just completely loose power and die? I'm thinking it might be the alternator and battery that are bad? Should I just replace the battery? I tried jumping it and it still just cranks. What is the problem?!?!?!?


Tony B.
1991 Jeep Wrangler YJ
2.5 liter Herculined, 2.5” ProComp Suspension lift, 1.4” shackle lift, New Gibson Exhaust,31” Pro Comp Mud Terrain, Olympic Grill guard, Olympic Brush guard, smittybuilt nerf bars with step, Hella 550
tndboult@yahoo.com
91 YJ
/____\
{OlllllO}
[]---[]
Tony & his 91' YJ is offline  
post #2 of Old 12-20-2001, 04:37 PM
Big92Jeep
Registered User
2008 JK Wrangler 
 
Join Date: Oct 2001
Location: Sunny Florida
Posts: 109
Did you hit a big bump or drop? Or did it just die?

Well, if your alternator is dead you jeep will run off the battery juice until it drains it completely. Pull the alternator and have it tested before you spend money on a new battery or you are could be just wasting money. If it's not your alternator then we will need some more info on exactly what you were doing to figure out what happened. Big bump, water ect.


~RìCK

2008 Unlimited Rubicon
"The weather is here, I wish you were beautiful"
Big92Jeep is offline  
post #3 of Old 12-20-2001, 06:07 PM Thread Starter
Tony & his 91' YJ
Registered User
 
Join Date: May 2001
Location: San Antonio, TX
Posts: 31
No big bumps and very little water. It just quit on me on a flat part of a trail. I'll have the alternator tested and let you know the outcome. -T

Tony B.
1991 Jeep Wrangler YJ
2.5 liter Herculined, 2.5” ProComp Suspension lift, 1.4” shackle lift, New Gibson Exhaust,31” Pro Comp Mud Terrain, Olympic Grill guard, Olympic Brush guard, smittybuilt nerf bars with step, Hella 550
tndboult@yahoo.com
91 YJ
/____\
{OlllllO}
[]---[]
Tony & his 91' YJ is offline  
post #4 of Old 12-21-2001, 07:10 AM
MusicMaverick
Registered User
 
MusicMaverick's Avatar
2014 JK Wrangler 
 
Join Date: Sep 2001
Location: Santa Monica
Posts: 1,254
It sounds like your Jeep isnt getting fuel. Check your fuel lines. Sounds like a fuel pump to me. Your Battery died because you kept cranking it after it wouldnt start, and the alternator couldnt charge your battery back up because the engine wasnt running. I think your electrical system is still good, you just need to charge your battery. A good way to check is to spray some starter fluid in your carb, if it turns over just for a second, then its definately your fuel line or pump.

Currently: '14 JKU

Past vehicles: '92 YJ, '97 TJ, '10 JK
MusicMaverick is offline  
post #5 of Old 12-21-2001, 03:21 PM
Kev
Master of the Obvious
 
Kev's Avatar
 
Join Date: Jul 2001
Location: Central Utah
Posts: 688
Check to see if you are getting fuel like MusicMaverick posted. If that's okay, check for spark (but don't get yourself shocked ). If you have both, I would lean toward a timing problem; what kind of mileage do you have? Has the timing gears/chain ever been changed? I have the exact same senario (not on a Jeep) and it ended up being the timing gears were toast.

Good luck and keep us posted on what you find.

"AN ARMED SOCIETY IS A POLITE SOCIETY"

"We, too, born to freedom, and believing in freedom, are willing to fight to maintain freedom. We and all others who believe as deeply as we do, would rather die on our feet than live on our knees." FDR

Blue Jeep Club Member #4
92 Canyon Blue Wrangler YJ 4.0L - with some fun goodies
Kev is offline  
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome