What other parts to replace? - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Wrangler Forums > YJ Wrangler Technical Forum > What other parts to replace?

BLACK FRIDAY SPECIALS!! You asked, we deliver!FS: Wrangler RGB Multicolor Fog Light LEDs: Awesome EffectRockridge 4WD IS Taking Zone Offroad Suspension Lift Kits

Reply
Unread 03-08-2010, 03:22 PM   #1
mudbugII
Registered User
2006 LJ Wrangler 
 
Join Date: Apr 2004
Location: Central PA
Posts: 97
What other parts to replace?

94 YJ 2.5L. About 40k on new motor. Sporadically will NOT start. Turns over fine, fuel at rail at proper pressure, compression good on all 4 cyl. New coil, plugs, wires, distributer, coil pickup, correct voltage to coil from ecm when cranking. Checked sensor in bell housing, passes chilton's manual test. When it runs, it is perfect (for a 2.5 anyhow). I went to leave work, turned over but wouldn't start. Walked home, got truck, returned to work to pick up stuff (maybe 15 minutes later), just for hell of it, tried the key and the jeep started right up. Can't duplicate when it is at garage, have had 3 different mechanics work on it, no codes on computer. Completely random, has done it when dry, wet, hot, cold, etc. No pattern that I can find. Any suggestions?

mudbugII is offline   Reply With Quote Quick reply to this message
Unread 03-08-2010, 04:53 PM   #2
TheRealOldjeep
Registered User
1994 YJ Wrangler 
 
Join Date: Dec 2008
Location: mn
Posts: 1,477
Could be that the CPS connector is intermittant. Used to have that problem on my kids comanche. Wound up just cutting off the plugs and soldering it. Never had a problem after that.
__________________
Chuck P
94 YJ 2.5L/AW4 (Gone)
98 ZJ Limited 5.2 - sons car
97 TJ 2.5L/30RH - daughters car

www.oldjeep.com My site
TheRealOldjeep is offline   Reply With Quote Quick reply to this message
Unread 03-08-2010, 05:15 PM   #3
idaholtby
Registered User
1991 YJ Wrangler 
 
Join Date: Apr 2008
Location: Meridian, Idaho
Posts: 2,554
When this problem presents it'self,... when the ignition is first turned on, and before you go to start... Does the CEL lamp come on? It should, which would mean the ECM is powered up and then in-turn the fuel pump and ASD relay. If the CEL lamp does not light when the ign is first turned on, then likely you have bad capacitors in the ECM and it is easily/cheaply fixed. If the CEL does not initially light, will it do so if you what a spell?
idaholtby is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.