What did you do to your YJ today? - Page 2955 - JeepForum.com

 649Likes
 
LinkBack Thread Tools
post #44311 of 70309 Old 05-17-2013, 01:22 AM
Sparrows
Registered User
1995 YJ Wrangler 
 
Join Date: Dec 2012
Location: Boise
Posts: 4,473
Ok so made it home. Found a blown 15 amp fuse and replaced it with all I had on me at the time; a 30 amp. Alternator began charging again, and the speedo started moving again. But now the speedo is sluggish- it lags really bad and isn't responsive at all. Is this because of the heavier fuse that I used or is there now another problem? Anyone care to give me a crash course on what could cause this?

cheers


WARBIRD 2
EXILED OFFROAD
June '13 YJOTM
Sparrows is offline  
Sponsored Links
Advertisement
 
post #44312 of 70309 Old 05-17-2013, 02:11 AM
chilson0602
Registered User
1994 YJ Wrangler 
 
Join Date: Sep 2012
Location: Wellsboro
Posts: 142
Quote:
Originally Posted by rodgers3 View Post

how hard to replace the wheel bearings? mine squeak really bad when i use reverse...
Mine wasn't bad at all, Mine was all one piece so I took the tire off, then the 2 bolts that hold the caliper, then there are 3 bolts that hold the hub on I took those out and the axle nut and removed the hub/wheel bearing assembly and replaced it with the new one and put it all back together it was about 45 min including buying the parts
chilson0602 is offline  
post #44313 of 70309 Old 05-17-2013, 05:21 AM
grandboost98
Registered User
1989 YJ Wrangler 
 
Join Date: Aug 2010
Location: Durham/East Haven
Posts: 4,019
Garage
Quote:
Originally Posted by mattxoaaron View Post
Ordered a cab cover with door flaps from Quadratec. I tried to get a discount from them by letting them know I was a JF member, but he said "No". Anyone getting discounts from them?
The discount we get is free ground shipping and no tax

89 Wrangler-3.5" HD BDS lift,M.O.R.E HD 5/8" booms on 35" KM2s
99 Cherokee-2 door,5" lift on 35" KM2s
04 Grand Cherokee Overland
72 Chevy Nova-in progress
http://tiny.cc/BRASSBALLSOFFROAD
grandboost98 is online now  
post #44314 of 70309 Old 05-17-2013, 05:24 AM
grandboost98
Registered User
1989 YJ Wrangler 
 
Join Date: Aug 2010
Location: Durham/East Haven
Posts: 4,019
Garage
I finally got around to taking the top and full doors off! Kinda had to after swamping it yesterday, made it a lot easier to hose out lol Now I get to use my Jammock!

89 Wrangler-3.5" HD BDS lift,M.O.R.E HD 5/8" booms on 35" KM2s
99 Cherokee-2 door,5" lift on 35" KM2s
04 Grand Cherokee Overland
72 Chevy Nova-in progress
http://tiny.cc/BRASSBALLSOFFROAD
grandboost98 is online now  
post #44315 of 70309 Old 05-17-2013, 06:58 AM
Ken3783
Member
 
Ken3783's Avatar
1995 YJ Wrangler 
 
Join Date: May 2011
Location: Sitka
Posts: 341
Garage
Quote:
Originally Posted by Sparrows View Post
Ok so made it home. Found a blown 15 amp fuse and replaced it with all I had on me at the time; a 30 amp. Alternator began charging again, and the speedo started moving again. But now the speedo is sluggish- it lags really bad and isn't responsive at all. Is this because of the heavier fuse that I used or is there now another problem? Anyone care to give me a crash course on what could cause this?

cheers
Do you know which 15 amp fuse blew, IGN LPS? The alternator fuses from the stock PDC setup are 2 50amps in parallel with each other. I don't know if you have a sensor or a cable but one of those may be going out. I would check the continuity of the wiring to the cluster if you have a sensor type. If there is corrosion on any of the contacts or not properly seated, resistance will be created causing sluggish reactions if nothing at all. I would, as I'm sure you know, place a new 15 amp back in its place, with the whole fire, death, doom thing. If it blows the 15 amp again then you need to investigate why it's getting the higher amps into the fuse to begin with. The higher amp fuse, being designed differently, could, as it heats up, cause a higher resistance as it designed to run hotter than it's lower amp brother. Also your fuel pump is run off that IGN LPS fuse, so maybe see if that kicks in right away when you cycle the key. Hope that helps some.

'95 Wrangler YJ: http://www.jeepforum.com/forum/f22/m...rship-1481851/
'98 Cherokee XJ: http://www.jeepforum.com/forum/f22/k...41/index2.html
'07 Grand Cherokee WK ("No Mods"-The Wife)
Ken3783 is offline  
post #44316 of 70309 Old 05-17-2013, 07:48 AM
mattxoaaron
Registered User
1993 YJ Wrangler 
 
Join Date: Sep 2012
Location: Great Falls
Posts: 39
Quote:
Originally Posted by grandboost98 View Post
The discount we get is free ground shipping and no tax
Is there a secret code He said because I was Military I could get 5% off if I went back to my office, sent him an email from a government computer, waited for his reply and than used his code. I didn't have that much time.

All stock 2016 Sahara
mattxoaaron is offline  
post #44317 of 70309 Old 05-17-2013, 08:17 AM
grandboost98
Registered User
1989 YJ Wrangler 
 
Join Date: Aug 2010
Location: Durham/East Haven
Posts: 4,019
Garage
Quote:
Originally Posted by mattxoaaron View Post
Is there a secret code He said because I was Military I could get 5% off if I went back to my office, sent him an email from a government computer, waited for his reply and than used his code. I didn't have that much time.
The first few times I ordered from them, I just told them I was a paying member(my membership just ran out, waiting to renew) and that was it. After like 4 or 5 times they just put it on my account so it automatically does it now even if I order online

89 Wrangler-3.5" HD BDS lift,M.O.R.E HD 5/8" booms on 35" KM2s
99 Cherokee-2 door,5" lift on 35" KM2s
04 Grand Cherokee Overland
72 Chevy Nova-in progress
http://tiny.cc/BRASSBALLSOFFROAD
grandboost98 is online now  
post #44318 of 70309 Old 05-17-2013, 08:21 AM
Anticanman
RIP one good jeeper
 
Anticanman's Avatar
1994 YJ Wrangler 
 
Join Date: Aug 2009
Location: Ripon
Posts: 20,368
Contact them in tr vendor section of this site. They'll probably give you a coupon code

Luck Favours The Prepared
Anticanman is offline  
post #44319 of 70309 Old 05-17-2013, 09:07 AM
remmons
Web Wheeler
 
remmons's Avatar
2015 KL Cherokee 
 
Join Date: Mar 2010
Location: Vernal
Posts: 2,771
Garage
Quote:
Originally Posted by juicyj View Post
Or you can simply check your camera options and change the pixel size.

love my jeep
Very true. I guess that I had overlooked the simple.

Robert.

2015 Cherokee Trailhawk V6.
remmons is offline  
post #44320 of 70309 Old 05-17-2013, 10:11 AM
juicyj
Registered User
1988 YJ Wrangler 
 
Join Date: Feb 2012
Location: Winston Salem
Posts: 641
Quote:
Originally Posted by remmons View Post

Very true. I guess that I had overlooked the simple.
Is always easy to forget, I replaced the radiator, thermostat, water pump, temp sensor, and a few other things in my wifes car. Then I realized it was over heating due to a lose hose. DOHHHHH. *bang head on desk*.

love my jeep

Don't wait on the storm to pass, learn to wheel in the rain.
juicyj is offline  
post #44321 of 70309 Old 05-17-2013, 10:53 AM
grandboost98
Registered User
1989 YJ Wrangler 
 
Join Date: Aug 2010
Location: Durham/East Haven
Posts: 4,019
Garage
Took it out on lunch break



Noticed I have a hesitation if I punch the throttle. Drives normal otherwise, maybe even a little peppier. Any ideas?

89 Wrangler-3.5" HD BDS lift,M.O.R.E HD 5/8" booms on 35" KM2s
99 Cherokee-2 door,5" lift on 35" KM2s
04 Grand Cherokee Overland
72 Chevy Nova-in progress
http://tiny.cc/BRASSBALLSOFFROAD
grandboost98 is online now  
post #44322 of 70309 Old 05-17-2013, 11:04 AM
Anticanman
RIP one good jeeper
 
Anticanman's Avatar
1994 YJ Wrangler 
 
Join Date: Aug 2009
Location: Ripon
Posts: 20,368
I think its the elephants trunk that's causing the hesitation.

Luck Favours The Prepared
Anticanman is offline  
post #44323 of 70309 Old 05-17-2013, 11:08 AM
squishy
Registered User
1992 YJ Wrangler 
 
Join Date: Mar 2012
Location: JBMDL
Posts: 1,758
Quote:
Originally Posted by Anticanman
I think its the elephants trunk that's causing the hesitation.
Haha.

Did you upgrade the injectors?

Quote:
Originally Posted by Luuca View Post
Gratitude and Gold both start with G and are just as rare.
squishy is offline  
post #44324 of 70309 Old 05-17-2013, 11:08 AM
grandboost98
Registered User
1989 YJ Wrangler 
 
Join Date: Aug 2010
Location: Durham/East Haven
Posts: 4,019
Garage
The elephants trunk has been there for over a year now though and has saved me a few times already, so its not going anywhere lol besides, I noticed no difference in power, good or bad, after installing the snorkel.



Quote:
Haha.

Did you upgrade the injectors?
Nope

89 Wrangler-3.5" HD BDS lift,M.O.R.E HD 5/8" booms on 35" KM2s
99 Cherokee-2 door,5" lift on 35" KM2s
04 Grand Cherokee Overland
72 Chevy Nova-in progress
http://tiny.cc/BRASSBALLSOFFROAD
grandboost98 is online now  
post #44325 of 70309 Old 05-17-2013, 11:08 AM
Sparrows
Registered User
1995 YJ Wrangler 
 
Join Date: Dec 2012
Location: Boise
Posts: 4,473
Quote:
Originally Posted by Ken3783 View Post
Do you know which 15 amp fuse blew, IGN LPS? The alternator fuses from the stock PDC setup are 2 50amps in parallel with each other. I don't know if you have a sensor or a cable but one of those may be going out. I would check the continuity of the wiring to the cluster if you have a sensor type. If there is corrosion on any of the contacts or not properly seated, resistance will be created causing sluggish reactions if nothing at all. I would, as I'm sure you know, place a new 15 amp back in its place, with the whole fire, death, doom thing. If it blows the 15 amp again then you need to investigate why it's getting the higher amps into the fuse to begin with. The higher amp fuse, being designed differently, could, as it heats up, cause a higher resistance as it designed to run hotter than it's lower amp brother. Also your fuel pump is run off that IGN LPS fuse, so maybe see if that kicks in right away when you cycle the key. Hope that helps some.
It didn't blow one of the under dash, labeled circuits. I checked them all and they were all fine, including IGN LPS fuse. This morning I replaced the blown fuse with the correct amperage one.
Here's a pic of the block that contained the fuse that blew...


And here's my main block


I believe my speedo is cable driven. I'm still confused as to how it would become sluggish and unresponsive at the same time the fuse problem cropped up. It was working fine earlier yesterday so I'm fairly certain it's not corrosion, build up, or a busted cable or anything like that.

I'm also pretty sure that the reason that fuse blew is because it's some how tied to the circuit that I wired my fan into. I'll be moving the fan to it's own, dedicated circuit today to prevent future issues.

Still confused on the speedo though. :
Thanks and,
Cheers

WARBIRD 2
EXILED OFFROAD
June '13 YJOTM
Sparrows is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 4 (3 members and 1 guests)
bruinjeeper , campbell990 , ThatGuyCollin
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
I had fun today! Burnerman YJ Wrangler Technical Forum 9 06-18-2014 06:12 PM
Not a good day today. :( CHRRRIS TJ Wrangler Technical Forum 35 09-17-2013 02:39 PM
what i did to my tj today? shovelhead Wrangler General Discussion 6 11-05-2012 12:22 PM
Hit by Bus Today Cooneys08JK JK Wrangler Technical Forum 32 01-07-2012 03:30 PM
New today AZGreenMonster YJ Wrangler Technical Forum 7 09-02-2010 07:52 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome