Went into the river and died - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Wrangler Forums > YJ Wrangler Technical Forum > Went into the river and died

Don't forget the Jeep Forum discount, 10% off!Ruffstuff Axle Simple Swap Kit!The Original 3/8" Ruffstuff Diff Cover!

Reply
Unread 01-14-2014, 04:52 PM   #1
Eagosspr
Registered User
 
Join Date: Jan 2014
Location: San Juan, Puerto Rico
Posts: 3
Went into the river and died

Greeting from PR fellow Jeepers!!!

Last weekend my friend and I went offroading and
I went to cross a river and before I knew it my Wrangler 1995 stalled...
We took it out and everything was okay enginewise.
The problem was there was no electricity running thru the jeep I we have been
Killing ourselves trying to fix it and we wonder if it could be
the ECU any opinions???
Any help would be great!!!
Thanks

Eagosspr is offline   Reply With Quote Quick reply to this message
Unread 01-14-2014, 07:05 PM   #2
kloppk
Registered User
1992 YJ Wrangler 
 
Join Date: Oct 2006
Location: Massachusetts
Posts: 2,716
You say "no electricity"
Does anything work? Headlights? Brake Lights?
Do any of the dash idiot lights go on when you turn the key to from Off to Run?
__________________
Baystate Jeepers
Deep Woods Extreme
New England 4 Wheelers
kloppk is offline   Reply With Quote Quick reply to this message
Unread 01-15-2014, 12:06 AM   #3
plumber1
Registered User
2005 TJ Wrangler 
 
Join Date: Jan 2007
Location: San Ramon, CA
Posts: 2,199
Anything like this


__________________
I can quite drinking anytime I want, but hey I'm no quitter :)


White Jeep Club #224
plumber1 is offline   Reply With Quote Quick reply to this message
Unread 01-15-2014, 12:07 AM   #4
plumber1
Registered User
2005 TJ Wrangler 
 
Join Date: Jan 2007
Location: San Ramon, CA
Posts: 2,199
__________________
I can quite drinking anytime I want, but hey I'm no quitter :)


White Jeep Club #224
plumber1 is offline   Reply With Quote Quick reply to this message
Unread 01-15-2014, 04:17 AM   #5
Eagosspr
Registered User
 
Join Date: Jan 2014
Location: San Juan, Puerto Rico
Posts: 3
Kloppk
Yes no electricity what so ever!!! No brake , dash light nothing! And the batterry is 100% brand new optima.
Plumber1
Yes exactly luke that maybe 2-3 more inches higher...
Eagosspr is offline   Reply With Quote Quick reply to this message
Unread 01-15-2014, 07:30 AM   #6
jaycal3
Registered User
1993 YJ Wrangler 
 
Join Date: Mar 2009
Location: , Ct
Posts: 1,118
You went through that much water and didnt hydrolock? You say everything was "ok engine wise"... what did you check? I cant imagine you not getting water in the engine unless you are snorkled... I would assume you got water in a lot of electical parts that dont play nice with water.
__________________
93 YJ, 6 cyl,3.5" BDS,1" Prothane BL,1/2" booms

KCCO
jaycal3 is offline   Reply With Quote Quick reply to this message
Unread 01-15-2014, 02:49 PM   #7
Eagosspr
Registered User
 
Join Date: Jan 2014
Location: San Juan, Puerto Rico
Posts: 3
No water in the engine for sure and im just guessing but can the ECU be fried?
Eagosspr is offline   Reply With Quote Quick reply to this message
Unread 01-15-2014, 05:30 PM   #8
bigbossd1030
Registered User
1995 YJ Wrangler 
 
Join Date: Feb 2010
Location: Edmonton, AB, Alberta
Posts: 2,515
Did you pull the plugs and check the cylinders? The dist doesn't react to water very well.
And it is possible the ecu got messed up. That much water and I'm just guessing nothing is siliconed under the good right? If you haven't pulled the plugs yet, do so.
__________________
[COLOR="DarkGreen"]/l ,[____],
l----L-[]lllllll[]-
()_)-()_)--o)_)[/COLOR]
[COLOR="Blue"]OFFICIAL JEEPER[/COLOR]
[COLOR="Red"]Any Jeepers in Edmonton, AB
I am on channel 33.[/COLOR]
I live, I ride, I am JEEP.
bigbossd1030 is offline   Reply With Quote Quick reply to this message
Unread 01-15-2014, 05:35 PM   #9
Mobile_Homie
Desert Rat
 
Mobile_Homie's Avatar
1994 YJ Wrangler 
 
Join Date: Jun 2008
Location: Winnemucca, NV
Posts: 1,289
Quote:
Originally Posted by jaycal3 View Post
You went through that much water and didnt hydrolock? You say everything was "ok engine wise"... what did you check? I cant imagine you not getting water in the engine unless you are snorkled... I would assume you got water in a lot of electical parts that dont play nice with water.
I dunno, although I have never been that deep, I have looked at the air cleaner intake and I thought it looked good go up to the top of the fenders...
Imma go look again.
__________________
Mark



Smoke em if you got em!

Click here
Mobile_Homie is online now   Reply With Quote Quick reply to this message
Unread 01-15-2014, 05:37 PM   #10
bigbossd1030
Registered User
1995 YJ Wrangler 
 
Join Date: Feb 2010
Location: Edmonton, AB, Alberta
Posts: 2,515
Quote:
Originally Posted by Mobile_Homie
I dunno, although I have never been that deep, I have looked at the air cleaner intake and I thought it looked good go up to the top of the fenders... Imma go look again.
the hole is at the bottom of the box. I believe it's just below the headlight or level with it.
__________________
[COLOR="DarkGreen"]/l ,[____],
l----L-[]lllllll[]-
()_)-()_)--o)_)[/COLOR]
[COLOR="Blue"]OFFICIAL JEEPER[/COLOR]
[COLOR="Red"]Any Jeepers in Edmonton, AB
I am on channel 33.[/COLOR]
I live, I ride, I am JEEP.
bigbossd1030 is offline   Reply With Quote Quick reply to this message
Unread 01-15-2014, 08:13 PM   #11
YJ475
Registered User
1993 YJ Wrangler 
 
Join Date: Feb 2012
Location: Mapleton, UT
Posts: 296
Did you check the battery connections? What about the ground connector on the engine block?
YJ475 is offline   Reply With Quote Quick reply to this message
Unread 01-16-2014, 09:07 AM   #12
Que89YJ
Web Wheeler
1989 YJ Wrangler 
 
Join Date: Apr 2008
Location: Detroit, Michigan
Posts: 15,416
No power to anything is the battery connection. Remember that your ground is every bit as important as the power so check it and make sure its good. You can use a set of jumper cables to bridge the battery to the PDC and the battery to ground.
Que89YJ is online now   Reply With Quote Quick reply to this message
Unread 01-16-2014, 10:18 PM   #13
JohnnyZJ
Web Wheeler
 
JohnnyZJ's Avatar
1992 YJ Wrangler 
 
Join Date: Oct 2008
Location: Calgary
Posts: 2,306
like these guys said.
sounds battery
__________________
92 YJ ~ locked rollin' on 35s
05' WK Hemi limited ~ wifey mobile
13' Chevy Cruze ~ boo
13' GMC Sierra ~ 2.5" lift 33" MTs.
RIP 95 ZJ ~ 33s built/longarmed/locked/awesome Feb 2014 ZJOTM winner
JohnnyZJ is offline   Reply With Quote Quick reply to this message
Reply

Tags
1995 , ecu , electrical issue , water damage , wrangler

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools






Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.