vacuum problems -

LinkBack Thread Tools
post #1 of 3 Old 01-26-2010, 03:48 PM Thread Starter
Registered User
Join Date: Mar 2009
Location: Alfred
Posts: 21
vacuum problems

having a wierd issue with the 2.5l engine. We had to swap another 4cyl in it cause we blew the other well we weren' that smart and didn't mark anything. We have it pretty close but it idles rough. When i unhook the ccv valve line it'll idle up and idle normal. Shouldn't this be the opposite? anybody have any ideas of what could be going on?

Bryan01702 is offline  
Sponsored Links
post #2 of 3 Old 01-26-2010, 04:37 PM
Registered User
1989 YJ Wrangler 
Join Date: Dec 2009
Location: clinton twp mi
Posts: 345
That is weird, do you mean the pcv valve? If so, reinsert the pcv valve and remove the oil filler cap. does it smooth out? Is the pcv valve good? this will at least tell you if its becaause of the pcv valve or the crank case presure.

I recently swapped motors in mine with one that sat for some time and the rings were stuck from sitting. So I remoived the plugs and shot some tranny fluid down into the cylinders and let it soak for a while .5 hour. then ran it some more. Let it heat up and then let it sit. after a while they free'd up and it ran smooth. I dont know if this is your problem, just something to concider.
yj98joe is offline  
post #3 of 3 Old 01-26-2010, 06:56 PM Thread Starter
Registered User
Join Date: Mar 2009
Location: Alfred
Posts: 21
no i guess in 91 they started calling it the ccv valve. wierd.
Bryan01702 is offline  

Quick Reply

Register Now

In order to be able to post messages on the forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page

Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
Vacuum Disconnect Problems Alabamaranger YJ Wrangler Technical Forum 7 02-04-2010 02:25 PM
'88 4.2 carb vacuum problems jeepbro's YJ Wrangler Technical Forum 6 04-22-2007 06:23 AM
vacuum line problems tonyk YJ Wrangler Technical Forum 6 07-31-2005 01:00 PM
vacuum problems wdc YJ Wrangler Technical Forum 5 04-18-2005 10:00 AM
4wd problems with vacuum system jeep75 YJ Wrangler Technical Forum 2 09-19-2004 07:43 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome