Under powered 95 yj with a 2.5L - Page 7 - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Wrangler Forums > YJ Wrangler Technical Forum > Under powered 95 yj with a 2.5L

Dual Color LED Light Bars White/AmberTJ 5.25" Speaker Adapters - NalinMFGAlloy USA Still Available

Reply
Unread 02-11-2014, 01:23 PM   #91
Firemandan
Registered User
1979 CJ7 
 
Join Date: Nov 2010
Location: McCalla, Alabama
Posts: 182
Yeah Que, still have a very hard start.

I haven't replaced the tps but I have replaced the O2 sensor.

__________________
[FONT="Impact"][SIZE="4"][COLOR="Black"]195? M38
1979 CJ7
1995 YJ [/COLOR][/SIZE][/FONT]
Firemandan is offline   Reply With Quote
Unread 02-11-2014, 01:25 PM   #92
Que89YJ
Web Wheeler
1989 YJ Wrangler 
 
Join Date: Apr 2008
Location: Detroit, Michigan
Posts: 14,546
The tps does fit but I thought you checked it?
Que89YJ is offline   Reply With Quote
Unread 02-11-2014, 01:29 PM   #93
Firemandan
Registered User
1979 CJ7 
 
Join Date: Nov 2010
Location: McCalla, Alabama
Posts: 182
No, I haven't touched the tps , never seen a code for it so I thought it was ok.
I might as well replace it and see what happens.
__________________
[FONT="Impact"][SIZE="4"][COLOR="Black"]195? M38
1979 CJ7
1995 YJ [/COLOR][/SIZE][/FONT]
Firemandan is offline   Reply With Quote
Unread 02-11-2014, 01:43 PM   #94
Firemandan
Registered User
1979 CJ7 
 
Join Date: Nov 2010
Location: McCalla, Alabama
Posts: 182
TPS is on the way, gotta work tomorrow, I'll pick it up Thursday morning and see what happens and report back.
__________________
[FONT="Impact"][SIZE="4"][COLOR="Black"]195? M38
1979 CJ7
1995 YJ [/COLOR][/SIZE][/FONT]
Firemandan is offline   Reply With Quote
Unread 02-11-2014, 02:22 PM   #95
bhamdan
Registered User
1992 YJ Wrangler 
 
Join Date: Jan 2011
Location: bessemer, alabama
Posts: 229
Quote:
Originally Posted by Firemandan View Post
TPS is on the way, gotta work tomorrow, I'll pick it up Thursday morning and see what happens and report back.
If the screws for your TPS are rusted like mine were, you will have a good time getting them out. I used a small ratcheting screwdriver if I remember correctly. I should have replaced the rusty screws but was in a hurry.
bhamdan is offline   Reply With Quote
Unread 02-13-2014, 08:16 AM   #96
Firemandan
Registered User
1979 CJ7 
 
Join Date: Nov 2010
Location: McCalla, Alabama
Posts: 182
ok, unhooked the battery, replaced the TPS, hooked the battery back up and fired her up.
Still hard to start and still cutting out at 3000rpms.
__________________
[FONT="Impact"][SIZE="4"][COLOR="Black"]195? M38
1979 CJ7
1995 YJ [/COLOR][/SIZE][/FONT]
Firemandan is offline   Reply With Quote
Unread 02-13-2014, 08:32 AM   #97
Que89YJ
Web Wheeler
1989 YJ Wrangler 
 
Join Date: Apr 2008
Location: Detroit, Michigan
Posts: 14,546
Can you post a video of it cutting out? I want to see exactly what you are dealing with. Post up a link to the video.
Que89YJ is offline   Reply With Quote
Unread 02-13-2014, 08:50 AM   #98
Firemandan
Registered User
1979 CJ7 
 
Join Date: Nov 2010
Location: McCalla, Alabama
Posts: 182
I'll see what I can do
__________________
[FONT="Impact"][SIZE="4"][COLOR="Black"]195? M38
1979 CJ7
1995 YJ [/COLOR][/SIZE][/FONT]
Firemandan is offline   Reply With Quote
Unread 02-13-2014, 10:21 AM   #99
bhamdan
Registered User
1992 YJ Wrangler 
 
Join Date: Jan 2011
Location: bessemer, alabama
Posts: 229
I wonder if its the PCM... too bad I sold my spare. I also have a 2.5.
bhamdan is offline   Reply With Quote
Unread 02-13-2014, 12:44 PM   #100
bmw328rh
Registered User
1993 YJ Wrangler 
 
Join Date: Feb 2014
Location: warminster, pa
Posts: 2
did you check timing? it could be the timing is off that happened to me in a saturn and ended up bending most of the valves. but ill tell you one thing in my buddies 2.5 he was having the same sluggish problems and one night it wouldn't start. sounding like a fuel problem i banged on the tank and it started right up. after he took it home he had called me and said that it was running on full power again. my thoughts on that were theres was a lot pf debris and dirt in the sock of the fuel pump and when i banged on the tank with the hammer it shifted the dirt around away from the sock and let the pump suck up the correct amount of fuel again. so i would check your fuel pump sock to see if it is clogged up and if it is try and clean the tank out best as possible put a new sock on it and see what happens.
bmw328rh is offline   Reply With Quote
Unread 02-13-2014, 02:11 PM   #101
Why J?
Registered User
1993 YJ Wrangler 
 
Join Date: Sep 2004
Location: Knoxville Tn
Posts: 3,437
For a $90 diag charge a Jeep dealer will most likely be able to tell you exactly what is wrong with it in an hour or so.

Or you can keep throwing parts at it.
__________________
New Project "Pissed Wife"

http://www.jeepforum.com/forum/f22/project-pissed-wife-747535/
Phase II 5.3L/4L60e then NV3550
http://www.jeepforum.com/forum/f22/p...stall-1400506/
Why J? is offline   Reply With Quote
Unread 02-13-2014, 03:18 PM   #102
Que89YJ
Web Wheeler
1989 YJ Wrangler 
 
Join Date: Apr 2008
Location: Detroit, Michigan
Posts: 14,546
I just watched the video. It is a misfire at 3000 rpm. Have you done anything to the distributor before this started? That it's a spark timing issue for sure.
Que89YJ is offline   Reply With Quote
Unread 02-13-2014, 06:05 PM   #103
Firemandan
Registered User
1979 CJ7 
 
Join Date: Nov 2010
Location: McCalla, Alabama
Posts: 182
I did buy a kit that had a coil, distributor cap, rotor and plug wires. That's the only things I've done with that stuff.
__________________
[FONT="Impact"][SIZE="4"][COLOR="Black"]195? M38
1979 CJ7
1995 YJ [/COLOR][/SIZE][/FONT]
Firemandan is offline   Reply With Quote
Unread 02-13-2014, 07:14 PM   #104
bhamdan
Registered User
1992 YJ Wrangler 
 
Join Date: Jan 2011
Location: bessemer, alabama
Posts: 229
have you changed the plugs? one of mine was crushed to where there was no gap when i bought it.
bhamdan is offline   Reply With Quote
Unread 02-13-2014, 07:22 PM   #105
Firemandan
Registered User
1979 CJ7 
 
Join Date: Nov 2010
Location: McCalla, Alabama
Posts: 182
Yeah, when put the motor together I put in those big gap platinum plugs but I've changed them out for champion copper plugs
__________________
[FONT="Impact"][SIZE="4"][COLOR="Black"]195? M38
1979 CJ7
1995 YJ [/COLOR][/SIZE][/FONT]
Firemandan is offline   Reply With Quote
Reply
Thread Tools






Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.