Under powered 95 yj with a 2.5L - Page 5 - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Wrangler Forums > YJ Wrangler Technical Forum > Under powered 95 yj with a 2.5L

** FALL SALE on all Jeep Optic Armor Windshields **Introducing MONSTALINERô UV Permanent DIY Roll On Bed Line~Artec JK 1 TON SWAP~

Reply
Unread 02-07-2014, 10:29 AM   #61
Firemandan
Registered User
1979 CJ7 
 
Join Date: Nov 2010
Location: McCalla, Alabama
Posts: 182
ok, ill go and get another one, just replaced it last week or the week before.

__________________
[FONT="Impact"][SIZE="4"][COLOR="Black"]195? M38
1979 CJ7
1995 YJ [/COLOR][/SIZE][/FONT]
Firemandan is offline   Reply With Quote Quick reply to this message
Unread 02-07-2014, 10:41 AM   #62
Que89YJ
Web Wheeler
1989 YJ Wrangler 
 
Join Date: Apr 2008
Location: Detroit, Michigan
Posts: 15,425
I remember. it should be under warranty. Weird that you get that fault immeadiately after replacing the air temp sensor. The readings were good on both. It makes no sense.
Que89YJ is offline   Reply With Quote Quick reply to this message
Unread 02-07-2014, 12:28 PM   #63
ronniez
Registered User
1995 YJ Wrangler 
 
Join Date: Aug 2010
Location: hewlett, NY
Posts: 126
your capacitors on your ecm may be going, i had similar symptoms when the weather was cold and when i changed my ecm they went away. a lot of people just replace the capacitors in the ecm and that helps too search brain surgery in the forum and you will find that. btw when you turn the key before firing her up does the check engine light come right on , if it doesnt then its definately yout ecm
ronniez is offline   Reply With Quote Quick reply to this message
Unread 02-07-2014, 12:58 PM   #64
Firemandan
Registered User
1979 CJ7 
 
Join Date: Nov 2010
Location: McCalla, Alabama
Posts: 182
ok, I have a coolant temp sensor on the way, should be here in the morning, I did get a noid light test set.
I'm gonna try the noid light after I get the ect sensor put in and see what I can find out in the injectors.
__________________
[FONT="Impact"][SIZE="4"][COLOR="Black"]195? M38
1979 CJ7
1995 YJ [/COLOR][/SIZE][/FONT]
Firemandan is offline   Reply With Quote Quick reply to this message
Unread 02-07-2014, 01:18 PM   #65
Que89YJ
Web Wheeler
1989 YJ Wrangler 
 
Join Date: Apr 2008
Location: Detroit, Michigan
Posts: 15,425
Really curious to see if the injectors are dropping out.How much was the nod light?
Que89YJ is offline   Reply With Quote Quick reply to this message
Unread 02-07-2014, 01:20 PM   #66
Firemandan
Registered User
1979 CJ7 
 
Join Date: Nov 2010
Location: McCalla, Alabama
Posts: 182
Ronniez, that's what I'm afraid of, being the ECM. I did some checking on the prices, $195 for rebuild and lifetime warranty.
When I turn the key , the CEL does come on.
__________________
[FONT="Impact"][SIZE="4"][COLOR="Black"]195? M38
1979 CJ7
1995 YJ [/COLOR][/SIZE][/FONT]
Firemandan is offline   Reply With Quote Quick reply to this message
Unread 02-07-2014, 01:21 PM   #67
Firemandan
Registered User
1979 CJ7 
 
Join Date: Nov 2010
Location: McCalla, Alabama
Posts: 182
I Got a 10 piece kit at advanced for 29.99
__________________
[FONT="Impact"][SIZE="4"][COLOR="Black"]195? M38
1979 CJ7
1995 YJ [/COLOR][/SIZE][/FONT]
Firemandan is offline   Reply With Quote Quick reply to this message
Unread 02-08-2014, 01:45 PM   #68
Firemandan
Registered User
1979 CJ7 
 
Join Date: Nov 2010
Location: McCalla, Alabama
Posts: 182
OK Que, installed the new ECT sensor, hooked up the battery and fired her up and hooked up the noid light, wife sat in the seat and had her throttle up to 3000rpms, as soon as I hooked up the noid light it was flashing like a strobe. Light never went out, even when it was in the bad zone at 3000. did the same thing on all cylinders none of the injectors cut out.
Wife said as soon as I unhooked the first injector the check engine light came on. I checked the codes and it showed code 27, pretty sure its from being unhooked but that all I have for now.
__________________
[FONT="Impact"][SIZE="4"][COLOR="Black"]195? M38
1979 CJ7
1995 YJ [/COLOR][/SIZE][/FONT]
Firemandan is offline   Reply With Quote Quick reply to this message
Unread 02-08-2014, 01:48 PM   #69
Firemandan
Registered User
1979 CJ7 
 
Join Date: Nov 2010
Location: McCalla, Alabama
Posts: 182
just an observation from my wife. All the sensors I got from advanced are the ones that I've had to replace. Don't wanna ruffle any feathers but just food for thought.
__________________
[FONT="Impact"][SIZE="4"][COLOR="Black"]195? M38
1979 CJ7
1995 YJ [/COLOR][/SIZE][/FONT]
Firemandan is offline   Reply With Quote Quick reply to this message
Unread 02-08-2014, 03:08 PM   #70
bedwards24676
Registered User
1993 YJ Wrangler 
 
Join Date: Feb 2013
Location: Brewton, Al
Posts: 262
Have you tried unplugging 1 injector at a time while the jeep is idling. Just a suggestion. As you unplug one it should affect your idle. Plug it back up and move on to another one. If you get to one that doesn't make a change in idle. You have found your problem. 5 min test that might be worth your time.
bedwards24676 is offline   Reply With Quote Quick reply to this message
Unread 02-08-2014, 04:13 PM   #71
Que89YJ
Web Wheeler
1989 YJ Wrangler 
 
Join Date: Apr 2008
Location: Detroit, Michigan
Posts: 15,425
You have done fuel pressure and the injectors are not cutting out then the issue has to be with the timing control side of things. We are getting close.
Que89YJ is offline   Reply With Quote Quick reply to this message
Unread 02-08-2014, 05:56 PM   #72
Firemandan
Registered User
1979 CJ7 
 
Join Date: Nov 2010
Location: McCalla, Alabama
Posts: 182
Bedwards, it idles fine with no problems, It's a hard crank and when it get to 3000rpms it's like it hits a rev limiter, spits and sputters and drops power.
__________________
[FONT="Impact"][SIZE="4"][COLOR="Black"]195? M38
1979 CJ7
1995 YJ [/COLOR][/SIZE][/FONT]
Firemandan is offline   Reply With Quote Quick reply to this message
Unread 02-08-2014, 06:12 PM   #73
bedwards24676
Registered User
1993 YJ Wrangler 
 
Join Date: Feb 2013
Location: Brewton, Al
Posts: 262
Quote:
Originally Posted by Firemandan
Bedwards, it idles fine with no problems, It's a hard crank and when it get to 3000rpms it's like it hits a rev limiter, spits and sputters and drops power.
I've been following your thread and Stick with Que he will help you find it. It's just very similar to the problems I'm having. After a lot of trouble shooting and replacing some sensors. I did the unplug injector test. To find out I'm only running on 3 cyls. Misfiring when I get to 3000 RPMS and no power. My injectors are firing but nothing is getting through my #4 injector. Unplugging them was the only way I would have found out. Like I said they were all firing. Que will stick with you and y'all will figure it out. It was just a quick suggestion. Good luck.
bedwards24676 is offline   Reply With Quote Quick reply to this message
Unread 02-08-2014, 06:14 PM   #74
bedwards24676
Registered User
1993 YJ Wrangler 
 
Join Date: Feb 2013
Location: Brewton, Al
Posts: 262
And also mine idles perfectly even only running on 3 cyls. I know that doesn't sound possible but it is. Good luck.
bedwards24676 is offline   Reply With Quote Quick reply to this message
Unread 02-08-2014, 06:51 PM   #75
Overhead
You built a 4cyl?
 
Overhead's Avatar
1995 YJ Wrangler 
 
Join Date: May 2011
Location: Sterling, Virginia
Posts: 1,327
Quote:
Originally Posted by bedwards24676 View Post
And also mine idles perfectly even only running on 3 cyls. I know that doesn't sound possible but it is. Good luck.
x2, you'll only hear it at some rpm if its only running 3 cyl
Overhead is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools






Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.