JeepForum.com

JeepForum.com (http://www.jeepforum.com/forum/)
-   YJ Wrangler Technical Forum (http://www.jeepforum.com/forum/f12/)
-   -   Under powered 95 yj with a 2.5L (http://www.jeepforum.com/forum/f12/under-powered-95-yj-2-5l-2030385/)

Firemandan 01-23-2014 10:19 PM

Under powered 95 yj with a 2.5L
 
Ok Folks, as some of you know, I've just finished with my 95 yj to use as a daily driver. As I took it out for it's victory drive around the community, I noticed it was VERY under powered. It's a rebuilt 2.5L, 5 speed with 31" tires. She's real slow on take off. RPM's are pretty low " I think they are low"
I'm not an expert. I have to drop down to 2nd for some of the small inclines in the area. on flat road, I can get it up to 48-52MPH and that's as fast as I have gotten her. Just asking what could it be?
Is it gears?
a sensor?
the moon not being aligned with mars?
Help please

Firemandan 01-23-2014 10:21 PM

OH one of the most important things...........stock 4:10 gears

Que89YJ 01-24-2014 04:16 AM

Start with your codes.
http://www.jeepforum.com/forum/f12/h...codes-1257145/

Jeepsr4me 01-24-2014 08:24 AM

Yeah computer could be gone or exhaust is stopped up.. Many things. But these little engines like to rev, so that should not be a issue.

EABiker 01-24-2014 11:15 AM

Does it run the same cold as it does when warmed up? The sensors really only come in to play after it reaches operating temperature. I would first look for a vacuum leak, especially around the intake manifold.

Firemandan 01-25-2014 07:36 AM

EAB, it runs the same at operating temp as it does cold.
I'm at the station today so I'm gonna check the codes out tomorrow when I get home.
I should mention that I do have a screaming demon coil and live wires with big gap plugs on it, just thought I should mention that.
Also, she's VERY cold natured, takes a bit to get her to start and after she's been run for a bit and sits for a few minutes she is slow to start.
Not sure if it could be a timing issue, what do y'all think?

Jeepsr4me 01-25-2014 08:16 AM

check your fuel pressure

Firemandan 01-25-2014 08:36 AM

Thanks jeeps, I'll check that in the morning.

Good thought.

Que89YJ 01-25-2014 09:18 AM

Fuel pressure. 31 psi drinking. 39 psi after disconnecting the pressure regulator vacuum hose. Turn the key off. Pressure should stay above 20 for 20

plumber1 01-25-2014 10:00 AM

It's not gears, when my 2.5 YJ was on 31's I could go 65+ on the freeway on the flats w/o much problem. Now when I got to inclines it did suffer but never on the flats, it's no racer but I agree with the others you have something else going wrong.

flcracker 01-25-2014 10:14 AM

2.5, 5 spd, 4.10's and it gets up and goes just fine.... only had it on the Interstate once and it did 70, took a while to get there but it did 70....

edit: this was on 31's

Kowalski 01-25-2014 02:19 PM

Maybe it's the catalytic converter? Mine was stopped up and felt sluggish.

Firemandan 01-25-2014 02:30 PM

I put a new exhaust system on it, not saying it couldn't be the cat but Ill check.

Que89YJ 01-25-2014 07:42 PM

Fault codes?

Firemandan 01-25-2014 08:27 PM

Que, I haven't ran the codes yet, gonna do it in the morning when I get home.


The time now is 03:13 AM.

Powered by vBulletin Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.