Turn signal wiring problem - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Wrangler Forums > YJ Wrangler Technical Forum > Turn signal wiring problem

Artec Holiday Sale!Bead Lock Wheels! Raceline, Trail Ready, & Trail-GearROCKRIDGE4WD Introduces a NEW Jeep Wrangler JK *led* tail

Reply
Unread 03-02-2013, 05:05 PM   #1
silversldr
Registered User
 
Join Date: Mar 2013
Location: Woodhaven, MI
Posts: 2
Turn signal wiring problem

The drivers side rear turn signal doesn't operate as well as the brake light. Reverse is good.

While in the process of tracing wires, passenger side quit working altogether and now the reverse lights on drivers side has quit working. When operating the turn signals to check for operation the drivers side dash indicator works with the front light winking and blinking. The passenger side is steady. I have verified the fuses are in good shape.

Do I have 2 issues here or is this just one large one. I am at a loss of what to do outside of ripping out all the wires and running fresh wires.

Any help would be appreciated

silversldr is offline   Reply With Quote Quick reply to this message
Unread 03-02-2013, 05:54 PM   #2
Mark05059
Registered User
1989 YJ Wrangler 
 
Join Date: Mar 2009
Location: quechee Vermont
Posts: 4,394
you have a ground issue. Clean the mounting studs and the tub where they mount on the rear lamps.
__________________
1998 ZJ 5.2 Auto

1989 Wrangler Black Bone Stock 2.5l 5spd
/l , [____],
|---L--[]lllllll[]-
()_) ()_)==O=)_)
Mark05059 is offline   Reply With Quote Quick reply to this message
Unread 03-03-2013, 04:53 PM   #3
silversldr
Registered User
 
Join Date: Mar 2013
Location: Woodhaven, MI
Posts: 2
Thank you. Cleaning where it mounted fixed the drivers side. Doing a full bulb check, the passenger front running light was out and after replacing it, all lights are operating as they should
silversldr is offline   Reply With Quote Quick reply to this message
Unread 03-04-2013, 04:04 PM   #4
JWELK
Registered User
1999 XJ Cherokee 
 
Join Date: Apr 2011
Location: Ceiba, PR
Posts: 800
Welcome to the forum, may all your problems be this easy.
Thanks for posting your repair.

Regards,

Jim W
JWELK is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools






Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.