Time to ask, Fuel Pump/Electric issue - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Wrangler Forums > YJ Wrangler Technical Forum > Time to ask, Fuel Pump/Electric issue

Engo winches available at www.rockridge4wd.com! Free shippSwag Off Road BIG-HIT TJ-YJ Rear BumperCyber Sale on RUBICON EXPRESS - Short Arms, Long Arms, Tra

Reply
Unread 05-21-2013, 02:11 PM   #1
Gavlin
Registered User
1993 YJ Wrangler 
 
Join Date: May 2013
Location: bay city, mi
Posts: 12
Time to ask, Fuel Pump/Electric issue

Ok first off I would like to say thank you for all that everyone has put into these threads I am new here and dont know crap about working on car's. Without your help I would not have been able to get to the point I am at now.

Ok so after reading though a large number of posts in these forums I am now lost at what to do next. A little about the jeep itself. Its a 1993 YJ with a 4.3L Vortec engine with A/C, has 700-R-4 trans. and 231-c transfer case.

Again I dont know much about auto's but I can read and In genral I am handy so after reading through multi posts this is what I have found out.

I am getting no power to the Fuel Pump, I can run straight from the battery and power it and start the jeep right up. Also I can use the original Ground to do this so just taking power off battery. So I think the issue is within the 12V power line.

There are 3 wires that feed in, the middle wire I think the sender wire is getting ~6Volts with the key turned I do not know why if the pump is not getting power from the main line it seems that should not be the case but it does.

Checked every Fuse I could find under dash and under hood, pulled relay and I have power at 30 all the time, and I have power to 85 and 86 with the key turned. I tried jumping the relay from 30 to 87 and still will not start.

Other odd things that happened are I lost blinkers and fuel gauge is not working fuel gauge is Needled past full and for the blinkers the Hazards work but not the blinkers, I can swap those relays the blinkers and Hazards that is. The hazards still work they blink faster but still work and still no blinkers. I am just not sure what to do know I have done all of this so far based on what I have read on your forums so again thank you for that.

Also the ground wire is grounded to the body firewall not the E-brake like most I followed it down. It has good ground.

I will not have time to do anything else tonight but will be back at it tmr morning any advice would be great thanks guys.

Gavlin is offline   Reply With Quote
Unread 05-21-2013, 05:54 PM   #2
laybackman
Bikini Bridge Inspector
 
laybackman's Avatar
1995 YJ Wrangler 
 
Join Date: Dec 2002
Location: Massachusetts
Posts: 5,583
Quote:
Originally Posted by Gavlin View Post
Ok first off I would like to say thank you for all that everyone has put into these threads I am new here and dont know crap about working on car's. Without your help I would not have been able to get to the point I am at now.

Ok so after reading though a large number of posts in these forums I am now lost at what to do next. A little about the jeep itself. Its a 1993 YJ with a 4.3L Vortec engine with A/C, has 700-R-4 trans. and 231-c transfer case.

Again I dont know much about auto's but I can read and In genral I am handy so after reading through multi posts this is what I have found out.

I am getting no power to the Fuel Pump, I can run straight from the battery and power it and start the jeep right up. Also I can use the original Ground to do this so just taking power off battery. So I think the issue is within the 12V power line.

There are 3 wires that feed in, the middle wire I think the sender wire is getting ~6Volts with the key turned I do not know why if the pump is not getting power from the main line it seems that should not be the case but it does.

Checked every Fuse I could find under dash and under hood, pulled relay and I have power at 30 all the time, and I have power to 85 and 86 with the key turned. I tried jumping the relay from 30 to 87 and still will not start.

Other odd things that happened are I lost blinkers and fuel gauge is not working fuel gauge is Needled past full and for the blinkers the Hazards work but not the blinkers, I can swap those relays the blinkers and Hazards that is. The hazards still work they blink faster but still work and still no blinkers. I am just not sure what to do know I have done all of this so far based on what I have read on your forums so again thank you for that.

Also the ground wire is grounded to the body firewall not the E-brake like most I followed it down. It has good ground.

I will not have time to do anything else tonight but will be back at it tmr morning any advice would be great thanks guys.
Did you check the fuel pump relay in the PDC? If it does not get power from the ASD relay to close the fuel pump gets no voltage.

There should be a ground from the firewall to the block AND there should also be a ground in the area of the emergency brake.

And that one may be the one that is giving you all your troubles to include the gauges!
__________________
"Once good behavior becomes the exception and not the rule your society has begun to fail…..we are there." laybackman

If your girl is throwing gang signs with her toes you're hitting the spot.

"If we cannot afford to take care of Veterans, then we should stop making them."
David C. Wilker Jr. USAF (RET)
laybackman is offline   Reply With Quote
Unread 05-21-2013, 07:31 PM   #3
Gavlin
Registered User
1993 YJ Wrangler 
 
Join Date: May 2013
Location: bay city, mi
Posts: 12
Ok sorry I am a newb at this but PDC is the fuse / relay box near the battery under the hood correct? if so both the ASD relay and the fuel pump relay have power at pin 30 always and have power on 85 and 86 with key turned. I tried to jump the fuel pump and asd relays from 30 to 87, but I guess I did not try them both jumped at same time. I did not know the ASD was first in line. I will try to jump them both incase both relays are bad.

there is a ground near the parking brake that many wires go to and they seem clean and tight but I will check them to 12v and see if that ground is good also for guages and such. I will also check the firewall to the block but i was able to get 12v on my meter with the positive on the battery and the ground for the fuel pump.

Thank you
Gavlin is offline   Reply With Quote
Unread 05-22-2013, 05:47 AM   #4
laybackman
Bikini Bridge Inspector
 
laybackman's Avatar
1995 YJ Wrangler 
 
Join Date: Dec 2002
Location: Massachusetts
Posts: 5,583
Quote:
Originally Posted by Gavlin View Post
Ok sorry I am a newb at this but PDC is the fuse / relay box near the battery under the hood correct? if so both the ASD relay and the fuel pump relay have power at pin 30 always and have power on 85 and 86 with key turned. I tried to jump the fuel pump and asd relays from 30 to 87, but I guess I did not try them both jumped at same time. I did not know the ASD was first in line. I will try to jump them both incase both relays are bad.

there is a ground near the parking brake that many wires go to and they seem clean and tight but I will check them to 12v and see if that ground is good also for guages and such. I will also check the firewall to the block but i was able to get 12v on my meter with the positive on the battery and the ground for the fuel pump.

Thank you
The Power Distribution Center is the black oblong box in front of your battery that hold some fuses and relays. Here are pic of my '95YJ PDC;




__________________
"Once good behavior becomes the exception and not the rule your society has begun to fail…..we are there." laybackman

If your girl is throwing gang signs with her toes you're hitting the spot.

"If we cannot afford to take care of Veterans, then we should stop making them."
David C. Wilker Jr. USAF (RET)
laybackman is offline   Reply With Quote
Unread 05-22-2013, 08:05 AM   #5
Gavlin
Registered User
1993 YJ Wrangler 
 
Join Date: May 2013
Location: bay city, mi
Posts: 12
yes we are talking about the same thing then, I have pulled both the Auto shutdown and the fuel pump relay. I have power at pin 30 on both relays and I have power on 86 and 85 when the key is turned. I tried jumping the Fuel pump relay and auto shutdown relay from Pins 30 to 87 like the other forum posts say to do and I still get no power to the fuel pump.

I have not tried jumping them both at the same time yet incase both relays failed at the same time though that does not seem like that would happen but I am still gonna try. It is pouring rain out now so gonna have to wait a little for it to clear first.

I am starting to think it may be a ECU issue maybe a wire lose there I will have to do more research into how those are wired for a 4.3l engine as I am sure its a little diff then the jeep ECU.
Gavlin is offline   Reply With Quote
Unread 05-22-2013, 09:31 AM   #6
laybackman
Bikini Bridge Inspector
 
laybackman's Avatar
1995 YJ Wrangler 
 
Join Date: Dec 2002
Location: Massachusetts
Posts: 5,583
Quote:
Originally Posted by Gavlin View Post
yes we are talking about the same thing then, I have pulled both the Auto shutdown and the fuel pump relay. I have power at pin 30 on both relays and I have power on 86 and 85 when the key is turned. I tried jumping the Fuel pump relay and auto shutdown relay from Pins 30 to 87 like the other forum posts say to do and I still get no power to the fuel pump.

I have not tried jumping them both at the same time yet incase both relays failed at the same time though that does not seem like that would happen but I am still gonna try. It is pouring rain out now so gonna have to wait a little for it to clear first.

I am starting to think it may be a ECU issue maybe a wire lose there I will have to do more research into how those are wired for a 4.3l engine as I am sure its a little diff then the jeep ECU.
If you can 'hot wire' the fuel pump to work, then I have to believe that the wiring from the fuel pump relay to the fuel pump is NG.
testing a common relay.

A relay is a cheap heavy duty switch. It makes it easy to control a device that draws serious power like a fuel pump. The wiring that controls the relay is usually smaller gauge wire and the wiring that controls the device can be a much heavier gauge.

Testing a common normally open relay; 12v to pin 86 closes the relay when pin 85 is grounded. That gives you continuity between pin 30 and pin 87. You can control the relay in 2 ways. Control the ground at pin 85 or the power at pins 86 or 30.

Here is a diagram for installing a Zirgo electric fan showing what I stated.


__________________
"Once good behavior becomes the exception and not the rule your society has begun to fail…..we are there." laybackman

If your girl is throwing gang signs with her toes you're hitting the spot.

"If we cannot afford to take care of Veterans, then we should stop making them."
David C. Wilker Jr. USAF (RET)
laybackman is offline   Reply With Quote
Unread 05-22-2013, 09:50 AM   #7
Old4X
Registered User
1990 CJ7 
 
Join Date: Nov 2008
Location: Ga
Posts: 4,147
On your 4.3, doesn't the power to the fuel pump go through the oil pressure switch when ignition is in "run"?

Should not keep it from starting unless this has been the only feed and you had extended crank times.
__________________
Rust free YJ for sale. Need more room in barn.
Old4X is offline   Reply With Quote
Unread 05-22-2013, 09:58 AM   #8
Gavlin
Registered User
1993 YJ Wrangler 
 
Join Date: May 2013
Location: bay city, mi
Posts: 12
ok so should Pin 85 always read ground? I ask cause I am getting 12v at pin 85 when the key is turned. Also I tried to jump both relays from pin 30 to 87 thats Fuel pump relay and ASD and no go on running the fuel pump. In theory I think jumping them is giving them constant power just like when I power it straight of the battery so I am not sure why that did not work unless there is a break someplace in the wire that comes off 87 and goes to the fuel pump.

BTW I only brought up the ecu thing cause other posts say to look for a CEL light and I have none but really I dont know If I ever did have one, never looked till it stopped running.
Gavlin is offline   Reply With Quote
Unread 05-22-2013, 10:06 AM   #9
Gavlin
Registered User
1993 YJ Wrangler 
 
Join Date: May 2013
Location: bay city, mi
Posts: 12
Quote:
Originally Posted by Old4X View Post
On your 4.3, doesn't the power to the fuel pump go through the oil pressure switch when ignition is in "run"?

Should not keep it from starting unless this has been the only feed and you had extended crank times.
I have only owned it for a week I kinda had it tossed at me so to speak. ran fine for first 3 days then it just stopped and would not start. In the 3 days I did drive it around I did not notice any extended crank time to start it up though it would start right up with no issue's.

For now I am running a switch to keyed power for it just so I can be driven there is already a switch for the fan so gonna tie into that till I can figure it out.

I want to say thank you guys for the input so far if nothing else at least I am learning how this stuff works.
Gavlin is offline   Reply With Quote
Unread 05-22-2013, 10:44 AM   #10
laybackman
Bikini Bridge Inspector
 
laybackman's Avatar
1995 YJ Wrangler 
 
Join Date: Dec 2002
Location: Massachusetts
Posts: 5,583
Quote:
Originally Posted by Gavlin View Post
ok so should Pin 85 always read ground? I ask cause I am getting 12v at pin 85 when the key is turned. Also I tried to jump both relays from pin 30 to 87 thats Fuel pump relay and ASD and no go on running the fuel pump. In theory I think jumping them is giving them constant power just like when I power it straight of the battery so I am not sure why that did not work unless there is a break someplace in the wire that comes off 87 and goes to the fuel pump.

BTW I only brought up the ecu thing cause other posts say to look for a CEL light and I have none but really I dont know If I ever did have one, never looked till it stopped running.
Turn the ignition to the ON (not start) position your CEL light should come on for a second or three. Even if the relay(s) are working properly if the wiring to the fuel pump from the relay is NG that pump is not going to run. You need to start at the fuel ump and work backwards looking for continuity in the wiring because IF the relays are PK and you can only get the fuel pump to run when you hot wire it logic dictates that the wiring is NG. Compartmentalize this search for an answer. IF you cannot eliminate something from the list of possible causes.....it stay on the list of possible casues.
__________________
"Once good behavior becomes the exception and not the rule your society has begun to fail…..we are there." laybackman

If your girl is throwing gang signs with her toes you're hitting the spot.

"If we cannot afford to take care of Veterans, then we should stop making them."
David C. Wilker Jr. USAF (RET)
laybackman is offline   Reply With Quote
Unread 05-22-2013, 11:16 AM   #11
Gavlin
Registered User
1993 YJ Wrangler 
 
Join Date: May 2013
Location: bay city, mi
Posts: 12
Well thats good so it sounds like I am on the right track. If the weather would hold off now it would be nice so I could keep digging though the wires. After reading this I found I do not have a Check engine light come on at all with just the key turned to on position not even for a few sec's the only light I get for a few sec is the break light.
Gavlin is offline   Reply With Quote
Unread 05-22-2013, 05:35 PM   #12
laybackman
Bikini Bridge Inspector
 
laybackman's Avatar
1995 YJ Wrangler 
 
Join Date: Dec 2002
Location: Massachusetts
Posts: 5,583
Quote:
Originally Posted by Gavlin View Post
Well thats good so it sounds like I am on the right track. If the weather would hold off now it would be nice so I could keep digging though the wires. After reading this I found I do not have a Check engine light come on at all with just the key turned to on position not even for a few sec's the only light I get for a few sec is the break light.
Turn the ignition key to the ON position and wait until it does. When (and IF) it does fire it up. This just tells you that the ECM has bad capacitors which can be fixed.
__________________
"Once good behavior becomes the exception and not the rule your society has begun to fail…..we are there." laybackman

If your girl is throwing gang signs with her toes you're hitting the spot.

"If we cannot afford to take care of Veterans, then we should stop making them."
David C. Wilker Jr. USAF (RET)
laybackman is offline   Reply With Quote
Unread 05-22-2013, 07:17 PM   #13
Mark05059
Registered User
1989 YJ Wrangler 
 
Join Date: Mar 2009
Location: quechee Vermont
Posts: 4,201
Quote:
Originally Posted by laybackman View Post
Turn the ignition key to the ON position and wait until it does. When (and IF) it does fire it up. This just tells you that the ECM has bad capacitors which can be fixed.
You did read that someone had swapped in a 4.3 into this jeep?
__________________
1998 ZJ 5.2 Auto

1989 Wrangler Black Bone Stock 2.5l 5spd
/l , [____],
|---L--[]lllllll[]-
()_) ()_)==O=)_)
Mark05059 is offline   Reply With Quote
Unread 05-22-2013, 07:53 PM   #14
laybackman
Bikini Bridge Inspector
 
laybackman's Avatar
1995 YJ Wrangler 
 
Join Date: Dec 2002
Location: Massachusetts
Posts: 5,583
Quote:
Originally Posted by Mark05059 View Post
You did read that someone had swapped in a 4.3 into this jeep?
I actually forgot that when I started typing....

Doesn't it have a ECM also and a CEL? Does it have a crank, cam, o2 sensor(s), etc which are controlled in much the same manner?

If not then I am not helping him much and for that I am sorry if I screwed the OP with bad information.

Can you help him?????
__________________
"Once good behavior becomes the exception and not the rule your society has begun to fail…..we are there." laybackman

If your girl is throwing gang signs with her toes you're hitting the spot.

"If we cannot afford to take care of Veterans, then we should stop making them."
David C. Wilker Jr. USAF (RET)
laybackman is offline   Reply With Quote
Unread 05-22-2013, 08:48 PM   #15
Old4X
Registered User
1990 CJ7 
 
Join Date: Nov 2008
Location: Ga
Posts: 4,147
I have owned several 4.3s, They are different animals than the jeep FI engines. Most of the no start problems are distributor related.

I doubt the fuel pump relay is in the PDC, likely used a GM underhood harness and there are 2 black relays on a bracket located on the driver side firewall.

I have the factory service manual for 88 and 94, so if the engine is either, I probably have schematics for that engine.
__________________
Rust free YJ for sale. Need more room in barn.
Old4X is offline   Reply With Quote




Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.