stuck in four high - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Wrangler Forums > YJ Wrangler Technical Forum > stuck in four high

Savvy/Currie Aluminum Control ArmsRockridge 4WD IS Taking Zone Offroad Suspension Lift Kits ZONE 4.25" combo lift for TJ available at Rockridge4w

Reply
Unread 03-03-2008, 06:17 PM   #1
coolgreen
Registered User
 
Join Date: Jan 2004
Location: Newmarket, Ontario, Canada
Posts: 72
stuck in four high

My Jeep seems to be stuck in four wheel drive. When I shift into 2 wheel, the front axle appears to disengage, but the 4wd light stays on and the front driveshaft is still engaged.

I had a problem with my vacuum lines going to the front axle a few months ago, but I found the leak and fixed it. My problem at that point was no four wheel drive.

I'm going to check the linkage, but it feels OK.

Any ideas?

__________________
1995 Yj 6cyl. Auto all stock landscaping work truck w/add-a-leaf kit - very harsh ride - running a 6.8-foot SnoWay plow.
coolgreen is offline   Reply With Quote Quick reply to this message
Unread 03-03-2008, 07:07 PM   #2
xboardr311
Registered User
1995 YJ Wrangler 
 
Join Date: Feb 2008
Location: new york
Posts: 41
one thing i could think of is to check the fluid in the transfercase. if its low and depending how low it wont disengauge
xboardr311 is offline   Reply With Quote Quick reply to this message
Unread 03-03-2008, 08:13 PM   #3
coolgreen
Registered User
 
Join Date: Jan 2004
Location: Newmarket, Ontario, Canada
Posts: 72
Thanks, I will check it tommorrow.
__________________
1995 Yj 6cyl. Auto all stock landscaping work truck w/add-a-leaf kit - very harsh ride - running a 6.8-foot SnoWay plow.
coolgreen is offline   Reply With Quote Quick reply to this message
Unread 03-05-2008, 12:21 PM   #4
ksjohn
Registered User
1989 YJ Wrangler 
 
Join Date: Jul 2007
Location: wisconsin
Posts: 14
I am having the same issue on my '89. I changed the transfer case fluid and it still feels like it is in 4 wheel drive but the front tires don't spin, the front drive shaft is turning. When I do pull it inot 4 high the front tires spin like it should. The linkage feels goods.

A buddy of mine 99 TJ and his drive shaft is turning while he is in 2wd.

Thanks in advance for any suggestion.
ksjohn is offline   Reply With Quote Quick reply to this message
Unread 03-05-2008, 02:05 PM   #5
Yeepin
Registered User
1995 XJ Cherokee 
 
Join Date: Apr 2007
Location: Altoona PA
Posts: 183
I had almost the same problem.. problem with mine was i would shift it into 4wd the front driveshaft would spin but the tires wouldnt.. So i just tore apart the shift fork on the axle and it was stuck so i just hit it with a hammer and manually shifted it into 4wd. Every scince it worked fine. Check your axles shift fork out see if its stuck inbetween 2wd and 4. Because the 4wd light is just a completed circuit right off the shift fork.
__________________
1995 YJ Check it out..... http://www.jeepforum.com/forum/f12/picture-heep-532431/
1995 XJ For sale check out my classifieds (lifted 35's ect)
1999 Dodge Dakota
Yeepin is offline   Reply With Quote Quick reply to this message
Unread 03-05-2008, 02:06 PM   #6
Yeepin
Registered User
1995 XJ Cherokee 
 
Join Date: Apr 2007
Location: Altoona PA
Posts: 183
Also make sure all the vaccume lines are hooked up... If so take the vaccume line of that conects to the front axle and shift your jeep in and out of 4wd. Then hook the line back up and see what happens...
__________________
1995 YJ Check it out..... http://www.jeepforum.com/forum/showthread.php?t=532431
1995 XJ For sale check out my classifieds (lifted 35's ect)
1999 Dodge Dakota
Yeepin is offline   Reply With Quote Quick reply to this message
Unread 03-05-2008, 03:16 PM   #7
bhartwell59
Registered User
1987 YJ Wrangler 
 
Join Date: Sep 2007
Location: dallas, texas
Posts: 284
i was once told that if you ever were stuck in 4wd and wanted 2hi to drive in reverse and do a figure 8. i can't speak from experience on this tho.
__________________
4.2 '87 yj, 300,000+ miles, mopar mpi, 33" bfg mud KM2, skyjacker 4", 3.73 gears, arb lockers-f and r., tom wood's 2.07 sye conversion, tom wood's hd driveshaft, magnaflow cat/custom exhaust, 4wd rear bumper/swing-out tire carrier
bhartwell59 is offline   Reply With Quote Quick reply to this message
Unread 03-17-2008, 03:22 PM   #8
ksjohn
Registered User
1989 YJ Wrangler 
 
Join Date: Jul 2007
Location: wisconsin
Posts: 14
This past weekend I took my 4wd acutator off and found that it was stick in the locked position. I just pulled it back by hand and slid the collar over to match the shift fork and the problem was solved. While doing this I broke off a vacumm port on the acutator(rusty). I called local parts dealers to see how much the actuator is and they said about $140. I will fix that by installing the manual system discussed in the other pages. I hope this helps.

Thanks
ksjohn is offline   Reply With Quote Quick reply to this message
Unread 03-20-2008, 08:15 AM   #9
coolgreen
Registered User
 
Join Date: Jan 2004
Location: Newmarket, Ontario, Canada
Posts: 72
I found the problem

Thanks for the advice, guys. It turned out to be another vacuum leak. I got the Jeep out of 4wd by fixing one side of the vacuum harness (for the second time), but then it wouldn't go into 4wd. It turned out that the other line broke while I was fixing the other side. After fixing that side, I now have 4wd and 2wd again.

I think it's definately time for a new vacuum harness, or even better, one of those cable-operated posi-lok gizmos.
__________________
1995 Yj 6cyl. Auto all stock landscaping work truck w/add-a-leaf kit - very harsh ride - running a 6.8-foot SnoWay plow.
coolgreen is offline   Reply With Quote Quick reply to this message
Unread 03-20-2008, 09:10 AM   #10
jaw41272
Registered User
1991 YJ Wrangler 
 
Join Date: Feb 2007
Location: Glendale, NY
Posts: 643
if you can just replace vacuum hoses , I would go that route for now, posi lok is nice, but its much easier to use the factory set up, if the posi lok isnt adjusted properly it doesnt work properly, can be a pita
__________________
91 Sahara 4.0l Operation Welcome Home Parade Veh #69
PARADE JEEP MEMBER #1Auto posi-lok equipped, 4" susp. lift
K&N Drop in and loaded with battle scars
www.americaisfull.com
FOR SALE 2005 PT CRUISER CONVERTIBLE
2005 Suzuki DRZ400S For SALE
jaw41272 is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.