Starts fine then dies, I dont know why... - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Wrangler Forums > YJ Wrangler Technical Forum > Starts fine then dies, I dont know why...

FS: Wranger BRIGHT License Plate LED! Just $3! Great valueThanksgiving/Black Friday/Cyber Monday Deals at JeepinOutfBlack Friday Sale!!

Reply
Unread 10-16-2011, 03:40 PM   #1
bluedaffy
Registered User
1989 YJ Wrangler 
 
Join Date: Oct 2011
Location: Stevens Point, Wisconsin
Posts: 286
Starts fine then dies, I dont know why...

My 4.2L Wrangler yesterday morning out of the blue started acting a little funky. It will start just fine, nothing at all out of the ordinary and then die after like 15 seconds of running at a smooth idle. Nothing sputters when it dies, it just simply immediately dies. Any help on this would be wonderful, I'll need to fix this problem by next week when I will surely need it for work and school.

Thanks,
bluedaffy

bluedaffy is offline   Reply With Quote Quick reply to this message
Unread 10-16-2011, 07:34 PM   #2
castorriver
Registered User
1995 YJ Wrangler 
 
Join Date: Aug 2009
Location: South of St. Louis, Misery
Posts: 756
sounds like a dirty fuel filter. Mine would start ok but sputter and die after a few seconds and a new fuel filter fixed the problem. It's a cheap fix and you probly need a new one anyway.
__________________
Registered Nurse Jeep Club Member #1 (I think...)

Verse 36: And He said to them, "But now, whoever has a money belt is to take it along, likewise also a bag, and whoever has no sword is to sell his coat and buy one.
castorriver is offline   Reply With Quote Quick reply to this message
Unread 10-16-2011, 10:48 PM   #3
all83mci
Registered User
1989 YJ Wrangler 
 
Join Date: Oct 2011
Location: silverdale, wa
Posts: 31
New fuel filter,.fuel pump, or adjust ur keeper screws. Also spray starting fluid around ur carb . If it seems to run faster suddenly u have a vacume leak around ur carb. Have u been kidding latley? If so mayb u need a new distributor rigor cuz it is forties by moisture.
all83mci is offline   Reply With Quote Quick reply to this message
Unread 10-17-2011, 09:11 AM   #4
bluedaffy
Registered User
1989 YJ Wrangler 
 
Join Date: Oct 2011
Location: Stevens Point, Wisconsin
Posts: 286
Thanks for the replies and although I am probably due for all the new junk you guys mentioned, the problem actually turned out to be an anti-theft switch on the back of the parking brake pedal that wasn't grounded. It frustrates me that is was something so small, but it makes sense because it was like the jeep was dying for no reason at all... (anti-theft shut down)
bluedaffy is offline   Reply With Quote Quick reply to this message
Reply

Tags
carb , dies , start , start problems

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.