Starts fine then dies, I dont know why... -

LinkBack Thread Tools
post #1 of 4 Old 10-16-2011, 02:40 PM Thread Starter
Registered User
1989 YJ Wrangler 
Join Date: Oct 2011
Location: Stevens Point
Posts: 291
Starts fine then dies, I dont know why...

My 4.2L Wrangler yesterday morning out of the blue started acting a little funky. It will start just fine, nothing at all out of the ordinary and then die after like 15 seconds of running at a smooth idle. Nothing sputters when it dies, it just simply immediately dies. Any help on this would be wonderful, I'll need to fix this problem by next week when I will surely need it for work and school.


bluedaffy is offline  
Sponsored Links
post #2 of 4 Old 10-16-2011, 06:34 PM
Registered User
1995 YJ Wrangler 
Join Date: Aug 2009
Location: South of St. Louis
Posts: 751
sounds like a dirty fuel filter. Mine would start ok but sputter and die after a few seconds and a new fuel filter fixed the problem. It's a cheap fix and you probly need a new one anyway.

Registered Nurse Jeep Club Member #1 (I think...)

Verse 36: And He said to them, "But now, whoever has a money belt is to take it along, likewise also a bag, and whoever has no sword is to sell his coat and buy one.
castorriver is offline  
post #3 of 4 Old 10-16-2011, 09:48 PM
Registered User
1989 YJ Wrangler 
Join Date: Oct 2011
Location: silverdale
Posts: 31
New fuel filter,.fuel pump, or adjust ur keeper screws. Also spray starting fluid around ur carb . If it seems to run faster suddenly u have a vacume leak around ur carb. Have u been kidding latley? If so mayb u need a new distributor rigor cuz it is forties by moisture.
all83mci is offline  
post #4 of 4 Old 10-17-2011, 08:11 AM Thread Starter
Registered User
1989 YJ Wrangler 
Join Date: Oct 2011
Location: Stevens Point
Posts: 291
Thanks for the replies and although I am probably due for all the new junk you guys mentioned, the problem actually turned out to be an anti-theft switch on the back of the parking brake pedal that wasn't grounded. It frustrates me that is was something so small, but it makes sense because it was like the jeep was dying for no reason at all... (anti-theft shut down)
bluedaffy is offline  

carb , dies , start , start problems

Quick Reply

Register Now

In order to be able to post messages on the forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page

Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
Won't start - Doesn't crank - Push starts fine Panici TJ Wrangler Technical Forum 12 04-06-2010 08:36 PM
Starts, Idles, Dies, Wont Start, Wont Start, Pump Pedal, Starts... REPEAT inniett YJ Wrangler Technical Forum 2 04-08-2009 04:13 PM
6cyl. Starts fine then dies? Whats the prob? brianOU YJ Wrangler Technical Forum 4 09-07-2008 06:51 PM
Idles fine, Shift in gear and it sputters and dies smitkev2 YJ Wrangler Technical Forum 5 04-24-2008 08:19 PM
TJ dies, then wouldn't start, then wouldn't idle, now runs fine. K1dS3ns4t10n TJ Wrangler Technical Forum 18 02-25-2007 08:38 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome