JeepForum.com

JeepForum.com (http://www.jeepforum.com/forum/)
-   YJ Wrangler Technical Forum (http://www.jeepforum.com/forum/f12/)
-   -   Starts fine then dies, I dont know why... (http://www.jeepforum.com/forum/f12/starts-fine-then-dies-i-dont-know-why-1277640/)

bluedaffy 10-16-2011 02:40 PM

Starts fine then dies, I dont know why...
 
My 4.2L Wrangler yesterday morning out of the blue started acting a little funky. It will start just fine, nothing at all out of the ordinary and then die after like 15 seconds of running at a smooth idle. Nothing sputters when it dies, it just simply immediately dies. Any help on this would be wonderful, I'll need to fix this problem by next week when I will surely need it for work and school.

Thanks,
bluedaffy

castorriver 10-16-2011 06:34 PM

sounds like a dirty fuel filter. Mine would start ok but sputter and die after a few seconds and a new fuel filter fixed the problem. It's a cheap fix and you probly need a new one anyway.

all83mci 10-16-2011 09:48 PM

New fuel filter,.fuel pump, or adjust ur keeper screws. Also spray starting fluid around ur carb . If it seems to run faster suddenly u have a vacume leak around ur carb. Have u been kidding latley? If so mayb u need a new distributor rigor cuz it is forties by moisture.

bluedaffy 10-17-2011 08:11 AM

Thanks for the replies and although I am probably due for all the new junk you guys mentioned, the problem actually turned out to be an anti-theft switch on the back of the parking brake pedal that wasn't grounded. It frustrates me that is was something so small, but it makes sense because it was like the jeep was dying for no reason at all... (anti-theft shut down)


The time now is 12:12 PM.

Powered by vBulletin Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.