post #1 of Old 05-31-2013, 07:51 PM Thread Starter
jonny93yj
Registered User
1993 YJ Wrangler 
 
Join Date: Apr 2011
Location: readfield
Posts: 198
Squeak, no more of a creeek,

In march I installed my SYE KIT. I took my time and double checked everything since this was my first real solo project. Finally up here in Maine we had a summer day, so I stripped the top and doors off and went for a nice long ride through the back roads. While pulling into the garage I kept my foot on the clutch and killed the engine, while slowly rolling to a stop I heard a long creek ing sound until I stopped moving. I crawled under the jeep and slowly rolled it with my foot back n forth. It seemed like maybe it was coming from my speedo gear, so my thought was to pull that unit out in the morning when everything cooled down. Before heading in I rolled it a good way by hand with my hands on the tire and tub. I could feel it in the tire as well. I called it a night but tomorrow I'm going to remove the DS and see if I can get the t-case to do it by turning the flange by hand. Anybody else have a creek after install. I did not check fluid yet as there is no signs of any leaks and I did fill it after putting it back in.

jonny93yj is offline  
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome