Sputtering when i turn on any lights or heater - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Wrangler Forums > YJ Wrangler Technical Forum > Sputtering when i turn on any lights or heater

Ruffstuff XJ Unirail Channel Reinforcement....Rugged Ridge Modular XHD Snorkel Now for both 3.8L and 3.6RIGID LED Light Blowout Sale - All Sizes, All Series, all

Reply
Unread 10-24-2011, 01:53 AM   #1
Jeremiahsharp
Registered User
1990 YJ Wrangler 
 
Join Date: May 2011
Location: Wenatchee, Wa
Posts: 10
Sputtering when i turn on any lights or heater

My yj wrangler runs fine during the day but when I turn my headlights on or blinkers or kcs or heater it starts to sputter and backfire I need help I guest I had the alternater and battery tested everything was good iam in the dark right now I do all my own work so as much detail would be nice thank you I just want it to run smooth again.

Jeremiahsharp is offline   Reply With Quote Quick reply to this message
Unread 10-24-2011, 05:11 AM   #2
sprngrider
Registered User
1994 YJ Wrangler 
 
Join Date: Feb 2007
Location: san diego
Posts: 930
Is this only happening at idle, or while driving down the road? Are you saying you dont use your blinkers during the day?
Hook up a voltmeter to the battery when you turn on an accessory, see what the output is. Should be between 10 and 14.
__________________
1994 2.5L WRANGLER S.
sprngrider is offline   Reply With Quote Quick reply to this message
Unread 10-24-2011, 11:59 AM   #3
Brown Dog
Vendor
 
Brown Dog's Avatar
1991 YJ Wrangler 
 
Join Date: Nov 2005
Location: Queen Creek, Arizona
Posts: 3,532
I think you have a short to ground somewhere in the headlight circuit.
__________________
Brown Dog Offroad
http://www.browndogoffroad.com

The Jeep Forum Discount is ON!!

Motor Mounts, Motor Mount Lifts (MML), and Engine Brackets for Jeep
100% HANDCRAFTED IN AMERICA


91YJ 2.5
Brown Dog Mounts and Engine Brackets (Serial Number 1)
2" BL
4.5" Superlift SL
AA SYE
35" GoodYear Mud Terrains
Conteract Balancing Beads
Bulldog front bumper
Best Top seats
"Family" roll bar
25 foot 1/2" log chain
No Top, No Doors (Best Top Safari)
Brown Dog is offline   Reply With Quote Quick reply to this message
Unread 10-24-2011, 01:36 PM   #4
Jeremiahsharp
Registered User
1990 YJ Wrangler 
 
Join Date: May 2011
Location: Wenatchee, Wa
Posts: 10
Happens at an idle and driving I had the battery tested and I was Gunna pull the alternator out today to have it tested but idk the lights and everything work when the motor is off but when it's running it wants to die
Jeremiahsharp is offline   Reply With Quote Quick reply to this message
Unread 10-24-2011, 01:59 PM   #5
Que89YJ
Web Wheeler
1989 YJ Wrangler 
 
Join Date: Apr 2008
Location: Detroit, Michigan
Posts: 15,665
You are loading the alternator and it can't keep up. The stock alt. is 60 amps. If you are running KC's and other after markets you are asking too much of it. Look up the CS-144 alternator mod in the FAQ or search for it on line. It's a good mod to do and will take care of your issue.
Que89YJ is online now   Reply With Quote Quick reply to this message
Unread 10-24-2011, 07:53 PM   #6
nembudonna
Registered User
1990 YJ Wrangler 
 
Join Date: Feb 2011
Location: northwest, ark.
Posts: 903
Quote:
Originally Posted by Brown Dog View Post
I think you have a short to ground somewhere in the headlight circuit.
A bad ground somewhere gets my vote also. It happens all the time.
nembudonna is offline   Reply With Quote Quick reply to this message
Unread 10-24-2011, 10:15 PM   #7
Jeremiahsharp
Registered User
1990 YJ Wrangler 
 
Join Date: May 2011
Location: Wenatchee, Wa
Posts: 10
I went and bought a new alternator and now it holds a charge but it's still running rough I put new spark plugs in it as well then I looked at the air filter and it was covered in mud so new air filter and clean all the spark plug wires and cap and rotor look good idk why it's running so rough still any other ideas the headlights and kcs work I went with a 90 amp alternator so it has more pull
Jeremiahsharp is offline   Reply With Quote Quick reply to this message
Unread 10-24-2011, 11:27 PM   #8
nembudonna
Registered User
1990 YJ Wrangler 
 
Join Date: Feb 2011
Location: northwest, ark.
Posts: 903
Quote:
Originally Posted by Jeremiahsharp View Post
I went and bought a new alternator and now it holds a charge but it's still running rough I put new spark plugs in it as well then I looked at the air filter and it was covered in mud so new air filter and clean all the spark plug wires and cap and rotor look good idk why it's running so rough still any other ideas the headlights and kcs work I went with a 90 amp alternator so it has more pull
What the heck does idk mean. Wait, Maybe I don't want to know.
nembudonna is offline   Reply With Quote Quick reply to this message
Unread 10-25-2011, 12:10 AM   #9
lclark2074
Registered User
1990 YJ Wrangler 
 
Join Date: Nov 2008
Location: RI
Posts: 681
Ok first use a volt meter on the battrey set the volt meter on dc 20 volt scall . Turn the jeep on put the jeep in nutral then cheek the battrey. Then put the lites on check to see how much the volts drop. Next chang the scall to AC 20 volt scall . tell us what the numbers are. I got a cuppel of ideas what may make this hapen but do this first.
__________________
night crew 226
http://www.jeepforum.com/forum/f12/f...l-box-1471348/
lclark2074 is offline   Reply With Quote Quick reply to this message
Unread 10-25-2011, 12:20 AM   #10
ptwhaler
Member
 
ptwhaler's Avatar
1992 YJ Wrangler 
 
Join Date: Jan 2008
Location: Doha, Qatar
Posts: 316
Quote:
Originally Posted by nembudonna View Post
What the heck does idk mean. Wait, Maybe I don't want to know.
I had to ask my kids that when I first started texting with my phone. Means 'I don't know'
__________________
"In wine there is truth
In beer there is strength
In water there is bacteria"
ptwhaler is offline   Reply With Quote Quick reply to this message
Unread 10-25-2011, 12:37 AM   #11
nembudonna
Registered User
1990 YJ Wrangler 
 
Join Date: Feb 2011
Location: northwest, ark.
Posts: 903
Quote:
Originally Posted by ptwhaler View Post
I had to ask my kids that when I first started texting with my phone. Means 'I don't know'
OH. You didn't know like I didn't know. I don't text. Hell, I don't even have a cell phone. I still have a rock tablet. You take care.
nembudonna is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools






Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.