Speedo issue - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Wrangler Forums > YJ Wrangler Technical Forum > Speedo issue

Rampage Bowless Soft Top Oconee offroadAlloy USA Still AvailableAdvance Adapters SYE Kits

Reply
Unread 01-19-2013, 02:41 PM   #1
Northinger
Registered User
1993 YJ Wrangler 
 
Join Date: Jan 2013
Location: east stroudsburg, pa
Posts: 79
Speedo issue

When i bought the truck the speedo didn't work, I'm guessing its been that way for quite a while considering the odometer is 66601, what a bad number to land on. But i ordered a new vss, the plug didn't fit the new sensor, so i decided to put female spade terminals on. But the speedometer still isn't working, could it be that the wire sequence is different on the new vss? I also heard that a trace could be bad on the back of the gage, is there any other way to determine whats wrong before i pull the dash out?

Thanks

Northinger is offline   Reply With Quote Quick reply to this message
Unread 01-19-2013, 04:01 PM   #2
Mark05059
Registered User
1989 YJ Wrangler 
 
Join Date: Mar 2009
Location: quechee Vermont
Posts: 4,332
before you worry about wiring again.. Remove the speedometer adapter at the transfer case.. turn the key to on (engine doesnt have to be running) and turn the gear in a drill. Watch the speedometer on the dash.. let us know the result and we can let you know how to fix it.
__________________
1998 ZJ 5.2 Auto

1989 Wrangler Black Bone Stock 2.5l 5spd
/l , [____],
|---L--[]lllllll[]-
()_) ()_)==O=)_)
Mark05059 is offline   Reply With Quote Quick reply to this message
Unread 01-19-2013, 05:46 PM   #3
Northinger
Registered User
1993 YJ Wrangler 
 
Join Date: Jan 2013
Location: east stroudsburg, pa
Posts: 79
I did do this a little while back with the new vss, it didn't register on the speedometer at all.
Northinger is offline   Reply With Quote Quick reply to this message
Unread 01-19-2013, 06:00 PM   #4
Mark05059
Registered User
1989 YJ Wrangler 
 
Join Date: Mar 2009
Location: quechee Vermont
Posts: 4,332
in that case you will need to check the back of the gage.. might not be plugged in... might be a cable driven speedo.. never know what some other owner has messed with.
There is a writeup on how to remove the dash stuff under dash light led replacement. Shows all the screw locations.. actually not that hard to get apart.
__________________
1998 ZJ 5.2 Auto

1989 Wrangler Black Bone Stock 2.5l 5spd
/l , [____],
|---L--[]lllllll[]-
()_) ()_)==O=)_)
Mark05059 is offline   Reply With Quote Quick reply to this message
Unread 01-19-2013, 06:19 PM   #5
Northinger
Registered User
1993 YJ Wrangler 
 
Join Date: Jan 2013
Location: east stroudsburg, pa
Posts: 79
Ive taken the front cover off, but i didn't take the actual gage cluster itself. Im pretty certain its a vss. But the gage cluster is all circuit board..
Northinger is offline   Reply With Quote Quick reply to this message
Unread 01-19-2013, 06:28 PM   #6
Mark05059
Registered User
1989 YJ Wrangler 
 
Join Date: Mar 2009
Location: quechee Vermont
Posts: 4,332
if you have had it apart there are only a couple more screws to pull the speedo out. Take a pencil eraser to the connections where the ribbon plugs in and see what happens.
__________________
1998 ZJ 5.2 Auto

1989 Wrangler Black Bone Stock 2.5l 5spd
/l , [____],
|---L--[]lllllll[]-
()_) ()_)==O=)_)
Mark05059 is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools






Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.