Somebody Help!! tranny problems - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Wrangler Forums > YJ Wrangler Technical Forum > Somebody Help!! tranny problems

15 x 8 Black D-Window Steel Wheels Set of 4Advance Adapters SYE KitsRIGID LED Light Blowout Sale - All Sizes, All Series, all

Reply
Unread 05-10-2002, 06:13 AM   #1
jay
Registered User
 
Join Date: May 2002
Location: chicago
Posts: 1
Somebody Help!! tranny problems

Last year I swaped out the peugeot in my 87 yj and put a 97 tj ax-15 and transfer-case in it. The problem I have is when the tranny is cold it runs fine. But when it warms up it shifting is difficult and the clutch does not seem to engage all the way. Also if I sit at a light and put the vehicle in neutral, when I push the clutch in and try to put it in gear I can't. It won't let me put it in any gear. I have to turn the car off put it in gear then continue. Also when stoped at a light if I hold the clutch in I will hear and feel a small thump from inside the tranny and the tranny will try to creep the vehicle forward. On a final note: with out thinking I put an 87 clutch kit in the 97 tranny but it seems to work perfect when it's cold? Can anyone help? Is it a tranny, clutch, or both problem? Know how to fix, please help!

jay is offline   Reply With Quote
Reply
Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.