Running rough, code 27, exhaust smells like unburnt fuel - Page 2 - JeepForum.com

Reply
 
LinkBack Thread Tools
post #16 of 20 Old 05-23-2013, 05:52 AM
Que89YJ
Web Wheeler
1989 YJ Wrangler 
 
Join Date: Apr 2008
Location: Detroit
Posts: 21,415
Yes, it is worth it. It is definitely cam/crank with the symptoms. I was just helping someone who had the code 27 and it ended up being the cam when I thought it was the crank because of the symptoms. Swap it out and if it doesn't do the trick you are looking at the crank sensor.

Que89YJ is offline  
Sponsored Links
Advertisement
 
post #17 of 20 Old 05-23-2013, 08:30 AM Thread Starter
nathanninja
Registered User
1991 YJ Wrangler 
 
Join Date: Apr 2011
Location: Collegeville
Posts: 802
Quote:
Originally Posted by Que89YJ View Post
Yes, it is worth it. It is definitely cam/crank with the symptoms. I was just helping someone who had the code 27 and it ended up being the cam when I thought it was the crank because of the symptoms. Swap it out and if it doesn't do the trick you are looking at the crank sensor.
Yeah I'll give that a shot today. I replaced the crank sensor about 6 months ago so it should be good
nathanninja is offline  
post #18 of 20 Old 05-23-2013, 06:45 PM Thread Starter
nathanninja
Registered User
1991 YJ Wrangler 
 
Join Date: Apr 2011
Location: Collegeville
Posts: 802
Okay well I swapped the distributors and no change but I did a bunch of testing and long story short it ended up being a bad injector on #1. So the rough running is gone now but now I'm blowing white/blue smoke out of the exhaust. So from one problem to the next. I REALLY hope it's not bad rings

Edit: actually thinking about it, since the injector seemed to be stuck open (the spark plug I pulled was SOAKED in fuel after just a few seconds of running) so maybe that was just leaking fuel into my oil, which would make sense because when I checked the oil it seemed slightly higher than I remembered, and it smelled faintly of gas. Also the white smoke is definitely smoke not steam, and no coolant in my oil or vice versa
nathanninja is offline  
post #19 of 20 Old 05-24-2013, 10:49 AM
Que89YJ
Web Wheeler
1989 YJ Wrangler 
 
Join Date: Apr 2008
Location: Detroit
Posts: 21,415
did you do the fuel pressure bleed down test to find it?
Que89YJ is offline  
post #20 of 20 Old 05-24-2013, 11:06 AM Thread Starter
nathanninja
Registered User
1991 YJ Wrangler 
 
Join Date: Apr 2011
Location: Collegeville
Posts: 802
Quote:
Originally Posted by Que89YJ View Post
did you do the fuel pressure bleed down test to find it?
Nope I just pulled the spark plug and saw it was soaked in fuel. Tested the spark on it and it worked fine so I assumed it was the injector being stuck open. Switched it with a spare and it fixed the problem
nathanninja is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome