Rough idle and fuel smell - JeepForum.com

 
LinkBack Thread Tools
post #1 of 1 Old 03-27-2013, 02:25 PM Thread Starter
Wrangler87
Registered User
 
Join Date: Mar 2013
Posts: 1
Rough idle and fuel smell

I've got an 87 wrangler 4.2, auto. Just installed a brand new short block bored 60 over, new oil pump, screen, pan, harmonic balancer, had the head completely redone at the machine shop. Also put on a new 32/36 weber carb. New plugs, wires, fuel pump and filter, cap, and rotor. Jeep will start just fine, but when I put it in gear the idle will drop from 750 down to 250-300 range. It also has a fuel smell sometimes when I shut it off. Where Gould I start first trying to fix the problem?

Wrangler87 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome