Repairing Ecu? - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Wrangler Forums > YJ Wrangler Technical Forum > Repairing Ecu?

FS: Wrangler RGB Multicolor Fog Light LEDs: Awesome EffectThanksgiving holiday sale in effect @ oconeeoffroad.comRugged Ridge 8500lb Winch w/ Steel Cable $294.99 Shipped O

Reply
Unread 09-13-2013, 03:59 PM   #1
Saber
Registered User
1992 XJ Cherokee 
 
Join Date: Oct 2009
Location: Spanish Fork, Utah
Posts: 62
Repairing Ecu?

For about two weeks I have been battling stalling issues. It all started when I went mud wheeling and it progressivley got worse after that. It would randomly stall while driving down the road or coasting up to a stop sign. I cleaned battery connections, checked the plugs, wires, injectors and changed the crank sensor. After all that it was running fine until I started it to go home from work, The motor was misfiring and found out that #5 injector had no power to it. After some more diagnosing I had no power to any injector at all. I borrowed my sons Ecu from his 94 xj and it fired right up. My question is... Does this sound like a Bad capacitor issue? if not can the ECU be repaired?
Any help will be appreciated.

__________________
Big Orange-- 92 YJ Sold
92 red XJ current project
Saber is offline   Reply With Quote Quick reply to this message
Unread 09-14-2013, 08:34 PM   #2
laybackman
Bikini Bridge Inspector
 
laybackman's Avatar
1995 YJ Wrangler 
 
Join Date: Dec 2002
Location: Massachusetts
Posts: 6,222
Quote:
Originally Posted by Saber View Post
For about two weeks I have been battling stalling issues. It all started when I went mud wheeling and it progressivley got worse after that. It would randomly stall while driving down the road or coasting up to a stop sign. I cleaned battery connections, checked the plugs, wires, injectors and changed the crank sensor. After all that it was running fine until I started it to go home from work, The motor was misfiring and found out that #5 injector had no power to it. After some more diagnosing I had no power to any injector at all. I borrowed my sons Ecu from his 94 xj and it fired right up. My question is... Does this sound like a Bad capacitor issue? if not can the ECU be repaired?
Any help will be appreciated.
This JF link might be helpful;

http://www.jeepforum.com/forum/f12/c...rs-ecu-492597/
__________________
Chicks dig me.....Fish fear me

Getting older, I have developed some special skills. I have the ability to cough, sneeze, fart and pee at the same time.

"If we cannot afford to take care of Veterans, then we should stop making them."
David C. Wilker Jr. USAF (RET)
laybackman is online now   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools






Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.