JeepForum.com

JeepForum.com (http://www.jeepforum.com/forum/)
-   YJ Wrangler Technical Forum (http://www.jeepforum.com/forum/f12/)
-   -   Power lost while cruising or accelerating, tranny? clutch? engine? help?? (http://www.jeepforum.com/forum/f12/power-lost-while-cruising-accelerating-tranny-clutch-engine-help-1543703/)

mrbriteside1465 07-01-2013 06:04 PM

Power lost while cruising or accelerating, tranny? clutch? engine? help??
 
Hey guys thanks for helping. I drive a 94 wrangler YJ.

So this problem just started yesterday. While on the highway going 60mph in 5th gear, ill have the pedal close to the floor to maintain my speed. Then my jeep looses its acceleration for maybe half a sec and then picks it back up. It feels as if I lifted my foot off of the pedal and then put it back on. Sometimes it happens multiple times in a row, and I feel like it is about to stall. This is also sometimes accompanied by a terrible metal on metal sound from the tranny or the engine (hard to tell).

I know that these symptoms point towards a sensor/fuel mixing problem potentially but while sitting idle and pressing the gas the problem never occurs. My question is can it relate to my tranny/clutch? I'm asking because I just had a sketchy repair done on my clutch and my transmission was recently rebuilt. I'm wondering if something could have been done incorrectly. If it was a broken gear I feel like the problem would be much more consistent (i've done this before). I'm just not sure what to make of it.

Thanks in advance.

pete1991YJ 07-01-2013 07:38 PM

First I would check for any error codes in the computer. Then I would begin to suspect the fuel filter and fuel pump pressure. If the pump is getting old it maybe not have enough left to supply the engine under high load.

EDIT it is highly unlikely to be the trans or the clutch, even with a poor job. If those were bad you would have known about it in a few miles after doing them.

mrbriteside1465 07-02-2013 06:44 AM

Well my check engine light is not on. I'll check it out anyway.

I was driving this morning and I didn't notice the issue I was describing before, but when I was accelerating from a stop in first gear, I heard a hideous high pitched "clank" as if something got jammed up somewhere. I kept driving and this sound didn't stick around, but every now and then I can hear something rattling around somewhere. Again, it's difficult to pinpoint exactly where it's coming from. Any chance the behavior I was describing could be linked to a piston problem or something similar?

pete1991YJ 07-02-2013 08:10 AM

If you had a problem with a piston or something like that, I'm pretty sure it would be acting a lot worse. Far as the clank goes, I would check the driveline for any looseness. The clue was that it happened when you took off in first.

EDIT to add: it is possible to have errors stored in the computer even when there is no check engine light. Doesn't happen often but I have seen it here before. It doesn't hurt to check anyhow, just in case.

mrbriteside1465 07-05-2013 07:26 PM

So I checked the fuel pressure and everything is in spec. I changed out my spark plugs because I noticed some of them were charred. I added fuel injector cleaner to my gas. I added oil additive to the engine. And I seafoamed the engine to clean everything out. It felt good for the first day but the surging/hesitation problem is still occurring. Mainly on the highway while cruising. I'm stumped. The only error code in my jeep is that my a/c relay circuit might be bad, but i dont even have a/c. My next suspicion would be maybe a sensor within the engine? The fuel filter was replaced within the last 2 years.

Anyone have any suggestions?

mrbriteside1465 07-05-2013 07:59 PM

And now it isn't starting on me...that's a new problem. The engine turns over and it barely fires up, maintains a very low rpm (unusual), and stutters to a stall within a few seconds. Correct me if im wrong, but does this confirm that I am having an issue with my sensors? Sounds like the air/fuel ratio is not correct.

bigbossd1030 07-06-2013 12:22 AM

Sounds like a TPS to me.

Sent from my iPhone, probably because I am bored at work.


The time now is 07:17 AM.

Powered by vBulletin Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.