Poor heat - JeepForum.com

 
LinkBack Thread Tools
post #1 of 3 Old 09-08-2008, 08:10 AM Thread Starter
sheamus
Registered User
1990 MJ Comanche 
 
Join Date: May 2008
Location: Minnesota
Posts: 48
Poor heat

My heat seems to work but only when I'm moving, even when I am moving the heat is barely there. Also there seems to be no difference between hi and lo, it blows the same no matter what. Is my problem the blower motor?


1990 Comanche Eliminator
4.0L
D30/8.8
Disc Brakes front and rear
2" Budget Boost, Grand Cherokee front coils, AAL
Rubi Wheels
sheamus is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old 09-08-2008, 08:12 AM
jakemary
Registered User
1977 CJ7 
 
Join Date: Feb 2006
Location: st.paul mn
Posts: 369
pull the blower motor out and check it on the workbench and look for leaves stuck inside there.
jakemary is offline  
post #3 of 3 Old 09-08-2008, 10:53 AM
timatoe
Registered User
 
timatoe's Avatar
1990 YJ Wrangler 
 
Join Date: Aug 2006
Location: Grass Valley California
Posts: 14,835
I would bet it's a bad blower motor. You should also read through some of THESE threads from the FAQ and heater stuff, lots of good info in there.

Quote:
Originally Posted by George Orwell
We sleep safe in our beds because rough men stand ready in the night to visit violence on those who would do us harm.
timatoe is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
Wrangler has poor heat and runs cool RednekWrangler YJ Wrangler Technical Forum 50 10-24-2013 02:55 PM
Poor Heat: what am I missing? richla TJ Wrangler Technical Forum 17 01-06-2010 03:00 PM
poor heat from heater core marko686 TJ Wrangler Technical Forum 5 09-20-2008 10:19 PM
Sad day, what to do with my poor YJ? hokiehoo YJ Wrangler Technical Forum 18 05-17-2007 08:50 AM
Poor Heat In My '97 Tj. Swedejeeper TJ Wrangler Technical Forum 8 12-23-2005 06:49 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome