oil temp running high - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Wrangler Forums > YJ Wrangler Technical Forum > oil temp running high

New DEAL OF THE WEEK at ROCKRIDGE 4WD!FS: Wrangler RGB Multicolor Fog Light LEDs: Awesome EffectFS: 2007-2013 Jeep Wrangler "HALO" Angel Eye Kit

Reply
Unread 06-30-2013, 03:59 PM   #1
cdeck
Registered User
1994 YJ Wrangler 
 
Join Date: Jun 2013
Location: Dunn, NC
Posts: 4
oil temp running high

I recently noticed my oil temp jumped one day from 40 to almost 80!! I took it and had a complete 18 point change done on it but now it's running at 70, unless I push in the clutch then it drops down below 40... Do I need to replace pump?

cdeck is offline   Reply With Quote
Unread 06-30-2013, 04:11 PM   #2
Michaelgoesrawr
Web Wheeler
 
Michaelgoesrawr's Avatar
1988 YJ Wrangler 
 
Join Date: Nov 2009
Location: Waco, TX
Posts: 6,758
If you're reading the stock gauge, that's pressure not temp. A good rule of thumb is 10 psi per 1000 RPM. So as long as you're not going under that I'd think everything is okay even though I have no idea why your readings are jumping

Oil pressure will be high until it heats up then it will drop as the oil gets thinner.
Oil pressure will be up while driving and drop when idling in accordance with engine rpms. I feel the same goes when you press the clutch in so that would explain why it drops.
__________________
Adopt your pets. Don't shop for them.
Michaelgoesrawr is offline   Reply With Quote
Unread 06-30-2013, 04:27 PM   #3
cdeck
Registered User
1994 YJ Wrangler 
 
Join Date: Jun 2013
Location: Dunn, NC
Posts: 4
TY for the fast response!! I meant pressure gauge lol.. it never jumped like that before, as I said it always ran at 40 and now it runs at 70, I just don't want to blow up the engine,, this is my first Jeep and I'm doing all the mechanical work on it myself.
cdeck is offline   Reply With Quote
Unread 06-30-2013, 04:34 PM   #4
Michaelgoesrawr
Web Wheeler
 
Michaelgoesrawr's Avatar
1988 YJ Wrangler 
 
Join Date: Nov 2009
Location: Waco, TX
Posts: 6,758
You may have a blocked oil passage. But I'm not sure. Someone who knows more will be by. Just give it some time.
__________________
Adopt your pets. Don't shop for them.
Michaelgoesrawr is offline   Reply With Quote
Unread 06-30-2013, 05:12 PM   #5
pasinbuy
Registered User
1994 YJ Wrangler 
 
Join Date: Feb 2007
Location: florida
Posts: 3,839
Quote:
Originally Posted by cdeck View Post
TY for the fast response!! I meant pressure gauge lol.. it never jumped like that before, as I said it always ran at 40 and now it runs at 70, I just don't want to blow up the engine,, this is my first Jeep and I'm doing all the mechanical work on it myself.

WTH are we going to even shorten "thank you" with a TY now!

I must be totally out of it these days.
pasinbuy is offline   Reply With Quote
Unread 07-01-2013, 07:32 AM   #6
cdeck
Registered User
1994 YJ Wrangler 
 
Join Date: Jun 2013
Location: Dunn, NC
Posts: 4
Thank You passinbuy for your help on that matter but if you are going to criticize anyone on spelling check yourself first.. ie:WTH.....
cdeck is offline   Reply With Quote




Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.