Now mine won't start - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Wrangler Forums > YJ Wrangler Technical Forum > Now mine won't start

FS: Jeep Fog Light LED Bulbs! Several Brightness Options! Clayton Off Road JK Short Arm Suspension Kits~Artec JK 1 TON SWAP~

Reply
Unread 02-06-2009, 04:42 PM   #1
BtownFord
Registered User
1990 YJ Wrangler 
 
Join Date: Jan 2009
Location: Tallahassee
Posts: 44
Now mine won't start


Ok i have a 1990 wrangler with the 4.2 carb. stock carb and everything else as far as i know. It had a hesitation so i have replaced the following. Plugs, coil, and pcv. It still ran rough so i put new wires in it. I go to start it up and it just cranks and cranks and cranks. I smell fuel so its getting fuel. Everything spark related is in good condition and/or new. I don't know guys. The more i mess with it the more i get frustrated.

What gives guys? What else do i need to check

BtownFord is offline   Reply With Quote
Unread 02-06-2009, 04:44 PM   #2
Brandon_YJ
Registered User
1987 YJ Wrangler 
 
Join Date: Sep 2007
Location: Metro Detroit
Posts: 3,696
Have you "verified" spark?
__________________
Quote:
Originally Posted by Mean Max View Post
I think I'll keep the YJ. But can I talk you into taking the wife?
DISCLAIMER: I (usually) browse the web using Elinks in a (text only) terminal. Which means I do not have image viewing support. So if you get confused by my seemingly inability to comment on your pictures, emoticons, etc; now you know why.
If you're still confused click here to see how I view the forum.
Brandon_YJ is offline   Reply With Quote
Unread 02-06-2009, 04:51 PM   #3
BtownFord
Registered User
1990 YJ Wrangler 
 
Join Date: Jan 2009
Location: Tallahassee
Posts: 44
Quote:
Originally Posted by Brandon_YJ View Post
Have you "verified" spark?
yes it is getting spark from the coil
BtownFord is offline   Reply With Quote
Unread 02-06-2009, 05:03 PM   #4
bringbackphish
Registered User
1990 YJ Wrangler 
 
Join Date: Dec 2008
Location: amityville, ny
Posts: 74
ive had wires that were new that were a POS and wouldnt carry the spark. Also are ur plugs gapped, i think its supposed to be .035
bringbackphish is offline   Reply With Quote
Unread 02-06-2009, 05:06 PM   #5
BtownFord
Registered User
1990 YJ Wrangler 
 
Join Date: Jan 2009
Location: Tallahassee
Posts: 44
Quote:
Originally Posted by bringbackphish View Post
ive had wires that were new that were a POS and wouldnt carry the spark. Also are ur plugs gapped, i think its supposed to be .035
My plugs are gapped correctly. The same plug wires are used from the coil to distributer as the distributer to plugs. I will swap the plug wires back to the old ones tomorrow morning.

Thanks for the ideas guys, keep them coming though
BtownFord is offline   Reply With Quote
Unread 02-06-2009, 05:13 PM   #6
Brandon_YJ
Registered User
1987 YJ Wrangler 
 
Join Date: Sep 2007
Location: Metro Detroit
Posts: 3,696
I meant did you verify spark at the plugs.
But from the way you are talking, it sounds like you know what you're doing and likely have.
FI engines have so much extra stuff on them that I have no idea how to diagnose their problems. With my carb, it's easy.

Sorry man, no help here
__________________
Quote:
Originally Posted by Mean Max View Post
I think I'll keep the YJ. But can I talk you into taking the wife?
DISCLAIMER: I (usually) browse the web using Elinks in a (text only) terminal. Which means I do not have image viewing support. So if you get confused by my seemingly inability to comment on your pictures, emoticons, etc; now you know why.
If you're still confused click here to see how I view the forum.
Brandon_YJ is offline   Reply With Quote
Unread 02-06-2009, 05:53 PM   #7
BtownFord
Registered User
1990 YJ Wrangler 
 
Join Date: Jan 2009
Location: Tallahassee
Posts: 44
I haven't verified spark on the actual plug. Just to the distributor. Its dark here so no go tonight. One thing i did notice is that the new wires are 7mm and the old wires were 8mm. Will that make a difference?
BtownFord is offline   Reply With Quote
Unread 02-06-2009, 06:05 PM   #8
Brandon_YJ
Registered User
1987 YJ Wrangler 
 
Join Date: Sep 2007
Location: Metro Detroit
Posts: 3,696
The difference in wire size will not be the cause of this issue.
__________________
Quote:
Originally Posted by Mean Max View Post
I think I'll keep the YJ. But can I talk you into taking the wife?
DISCLAIMER: I (usually) browse the web using Elinks in a (text only) terminal. Which means I do not have image viewing support. So if you get confused by my seemingly inability to comment on your pictures, emoticons, etc; now you know why.
If you're still confused click here to see how I view the forum.
Brandon_YJ is offline   Reply With Quote
Unread 02-06-2009, 06:47 PM   #9
bigsquat
Registered User
1992 YJ Wrangler 
 
Join Date: Mar 2008
Location: placerville, ca
Posts: 4,282
if your getting spark at the plugs and at the right time and its getting fuel, then that only leaves compression, and or valve timming. but i dought thats it. dids you try spraying starter fluid in the carb?
__________________
red 92 yj,4.0,dana 44 rear,xj driveshaft,rubi 4-1 tc,35"tires,smitty built winch,oba, 6" flares,hand throttle,aussie's front and back,posi-lock,6" lift.anti-wrap, hombrew bumpers, rack and sliders,cb,rear shock truss <>< ,MY BUILD: http://www.jeepforum.com/forum/showt...hp?t=613943see
Two fish swim into a concrete wall. One turns to the other and says 'Dam!'
bigsquat is offline   Reply With Quote
Unread 02-06-2009, 06:58 PM   #10
giixxer21
Registered User
1990 YJ Wrangler 
 
Join Date: Feb 2007
Location: wappingers falls ,NY
Posts: 63
i have a 90 with a 4.2 stock engine...my choke gets stuck closed sometimes..like yesterday morning when it was 5 degrees. started up....warmed up drove off...and it closed. leaving me cranking and no start...just hesitation. i doubt you blew anything if it was running fine right before. nothing like a "carter" crappy carb. take the air cleaner off,and make sure its open. also a rebuild never hurts. or a damn good clean.
__________________
90' YJ 4.2L ,SOA 36' iroks, W/full cage
93' XJ stock
giixxer21 is offline   Reply With Quote
Unread 02-06-2009, 07:02 PM   #11
johnnyfitz14
Registered User
1995 YJ Wrangler 
 
Join Date: Sep 2008
Location: arvada, Colorado
Posts: 204
its your ecm going bad i had the same problem i just took the pos carter out and now im running a 2barrel weber and im so much happier
johnnyfitz14 is offline   Reply With Quote
Unread 02-07-2009, 06:05 AM   #12
kmj153
Registered User
1990 YJ Wrangler 
 
Join Date: Nov 2005
Posts: 159
Dumb question but you do have fuel in your gas tank? My fuel guage does not work the way it use to. Also my Ignition control mudule under the washer fluid resivior went up one time on the trail. No warning signs but it prevented the jeep from starting and I think I was getting some spark, just not continuous.
__________________
1990 YJ, Waggy 44's, 4.56, ARB's, 35's, 4.2 w/ Howell FI, Stak Dana 300 RAC, w/ JB 4:1 and 32 spline output, undercoverfab belly up
2005 F-150, DD/Tow rig
kmj153 is offline   Reply With Quote
Unread 02-07-2009, 06:17 AM   #13
BtownFord
Registered User
1990 YJ Wrangler 
 
Join Date: Jan 2009
Location: Tallahassee
Posts: 44
Quote:
Originally Posted by kmj153 View Post
Dumb question but you do have fuel in your gas tank? My fuel guage does not work the way it use to. Also my Ignition control mudule under the washer fluid resivior went up one time on the trail. No warning signs but it prevented the jeep from starting and I think I was getting some spark, just not continuous.
I filled the jeep up whhen i got it and only have 35 miles on tripometer. If swapping the plug wires back does not work, i guess i will just have to start throwing stuff at it.
BtownFord is offline   Reply With Quote
Unread 02-07-2009, 06:26 AM   #14
pman
Web Wheeler
 
pman's Avatar
1988 YJ Wrangler 
 
Join Date: Aug 2005
Location: Charleston, SC
Posts: 1,241
Did you ever verify spark at the plug? Also, aside from the smell, actually look to see that you're delivering fuel into the intake. (Also, I'd agree with BigSquat about hitting the carb with starting fluid..at least it's a cheap way to ensure fuel's not the issue). At least try to rule out these basics before you throw the spark box at it. That's a "non-returnable" item at most parts stores. However, from my 20+ years experience with my own YJ, the ignition module does tend to die "suddenly" and can create a host of symptoms, including flakey spark conditions.

I never knew the Ignition Modules could be checked for proper operation, but apparently from what I've read on the board here, Advance Auto/Autozone can do it.
__________________
88 Wrangler Laredo 258-999-NP231
81/76 CJ5 304-t150-Spicer 20
82 Wagoneer 360-727-NP208
82 CJ8 Scrambler 258-t5-Dana 300
http://www.jeepforum.com/forum/f8/cj...-lulu-1350563/
pman is offline   Reply With Quote
Unread 02-07-2009, 11:16 AM   #15
BtownFord
Registered User
1990 YJ Wrangler 
 
Join Date: Jan 2009
Location: Tallahassee
Posts: 44
ok so i've messed with it all morning and still can not get it to start. Where is the ignition control module and how to i get to it?
BtownFord is offline   Reply With Quote
Reply
Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.