Is this normal - JeepForum.com
 
LinkBack Thread Tools
post #1 of 6 Old 04-18-2010, 01:11 PM Thread Starter
AM0608
Registered User
1995 YJ Wrangler 
 
Join Date: Dec 2009
Location: Niagara Falls on
Posts: 83
Is this normal

I'm installing a 4" RC lift. On the front the spring goes in the shackle fine but for the frame mount it's about 4" too short.



AM0608 is offline  
Sponsored Links
Advertisement
 
post #2 of 6 Old 04-18-2010, 02:11 PM
Fhajad
Registered User
1993 YJ Wrangler 
 
Join Date: Jun 2009
Location: Greenfield
Posts: 1,932
I personally never did a lift, but I'd imagine so. That way it actually has some force to push up with. Right now the leaf is under no pressure at all.
Fhajad is offline  
post #3 of 6 Old 04-18-2010, 02:34 PM
NorthwestYJ
Registered User
1994 YJ Wrangler 
 
Join Date: Jan 2009
Location: Star Idaho
Posts: 272
is this with the shackle bent or straight?
NorthwestYJ is offline  
post #4 of 6 Old 04-18-2010, 02:35 PM
Joe Dillard
Electric Chair Operator
 
Joe Dillard's Avatar
1991 YJ Wrangler 
 
Join Date: May 2004
Location: Lexington Park
Posts: 13,147
I often attach the spring to the spring hanger first, then the shackle end since the shackle end can swing back to couple with the spring eye.
Joe Dillard is offline  
post #5 of 6 Old 04-18-2010, 03:03 PM
brunolinski
Registered User
1989 YJ Wrangler 
 
Join Date: Dec 2008
Posts: 191
Completely normal. I have used a pry bar to get the eye in position. Use some muscle.
brunolinski is offline  
post #6 of 6 Old 04-18-2010, 04:15 PM
fyrdriver
Registered User
1983 CJ7 
 
Join Date: Jun 2008
Location: Lake Worth, FL
Posts: 767
Do what Joe says, install the frame side first then you can slide the shackle rearward. If it doesn't reach then put a jack under the spring and compress it enough to bolt it to the shackle. Also dont tighten until everythings done then torque it down.

--------------------------------------------------
Firefighters Jeep Club

http://groups.jeepforum.com/Firefighters_Jeep_Club
fyrdriver is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
Is this normal? GLANGA88 TJ Wrangler Technical Forum 13 05-04-2014 02:28 PM
D35 ? is this normal df19087 YJ Wrangler Technical Forum 10 06-02-2009 07:17 PM
normal RPM for TJ? dptx76 TJ Wrangler Technical Forum 8 07-12-2006 08:52 PM
Is this normal? NMullens YJ Wrangler Technical Forum 2 11-03-2004 04:21 PM
Is this normal? bcmopar TJ Wrangler Technical Forum 4 10-05-2004 06:14 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome