No fuel spraying from fuel rail, no spark... - JeepForum.com

 
LinkBack Thread Tools
post #1 of 14 Old 08-31-2011, 08:22 PM Thread Starter
AnonymousD
Registered User
1992 YJ Wrangler 
 
Join Date: Jul 2010
Location: Louisiana
Posts: 903
No fuel spraying from fuel rail, no spark...

My Jeep died on me the other day, and I had figured it was probably the crankshaft position sensor.

Well I found out I wasnt getting spark, and then I decided to push down on the schrader valve.

I got no fuel from it. I should get a good bit of pressure coming out of it right?

Im pretty sure that my problem is the CPS. So, what do you think?

AnonymousD is offline  
Sponsored Links
Advertisement
 
post #2 of 14 Old 08-31-2011, 09:04 PM
oldtime_ironman
Web Wheeler
1991 YJ Wrangler 
 
Join Date: Dec 2010
Location: 14304 Niagara Falls
Posts: 2,537
I'm not sure that the two problems are even related. Are there any error codes? Does the CEL come on when you turn the key?

.
oldtime_ironman is offline  
post #3 of 14 Old 09-01-2011, 09:47 AM Thread Starter
AnonymousD
Registered User
1992 YJ Wrangler 
 
Join Date: Jul 2010
Location: Louisiana
Posts: 903
I has heard that no fuel or spark was usually the CPS.

I just went outside and turned the key on and I get no lights on the dash. So does that mean my computer is toast?
AnonymousD is offline  
post #4 of 14 Old 09-01-2011, 09:58 AM
oldtime_ironman
Web Wheeler
1991 YJ Wrangler 
 
Join Date: Dec 2010
Location: 14304 Niagara Falls
Posts: 2,537
Quote:
Originally Posted by AnonymousD View Post
I has heard that no fuel or spark was usually the CPS.

I just went outside and turned the key on and I get no lights on the dash. So does that mean my computer is toast?
Either that or its not getting power at all. There's a link on how to test the computer for cheap:

http://www.jeepforum.com/forum/f12/9...plained-490788

And here's one of the guys showing how to fix the computer for cheap:

http://www.jeepforum.com/forum/f12/c...ors-ecu-492597

Both of them walk you through the whole thing step-by-step with pics.
Hope that helps!

.
oldtime_ironman is offline  
post #5 of 14 Old 09-01-2011, 09:59 AM
oldtime_ironman
Web Wheeler
1991 YJ Wrangler 
 
Join Date: Dec 2010
Location: 14304 Niagara Falls
Posts: 2,537
BTW do the headlights turn on?
oldtime_ironman is offline  
post #6 of 14 Old 09-01-2011, 10:24 AM Thread Starter
AnonymousD
Registered User
1992 YJ Wrangler 
 
Join Date: Jul 2010
Location: Louisiana
Posts: 903
I'll check the headlights when I get home from school.

I also noticed two small 10A fuses in the power distribution center were blown. I don't have the lid for it, so I have no idea what they are for. Anyone have a fuse diagram for the power distribution center under the hood?
AnonymousD is offline  
post #7 of 14 Old 09-01-2011, 11:19 AM Thread Starter
AnonymousD
Registered User
1992 YJ Wrangler 
 
Join Date: Jul 2010
Location: Louisiana
Posts: 903
Headlights work.
AnonymousD is offline  
post #8 of 14 Old 09-01-2011, 11:42 AM
Que89YJ
Web Wheeler
1989 YJ Wrangler 
 
Join Date: Apr 2008
Location: Detroit
Posts: 21,456
Check your fault codes. The crank gets synced after the asd relay gets pulled in so you should still hear the fuel pump prime when you cycle the key if its a bad crank sensor. If not check the ign fuse at the drivers feet and the asd fuse in the pdc and swap the horn and asd relay.
Que89YJ is online now  
post #9 of 14 Old 09-01-2011, 11:52 AM Thread Starter
AnonymousD
Registered User
1992 YJ Wrangler 
 
Join Date: Jul 2010
Location: Louisiana
Posts: 903
Does anyone have a diagram for the fuses and relays in the power distribution center? Im missing my cover, so I have no idea what is what.

And I cant pull codes. The CEL doesnt come on.
AnonymousD is offline  
post #10 of 14 Old 09-01-2011, 12:09 PM
oldtime_ironman
Web Wheeler
1991 YJ Wrangler 
 
Join Date: Dec 2010
Location: 14304 Niagara Falls
Posts: 2,537
Quote:
Originally Posted by AnonymousD View Post
I'll check the headlights when I get home from school.

I also noticed two small 10A fuses in the power distribution center were blown. I don't have the lid for it, so I have no idea what they are for. Anyone have a fuse diagram for the power distribution center under the hood?
Lemme take a pic of mine:

From left to right the relays on top: Fuel Pump, A/C, Auto Shutdown, Starter, Fog

From left to right, fuses on the bottom with amp ratings: 20A Haz Lamps, 20A IOD 30A Headlamps, 50A Alt Pwr 2, 20A Fog Lamps, 40A Ign Syst, 50A Fuse Block, 50A Alt Pwr 1, 30A Fuel and ECU.

Notice there aren't any 10A fuses in there? Therefore you must have had the wrong fuses before.

.
Attached Thumbnails
pdc.JPG  
oldtime_ironman is offline  
post #11 of 14 Old 09-01-2011, 01:30 PM
Que89YJ
Web Wheeler
1989 YJ Wrangler 
 
Join Date: Apr 2008
Location: Detroit
Posts: 21,456
Check the ign. fuse in the fuse at the drivers feet. It double up with ainterior lights and many people end up pulling or shorting the fuse.
Que89YJ is online now  
post #12 of 14 Old 09-01-2011, 01:38 PM
Que89YJ
Web Wheeler
1989 YJ Wrangler 
 
Join Date: Apr 2008
Location: Detroit
Posts: 21,456
If you are not getting the CEL then it is either the ignition fuse in the fuse block or the battery fuse in the PDC.
Que89YJ is online now  
post #13 of 14 Old 09-01-2011, 02:57 PM Thread Starter
AnonymousD
Registered User
1992 YJ Wrangler 
 
Join Date: Jul 2010
Location: Louisiana
Posts: 903
Quote:
Originally Posted by oldtime_ironman View Post
Lemme take a pic of mine:

From left to right the relays on top: Fuel Pump, A/C, Auto Shutdown, Starter, Fog

From left to right, fuses on the bottom with amp ratings: 20A Haz Lamps, 20A IOD 30A Headlamps, 50A Alt Pwr 2, 20A Fog Lamps, 40A Ign Syst, 50A Fuse Block, 50A Alt Pwr 1, 30A Fuel and ECU.

Notice there aren't any 10A fuses in there? Therefore you must have had the wrong fuses before.

.
Thanks.

And after all the rap Ive found in this thing, Im not surprised at all that the PO had 10A fuses in a 30A spot.

Im going to go put the CPS back on and change those fuses and see what happens.

Think you can get a clearer pic so I can print it out to keep on me? That one is kinda fuzzy.
AnonymousD is offline  
post #14 of 14 Old 09-01-2011, 03:23 PM
oldtime_ironman
Web Wheeler
1991 YJ Wrangler 
 
Join Date: Dec 2010
Location: 14304 Niagara Falls
Posts: 2,537
Quote:
Originally Posted by AnonymousD View Post
Thanks.

And after all the rap Ive found in this thing, Im not surprised at all that the PO had 10A fuses in a 30A spot.

Im going to go put the CPS back on and change those fuses and see what happens.

Think you can get a clearer pic so I can print it out to keep on me? That one is kinda fuzzy.
Here's a bit better one - sorry I'm not much with digital cams. I like the old-school film better. You should just be able to make it out with the info from before, and then use a pen or something to write over the writing in your print-out.
Attached Thumbnails
pdc-2.jpg  
oldtime_ironman is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
Broken Fuel Rail and Fuel Lines!!!! narnold YJ Wrangler Technical Forum 12 08-28-2013 09:34 AM
How do you release the fuel pressure at the fuel rail on a 2005 4.0? msully TJ Wrangler Technical Forum 7 11-14-2010 12:11 PM
Exhaust Manifold Help : Lost on how to remove Fuel injectors, wiring, and fuel rail. Mr. Notorious YJ Wrangler Technical Forum 9 08-10-2005 06:00 PM
Replaced fuel pump & no gas to fuel rail Part 2 BrianBC YJ Wrangler Technical Forum 0 08-24-2004 07:20 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome