New motor; no spark or fuel pump - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Wrangler Forums > YJ Wrangler Technical Forum > New motor; no spark or fuel pump

Introducing MONSTALINER™ UV Permanent DIY Roll On Bed LineFS: Wrangler RGB Multicolor Fog Light LEDs: Awesome EffectSavvy Aluminum Gas Tank Skid

Reply
Unread 02-20-2009, 04:06 PM   #1
Checo18
Registered User
1993 YJ Wrangler 
 
Join Date: Sep 2008
Location: Sonora, California
Posts: 391
New motor; no spark or fuel pump

Installed a new 2.5L motor out of a '97 in my YJ this week same exact motor everything bolted up the same. Has all the same wiring connectors. After we hooked everything up we noticed the engine light was on even with no key in the ignition, didn't think anything of it at first. After trying to start it engine had no spark at all and the fuel pump would not turn on. We have been completely baffled by all of this. None of the wiring was messed up or pinch in the swap it was an easy install with no other problems besides this.

Do you think this could be a computer or wiring problem we have no clue and need help, thanks

__________________
[COLOR="red"] _______ [COLOR="Black"]Only in a YJ[/COLOR]
/l ,[_____], [/COLOR]
[COLOR="red"]l---L -[/COLOR][][COLOR="Red"]lllllll[/COLOR][][COLOR="Red"]-[/COLOR]
()_)[COLOR="red"]-[/COLOR]()_)--o-)_)

2.5L, 4" RE lift, 1" booms on the front, Revolvers on the back, 1" B.L., Aussie in the 35, 31" Trxus tires, Gen-rite rocker guards, BTF tube fenders, Pro Comp bumpers, KC lights, Hi-lift and a whole lot of love.
Checo18 is offline   Reply With Quote
Unread 02-20-2009, 04:13 PM   #2
Chris
Guy with jeep
 
Chris's Avatar
1990 YJ Wrangler 
 
Join Date: Jul 2008
Location: Wildomar/ Big Bear, CA
Posts: 2,537
Are all your ground wires on and clean?
Chris is offline   Reply With Quote
Unread 02-20-2009, 04:52 PM   #3
Gonewhln
Registered User
2006 TJ Wrangler 
 
Join Date: Nov 2008
Location: Currituck, NC
Posts: 1,175
Try disconnecting the battery for 30 seconds then see what happends to the check engine light.

Also do you know how to pull your trouble codes if so check to see if anything comes up.

another thing did you remove the distrubtor from the new engine when you installed it ?
Gonewhln is offline   Reply With Quote
Unread 02-20-2009, 05:41 PM   #4
heep1991
Registered User
2007 JK Wrangler 
 
Join Date: Feb 2007
Location: Honolulu, Hawaii
Posts: 263
easy test.. find fuel pump relay. take cover off relay. press metal flap down and see if fuel pump reacts. do same to starter relay. let us know what happens
__________________
1991 YJ 2.5L - SOLD
2006 Jeep Commander 6cyl - SOLD
2007 Jeep Unlimited Rubicon 3.8L
heep1991 is offline   Reply With Quote
Unread 02-21-2009, 04:46 PM   #5
Checo18
Registered User
1993 YJ Wrangler 
 
Join Date: Sep 2008
Location: Sonora, California
Posts: 391
Quote:
Originally Posted by _Chris_ View Post
Are all your ground wires on and clean?
Yes and Yes Chris clean and tight.
__________________
[COLOR="red"] _______ [COLOR="Black"]Only in a YJ[/COLOR]
/l ,[_____], [/COLOR]
[COLOR="red"]l---L -[/COLOR][][COLOR="Red"]lllllll[/COLOR][][COLOR="Red"]-[/COLOR]
()_)[COLOR="red"]-[/COLOR]()_)--o-)_)

2.5L, 4" RE lift, 1" booms on the front, Revolvers on the back, 1" B.L., Aussie in the 35, 31" Trxus tires, Gen-rite rocker guards, BTF tube fenders, Pro Comp bumpers, KC lights, Hi-lift and a whole lot of love.
Checo18 is offline   Reply With Quote
Unread 02-21-2009, 04:52 PM   #6
Checo18
Registered User
1993 YJ Wrangler 
 
Join Date: Sep 2008
Location: Sonora, California
Posts: 391
Quote:
Originally Posted by Gonewhln View Post
Try disconnecting the battery for 30 seconds then see what happends to the check engine light.

Also do you know how to pull your trouble codes if so check to see if anything comes up.

another thing did you remove the distrubtor from the new engine when you installed it ?
I know how to pull the codes, but it wasn't throwing any before we pulled the motor. But ill see if i get any thing it hasn't even ran yet.

Never pulled the distributor.
__________________
[COLOR="red"] _______ [COLOR="Black"]Only in a YJ[/COLOR]
/l ,[_____], [/COLOR]
[COLOR="red"]l---L -[/COLOR][][COLOR="Red"]lllllll[/COLOR][][COLOR="Red"]-[/COLOR]
()_)[COLOR="red"]-[/COLOR]()_)--o-)_)

2.5L, 4" RE lift, 1" booms on the front, Revolvers on the back, 1" B.L., Aussie in the 35, 31" Trxus tires, Gen-rite rocker guards, BTF tube fenders, Pro Comp bumpers, KC lights, Hi-lift and a whole lot of love.
Checo18 is offline   Reply With Quote
Unread 02-21-2009, 04:53 PM   #7
Checo18
Registered User
1993 YJ Wrangler 
 
Join Date: Sep 2008
Location: Sonora, California
Posts: 391
This is just stumping the crap out of me.
__________________
[COLOR="red"] _______ [COLOR="Black"]Only in a YJ[/COLOR]
/l ,[_____], [/COLOR]
[COLOR="red"]l---L -[/COLOR][][COLOR="Red"]lllllll[/COLOR][][COLOR="Red"]-[/COLOR]
()_)[COLOR="red"]-[/COLOR]()_)--o-)_)

2.5L, 4" RE lift, 1" booms on the front, Revolvers on the back, 1" B.L., Aussie in the 35, 31" Trxus tires, Gen-rite rocker guards, BTF tube fenders, Pro Comp bumpers, KC lights, Hi-lift and a whole lot of love.
Checo18 is offline   Reply With Quote
Unread 02-22-2009, 01:19 AM   #8
Checo18
Registered User
1993 YJ Wrangler 
 
Join Date: Sep 2008
Location: Sonora, California
Posts: 391
This is really starting to piss me off, the jeep is my daily driver and I need it to go to college any help would be gladly accepted thank you
__________________
[COLOR="red"] _______ [COLOR="Black"]Only in a YJ[/COLOR]
/l ,[_____], [/COLOR]
[COLOR="red"]l---L -[/COLOR][][COLOR="Red"]lllllll[/COLOR][][COLOR="Red"]-[/COLOR]
()_)[COLOR="red"]-[/COLOR]()_)--o-)_)

2.5L, 4" RE lift, 1" booms on the front, Revolvers on the back, 1" B.L., Aussie in the 35, 31" Trxus tires, Gen-rite rocker guards, BTF tube fenders, Pro Comp bumpers, KC lights, Hi-lift and a whole lot of love.
Checo18 is offline   Reply With Quote
Unread 02-22-2009, 04:26 AM   #9
dmock
Registered User
1984 CJ8 
 
Join Date: Jan 2007
Location: In my garage in Arizona, Arizona
Posts: 236
Check the harness that goes from the battery area back and under to the tranfer case. This harness contains the neutral safety switch. Also the harness that runs through the firewall near the gas pedal. This harness has the fuel pump wiring. Good luck.
dmock is offline   Reply With Quote
Unread 02-22-2009, 11:12 AM   #10
Gonewhln
Registered User
2006 TJ Wrangler 
 
Join Date: Nov 2008
Location: Currituck, NC
Posts: 1,175
Did you find your starting problem ?
Gonewhln is offline   Reply With Quote
Unread 02-22-2009, 11:41 PM   #11
Checo18
Registered User
1993 YJ Wrangler 
 
Join Date: Sep 2008
Location: Sonora, California
Posts: 391
Nope nothing yet
__________________
[COLOR="red"] _______ [COLOR="Black"]Only in a YJ[/COLOR]
/l ,[_____], [/COLOR]
[COLOR="red"]l---L -[/COLOR][][COLOR="Red"]lllllll[/COLOR][][COLOR="Red"]-[/COLOR]
()_)[COLOR="red"]-[/COLOR]()_)--o-)_)

2.5L, 4" RE lift, 1" booms on the front, Revolvers on the back, 1" B.L., Aussie in the 35, 31" Trxus tires, Gen-rite rocker guards, BTF tube fenders, Pro Comp bumpers, KC lights, Hi-lift and a whole lot of love.
Checo18 is offline   Reply With Quote
Unread 02-23-2009, 06:09 AM   #12
Que89YJ
Web Wheeler
1989 YJ Wrangler 
 
Join Date: Apr 2008
Location: Detroit, Michigan
Posts: 14,816
Diagnostics

You said you had an engine light. What are the diagnostic codes?
Que89YJ is offline   Reply With Quote
Unread 02-23-2009, 08:50 AM   #13
idaholtby
Registered User
1991 YJ Wrangler 
 
Join Date: Apr 2008
Location: Meridian, Idaho
Posts: 2,554
Seeing how you swapped in an OBDII motor into an OBDI equipped jeep, I have a couple of questions on exactly what it is that you did. Did you swap all of the sensors and accessories from the old motor to new? Did you retain the original ECU and wiring? Did you swap over the fuel rail and injectors? Throttle body? The fact that the CEL light is lit even without the key in the ignition is worrisome. OBDII sensors run on a different voltage than OBDI style. The OBDII style TJ fuel rail does not have a fuel regulator and fuel return line as it is regulated at the fuel pump.
idaholtby is offline   Reply With Quote
Unread 03-03-2009, 03:18 PM   #14
Checo18
Registered User
1993 YJ Wrangler 
 
Join Date: Sep 2008
Location: Sonora, California
Posts: 391
Quote:
Originally Posted by idaholtby View Post
Seeing how you swapped in an OBDII motor into an OBDI equipped jeep, I have a couple of questions on exactly what it is that you did. Did you swap all of the sensors and accessories from the old motor to new? Did you retain the original ECU and wiring? Did you swap over the fuel rail and injectors? Throttle body? The fact that the CEL light is lit even without the key in the ignition is worrisome. OBDII sensors run on a different voltage than OBDI style. The OBDII style TJ fuel rail does not have a fuel regulator and fuel return line as it is regulated at the fuel pump.
Sorry I got the years wrong it is an OBDI style, everything is exactly the same. CEL light was staying on with no key in the ignition because I had hooked the two wires that have one connector to the positive post of the starter solenoid and they should have been on the ground lug on the block, my bad. After fixing that the light turned off fuel pump is working now when key is in the on position or when you crank it. The thing now is that there's no spark at all.

Do you think those wires being wrongly connected could've fried the computer? Just got done checking codes and there is nothing wrong, the only codes are #12(battery disconnected), #33(A/C circuit open, note I don't have A/C), #55(End of codes). I'm thinking it could be that the CPS is bad, I don't think so cause it was running when we brought it into the garage.

Any more insight in this would be appreciated.
__________________
[COLOR="red"] _______ [COLOR="Black"]Only in a YJ[/COLOR]
/l ,[_____], [/COLOR]
[COLOR="red"]l---L -[/COLOR][][COLOR="Red"]lllllll[/COLOR][][COLOR="Red"]-[/COLOR]
()_)[COLOR="red"]-[/COLOR]()_)--o-)_)

2.5L, 4" RE lift, 1" booms on the front, Revolvers on the back, 1" B.L., Aussie in the 35, 31" Trxus tires, Gen-rite rocker guards, BTF tube fenders, Pro Comp bumpers, KC lights, Hi-lift and a whole lot of love.
Checo18 is offline   Reply With Quote
Unread 03-03-2009, 04:41 PM   #15
merlin7782
Registered User
1997 TJ Wrangler 
 
Join Date: Jan 2006
Location: Key West, FL
Posts: 453
Is the engine turning over at all now?
merlin7782 is offline   Reply With Quote
Reply
Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.