post #46 of Old 06-20-2013, 06:18 PM
PA_YJ19
Registered User
1994 YJ Wrangler 
 
Join Date: Mar 2011
Location: Altoona
Posts: 1,137
Awesome sounds like we're getting closer. Is the fluid real hot inside? Stick ur finger in right after n find out. It's ok if the pump is hot as long as the fluid isn't hot enough to burn ur finger it should b fine.

PA_YJ19 is offline  
post #47 of Old 06-20-2013, 06:34 PM Thread Starter
94_Yeti
Registered User
1994 YJ Wrangler 
 
Join Date: Jun 2013
Location: Spokane
Posts: 30
The fluid is pretty darn warm, warmer than I like my jacuzzi water........
94_Yeti is offline  
post #48 of Old 06-20-2013, 06:40 PM Thread Starter
94_Yeti
Registered User
1994 YJ Wrangler 
 
Join Date: Jun 2013
Location: Spokane
Posts: 30
Btw the pump and pulley are brand new from oreilys and I guess just to say again the gearbox was from a '96 grand Cherokee but it bolted straight up so I went with it....��
94_Yeti is offline  
post #49 of Old 06-20-2013, 07:00 PM Thread Starter
94_Yeti
Registered User
1994 YJ Wrangler 
 
Join Date: Jun 2013
Location: Spokane
Posts: 30
With ignition on I ran the steering through a few times and then started it up. Slight wheel jerk left but not to stops. Left on for 1 min and on turning it off I started to hear a noise hard to describe. Anyway shut it off at 1 min and noticed smoke once again coming from the pump for approx. one more min. Also the fluid while cool and clear in the res is still very hot on the outlet port of the pump. Let me know what you guys think.....
94_Yeti is offline  
post #50 of Old 06-20-2013, 07:07 PM
PA_YJ19
Registered User
1994 YJ Wrangler 
 
Join Date: Mar 2011
Location: Altoona
Posts: 1,137
It should b hot coming out of the pump that means its working but it shouldn't b smoking. As long as it just warm in ur resevoir then its not getting too hot. Ur sayin it's smoking while running or after u shut it off?
PA_YJ19 is offline  
post #51 of Old 06-20-2013, 07:19 PM Thread Starter
94_Yeti
Registered User
1994 YJ Wrangler 
 
Join Date: Jun 2013
Location: Spokane
Posts: 30
After I shut it off but I'm assuming it either just takes that long ( a min) to get hot enough to smoke or it's smoking the whole time and I can't see it because of my fan blowing
94_Yeti is offline  
post #52 of Old 06-20-2013, 07:26 PM
PA_YJ19
Registered User
1994 YJ Wrangler 
 
Join Date: Mar 2011
Location: Altoona
Posts: 1,137
Is the pump new or used?
PA_YJ19 is offline  
post #53 of Old 06-20-2013, 08:02 PM Thread Starter
94_Yeti
Registered User
1994 YJ Wrangler 
 
Join Date: Jun 2013
Location: Spokane
Posts: 30
New from O'Reilly's
94_Yeti is offline  
post #54 of Old 06-20-2013, 08:37 PM
PA_YJ19
Registered User
1994 YJ Wrangler 
 
Join Date: Mar 2011
Location: Altoona
Posts: 1,137
Wondering if mayb even tho it's new it's no good, everything else is hooked up correctly. I've gotten new parts that were not so good before, water pump with a bad bearing n so on. If its smoking id prob see if they would swap it for another one. I see no reason if it is hooked up correctly that it would smoke. I've had 3 pumps go bad on me before and never ne smoke. I don't see nething else that could really be ur problem. Im sure it prob came with sum sort of a warranty and it hasn't been very long since u bought it.
PA_YJ19 is offline  
post #55 of Old 06-20-2013, 08:39 PM Thread Starter
94_Yeti
Registered User
1994 YJ Wrangler 
 
Join Date: Jun 2013
Location: Spokane
Posts: 30
Good call man I'll head there in the morning!
94_Yeti is offline  
post #56 of Old 06-20-2013, 08:44 PM
PA_YJ19
Registered User
1994 YJ Wrangler 
 
Join Date: Mar 2011
Location: Altoona
Posts: 1,137
Quote:
Originally Posted by 94_Yeti
Good call man I'll head there in the morning!
Sounds good hopefully ur turning like a champ tmrrw.
PA_YJ19 is offline  
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome