map sensor - Page 4 - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Wrangler Forums > YJ Wrangler Technical Forum > map sensor

Hella Rallye 1000 Series 12-Volt/55-Watt Black Magic HalogFS: Jeep Fog Light LED Bulbs! Several Brightness Options! Jeep Wrangler Hurricane Flat Fender Flare Kits for 2007-20

Reply
Unread 11-05-2012, 08:52 AM   #46
Que89YJ
Web Wheeler
1989 YJ Wrangler 
 
Join Date: Apr 2008
Location: Detroit, Michigan
Posts: 14,981
ZTE. Now that you were able to get the connector off the ecu, there are 2 sides to that connector. The pins that make contact inside On the back of the connector there is a shell. You need to pull the shell off and look at the back of the pins to see if any of the pins are pushing back when you connect the ecu. Check all the pins to make sure they are not "spread and not making good contact with the pins on the ecu. It looks like the ecu was forced and you should never need to force it and bend pins. Also look for any moisture inside of the shell.

Que89YJ is online now   Reply With Quote
Reply
Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.