Major issues what to do?!?!? - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Wrangler Forums > YJ Wrangler Technical Forum > Major issues what to do?!?!?

Brand New! Quadratec LED Headlights!FS: 2007-2013 Jeep Wrangler "HALO" Angel Eye KitFS: Wranger BRIGHT License Plate LED! Just $3! Great value

Reply
Unread 03-12-2014, 04:48 PM   #1
Tnjeeper89
Registered User
 
Join Date: Mar 2014
Location: Greeneville, Tennessee
Posts: 13
Major issues what to do?!?!?

Hi guys I'm new to the forum but have had my jeep almost a year. Here's a little back story.
Bought jeep and it ran great for about 2 weeks then started having issues witha bad wire. So I replaced the wire and covered up the new connection with heat shrik. Drove good for a few days then had fuel issues. While it was down we went ahead and replaced fuel pump, fuel filter, fuel lines, vacuum lines and put in a new injector. Also changed out the cps, new coil, plugs and plug wires just to go ahead and have everything in good shape.
I've been driving the jeep to work for the past 2 monthes and it had ran great up until about a week ago it stumbled once coming home and cleared right. The next morning cranked up the jeep it stumbled twice coming out of the drive way then cleared up again. Left work that night was running fine went to the store to get a few items came fired right up. Went maybe 1000 ft and it stumbled again this time my shift lift started flashing like crazy and the jeep was dead. I thought I was out of gas my guage doesn't work. But no it was full with good gas. I couldn't hear my fuel pump coming on so I sprayed some starter fluid in it to see if it would start. It wouldn't so pulled a plug and had no spark. So I pulled it home with my buddies Cherokee. Since then I've replaced both relays in the engine bay and checked my cps it is good. Motor will turn over but won't start fuel pump still not coming on and still no spark. It's an 89 four banger 5 speed I think that's all I can give you guys as far as what's happening.

Tnjeeper89 is offline   Reply With Quote
Unread 03-12-2014, 04:51 PM   #2
Why J?
Registered User
1993 YJ Wrangler 
 
Join Date: Sep 2004
Location: Knoxville Tn
Posts: 3,437
Do you have a check engine light?
__________________
New Project "Pissed Wife"

http://www.jeepforum.com/forum/f22/project-pissed-wife-747535/
Phase II 5.3L/4L60e then NV3550
http://www.jeepforum.com/forum/f22/p...stall-1400506/
Why J? is offline   Reply With Quote
Unread 03-12-2014, 05:05 PM   #3
Tnjeeper89
Registered User
 
Join Date: Mar 2014
Location: Greeneville, Tennessee
Posts: 13
I'm pretty sure my year doesn't have a check engine light. That or mine is unhooked
Tnjeeper89 is offline   Reply With Quote
Unread 03-12-2014, 05:10 PM   #4
Why J?
Registered User
1993 YJ Wrangler 
 
Join Date: Sep 2004
Location: Knoxville Tn
Posts: 3,437
Yours has one. It should light up when you first start the Jeep. It is how you know the ECU is still alive.

What is the year and what engine.
__________________
New Project "Pissed Wife"

http://www.jeepforum.com/forum/showthread.php?t=747535
Phase II 5.3L/4L60e then NV3550
http://www.jeepforum.com/forum/f22/p...stall-1400506/
Why J? is offline   Reply With Quote
Unread 03-12-2014, 05:15 PM   #5
Tnjeeper89
Registered User
 
Join Date: Mar 2014
Location: Greeneville, Tennessee
Posts: 13
Well then my CEL light is unhooked cause it has never came on since I've had it.
Tnjeeper89 is offline   Reply With Quote
Unread 03-12-2014, 05:16 PM   #6
Tnjeeper89
Registered User
 
Join Date: Mar 2014
Location: Greeneville, Tennessee
Posts: 13
It's an 89 four cylinder tbi
Tnjeeper89 is offline   Reply With Quote
Unread 03-12-2014, 05:22 PM   #7
Why J?
Registered User
1993 YJ Wrangler 
 
Join Date: Sep 2004
Location: Knoxville Tn
Posts: 3,437
Verify the ECU is alive. Your fuel pump should prime for a few seconds when you first turn the key.

No spark, no fuel pump suggest to me that you may have a dead ECU. But also check all the fuses and relays.
__________________
New Project "Pissed Wife"

http://www.jeepforum.com/forum/showthread.php?t=747535
Phase II 5.3L/4L60e then NV3550
http://www.jeepforum.com/forum/f22/p...stall-1400506/
Why J? is offline   Reply With Quote
Unread 03-12-2014, 05:23 PM   #8
Tnjeeper89
Registered User
 
Join Date: Mar 2014
Location: Greeneville, Tennessee
Posts: 13
Checked all fuses and relays all are good.
Tnjeeper89 is offline   Reply With Quote
Unread 03-12-2014, 05:26 PM   #9
Why J?
Registered User
1993 YJ Wrangler 
 
Join Date: Sep 2004
Location: Knoxville Tn
Posts: 3,437
Then verify the ECU is alive by fixing the CEL.
__________________
New Project "Pissed Wife"

http://www.jeepforum.com/forum/showthread.php?t=747535
Phase II 5.3L/4L60e then NV3550
http://www.jeepforum.com/forum/f22/p...stall-1400506/
Why J? is offline   Reply With Quote
Unread 03-12-2014, 05:51 PM   #10
Tnjeeper89
Registered User
 
Join Date: Mar 2014
Location: Greeneville, Tennessee
Posts: 13
Ok so pulled the dash panel that should contain the CEL and I have no place for a CEL did some research and my jeep does not have a CEL and the only way to test things is with a volt meter
Tnjeeper89 is offline   Reply With Quote
Unread 03-12-2014, 06:06 PM   #11
Why J?
Registered User
1993 YJ Wrangler 
 
Join Date: Sep 2004
Location: Knoxville Tn
Posts: 3,437
I missed where you posted it was an 89. My mistake.

I would check the ECU and the ignition switch.
__________________
New Project "Pissed Wife"

http://www.jeepforum.com/forum/showthread.php?t=747535
Phase II 5.3L/4L60e then NV3550
http://www.jeepforum.com/forum/f22/p...stall-1400506/
Why J? is offline   Reply With Quote
Unread 03-12-2014, 06:24 PM   #12
jeepguy85
Bringing down the BFH
1987 YJ Wrangler 
 
Join Date: Jan 2009
Location: Kingsport, Tennessee
Posts: 1,076
I see you are in Greeneville. I live in Kingsport. If you need some help, pm me. I agree to check the ECM. It could be going out.
__________________
Quote:
Originally Posted by Exparrot View Post
"When Chuck Norris drives, Chuck Norris controls the radio..."
Quote:
Originally Posted by HurricaneRZA View Post
Mean Max created Chuck Norris with some spare parts, two trac bars and some differential fluid.
jeepguy85 is offline   Reply With Quote
Unread 03-12-2014, 06:37 PM   #13
Tnjeeper89
Registered User
 
Join Date: Mar 2014
Location: Greeneville, Tennessee
Posts: 13
How do I check the ecu and ignition like what am I wanting my readings to be and jeepguy85 will do man. Also how hard would it be to rip out all the 4banger junk and go to a carbed inline 6. My dad used to be a mechanic but he never worked on anything with an ecu beside myself I like a carb easier for me to work with less electronic stuff
Tnjeeper89 is offline   Reply With Quote
Unread 03-12-2014, 07:05 PM   #14
Why J?
Registered User
1993 YJ Wrangler 
 
Join Date: Sep 2004
Location: Knoxville Tn
Posts: 3,437
Read this.

http://www.jeepforum.com/forum/f12/h...ur-ecu-591031/
__________________
New Project "Pissed Wife"

http://www.jeepforum.com/forum/showthread.php?t=747535
Phase II 5.3L/4L60e then NV3550
http://www.jeepforum.com/forum/f22/p...stall-1400506/
Why J? is offline   Reply With Quote
Unread 03-12-2014, 10:18 PM   #15
AZJEEPGUY1
Registered User
 
Join Date: Sep 2013
Posts: 31
This sounds like a problem I had took it to the dealer 3 times each time they would say it was the ecm but it wasn't I put 2 other ecms in it. It did the same thing. Turned out to be the connection ears for the ignition fuse under the dash it took me a few months to find it I was a kid then. But it was doing the same thing no fuel pump or spark but it would crank fine it would sputter when I would hit a bump or just die. One of the ear connections that the fuse slides into in the fuse box for the ignition fuse was broken so it was losing connection. I just cut the wires out of the back of the fuse box and ran my own fuse like above the fuse box. Doesn't heart to check could be something that simple. Wave
AZJEEPGUY1 is offline   Reply With Quote




Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.