JeepForum.com

JeepForum.com (http://www.jeepforum.com/forum/)
-   YJ Wrangler Technical Forum (http://www.jeepforum.com/forum/f12/)
-   -   Low Fuel Pressure (http://www.jeepforum.com/forum/f12/low-fuel-pressure-1526135/)

aldersonfilm 05-20-2013 09:38 PM

Low Fuel Pressure
 
Jeep failed smog, because it was running too lean. Tested the fuel pressure and it's down at 22 psi. With the regulator disconnected, it jumps to 31 psi and the vacuum line leading to it is free of fuel and dry. When revving the engine, the psi jumps from 22 to about 27psi. Fuel filter is brand new. So I'm a little stumped. Is it the fuel pump or the fuel regulator that is bad?

pete1991YJ 05-21-2013 11:36 AM

You can always pinch off the return line for a minute and see what the pump builds up to. Shoule be in the range of 60 to 90 PSI. If its on the low side then you can bet its the pump. As a practical matter tho, I simply replaced both my pump and regulator at the same time, reasoning that they were both 20 yrs old and I didn't feel like screwing around.

Siva283 05-21-2013 01:15 PM

Quote:

Originally Posted by pete1991YJ (Post 15461361)
You can always pinch off the return line for a minute and see what the pump builds up to. Shoule be in the range of 60 to 90 PSI. If its on the low side then you can bet its the pump. As a practical matter tho, I simply replaced both my pump and regulator at the same time, reasoning that they were both 20 yrs old and I didn't feel like screwing around.

This is grat advice...I have swapped out alot just due to the age of it. Why wait until it goes bad and potentially causes other problems. After 20 years its due to go at anytime.

aldersonfilm 05-21-2013 09:35 PM

Well I replaced my pump, but that almost seemed to make it worse. For one, this new pump is super loud. It has a loud whine to it. Also, the fuel pressure is still down at around 22 psi. Didn't change a thing, but the regulator seems to be working fine... Now what???

aldersonfilm 05-21-2013 11:46 PM

I also have a total lack of power when accelerating that developed 5 minutes into driving with the new pump. I punch the gas from a dead stop and it very, very slowly accelerates. This little started happening in the middle of driving. One stop light it was zippy and responsive, and then next, it was sluggish and hardly moving forward at all. The cat is brand new. Unless the mechanic put a ****ty used one on there, but I don't think so.

Siva283 05-22-2013 05:34 AM

When was the last time you change the fuel filter. Has there been any work done lately? Could be a pinched line. Dont rule out the fuel pressure regulater yet eithier. Since you replaced the pump start at the tank and work your way forward.

Que89YJ 05-22-2013 06:15 AM

Why are you running 2 threads for the same issue?


The time now is 12:29 AM.

Powered by vBulletin Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.