lifter tap - JeepForum.com

 
LinkBack Thread Tools
post #1 of 6 Old 03-08-2014, 09:34 AM Thread Starter
rubisean
Registered User
1990 YJ Wrangler 
 
Join Date: Mar 2012
Location: wesley chapel
Posts: 229
lifter tap

advise on quieting noisy lifter..... 90 4.2

rubisean is offline  
Sponsored Links
Advertisement
 
post #2 of 6 Old 03-08-2014, 09:52 AM
Latefreight727
Registered User
1991 YJ Wrangler 
 
Join Date: Jul 2013
Location: Arcadia
Posts: 157
You can try Marvel Mystery Oil. It is a long shot but cheap to try.
Latefreight727 is offline  
post #3 of 6 Old 03-08-2014, 09:57 AM
bigbossd1030
Registered User
1995 YJ Wrangler 
 
Join Date: Feb 2010
Location: Edmonton, AB
Posts: 2,514
Quote:
Originally Posted by rubisean
advise on quieting noisy lifter..... 90 4.2
Déjà vu, I'm seeing doubles.
Add a litre of ATF in the engine for a couple hundred clicks.
Then change oil.

/l ,[____],
l----L-[]lllllll[]-
()_)-()_)--o)_)

OFFICIAL JEEPER
Any Jeepers in Edmonton, AB
I am on channel 33.

I live, I ride, I am JEEP.
bigbossd1030 is offline  
post #4 of 6 Old 03-08-2014, 02:43 PM
90DesertTanYJ
Registered User
1990 YJ Wrangler 
 
Join Date: Jun 2012
Location: Jacksonville
Posts: 749
Quote:
Originally Posted by bigbossd1030 View Post
Déjà vu, I'm seeing doubles.
Add a litre of ATF in the engine for a couple hundred clicks.
Then change oil.
This. Get a WIX or Napa Gold filter. AMC has been plagued by oiling issues. If your engine isnt clean it will cause all kind of problems.
90DesertTanYJ is offline  
post #5 of 6 Old 03-08-2014, 06:24 PM
93YJfalcon
Registered User
1993 YJ Wrangler 
 
Join Date: Apr 2005
Location: near St. Louis, mo.
Posts: 1,609
My ticking 4.0 quieted after switching to full synthetic motor oil.

ROCK OVER LONDON... ROCK ON CHICAGO!
93YJfalcon is offline  
post #6 of 6 Old 03-09-2014, 08:56 AM
sptrmike
Member
 
sptrmike's Avatar
1989 YJ Wrangler 
 
Join Date: Mar 2010
Location: epping
Posts: 220
I had the same problem. I used Marvel Mystery Oil, but I left it in for 3000 miles the lifter got quiet at about 1600 miles. I had changed pushrods and rockers because they had some wear, more than I thought they would have with just under 90,000. I did this before MMO and noticed a sludge film on every thing under the valve cover. I did my oil change last weekend and pulled the valve cover spotless,I mean it looked brand new! no sludge, all of it gone. I am going to keep using MMO every oil change and I changed from Rotella 10-30 to 15-40 and use Wix filter. My engine is now running like it did when I fist built it, that stuff is great!
sptrmike is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome