Led turn signal bulb - JeepForum.com

 
LinkBack Thread Tools
post #1 of 15 Old 01-24-2016, 03:44 PM Thread Starter
bck4more
Registered User
1987 YJ Wrangler 
 
Join Date: May 2010
Location: springfield,Mo
Posts: 411
Led turn signal bulb

Ok I've bought 3 different bulbs now but have same issue every time. Im just wanting to replace my front turn signal bulb with LED but they don't flash. I don't have side marker lights and on the rear I have the flush style LED lights. Anyone know what is causing this?


1987 4.2 automatic, 33" Pro Comp, 2100MC, nuttered, SOA, SYE,TW driveshaft
bck4more is offline  
Sponsored Links
Advertisement
 
post #2 of 15 Old 01-24-2016, 03:52 PM
xjrjrx
Registered User
 
Join Date: Oct 2014
Posts: 172
Garage
With mine on a 94 I added side marker led bulbs and a flasher that has an extra ground wire on it and got them to all work there is a floating ground of sorts that switches the front and side marker lights when you use your turn signal your lights are flashing but extremely fast try the flasher relay and adding the flare lights
xjrjrx is offline  
post #3 of 15 Old 01-25-2016, 04:01 PM
metalhead
Registered User
2011 WK 
 
Join Date: Nov 2008
Location: southampton, Pa
Posts: 1,272
This is what you need. Got it from amazon.
Attached Images
 

1994 YJ (no longer own
2000 Grand Cherokee WJ (no longer own)
2011 Grand Cherokee WK2
metalhead is offline  
post #4 of 15 Old 01-25-2016, 04:34 PM
fishadventure
Registered User
1991 YJ Wrangler 
 
Join Date: Jul 2013
Location: Morrisville
Posts: 2,687
Quote:
Originally Posted by metalhead
This is what you need. Got it from amazon.
I can't see what year he has on the app but that is likely the correct answer for him.
Amazon has a bunch of them. I have one on the kitchen counter right now for my CB400F that's got LED rear blinks/brake/tail inherited from an older Ducati Monster.

How many old threads actually convince *you* to read all 36 pages? http://www.jeepforum.com/forum/f12/length-envy-build-thread-629700/
fishadventure is offline  
post #5 of 15 Old 01-25-2016, 04:51 PM
xjrjrx
Registered User
 
Join Date: Oct 2014
Posts: 172
Garage
Quote:
Originally Posted by metalhead
This is what you need. Got it from amazon.
that's the one
xjrjrx is offline  
post #6 of 15 Old 01-25-2016, 05:03 PM
Drednot
Registered User
1991 YJ Wrangler 
 
Join Date: Aug 2005
Location: Phoenix
Posts: 3,289
Quote:
Originally Posted by bck4more View Post
. Anyone know what is causing this?
The LED bulbs don't pull enough power to heat up the flasher's bi-metallic switch that makes the flasher flash.

There are electronic flashers made that overcome that. Like the one pictured above.

91 YJ Sahara, 4.0L, AX-15/NP231, D30/D35@3.07
12 Cherokee 4x4,3.7L,42RLE/MP1522, D30M/8.25@3.73
Emission test=YES
"Non Vi Sed, Arte"
Drednot is offline  
post #7 of 15 Old 01-25-2016, 08:57 PM
Bailey_S1007
Registered User
1990 YJ Wrangler 
 
Join Date: Jan 2016
Location: Corona
Posts: 201
You can buy the electronic flasher at a autoparts store. I just bought some get the EL-12 flasher
Bailey_S1007 is offline  
post #8 of 15 Old 01-25-2016, 09:23 PM
Mr.B
Wot's...uh The Deal?
 
Mr.B's Avatar
1994 YJ Wrangler 
 
Join Date: Nov 2005
Location: Roseville, Ca.
Posts: 4,154
Quote:
Originally Posted by Bailey_S1007 View Post
You can buy the electronic flasher at a autoparts store. I just bought some get the EL-12 flasher
That's what I got. Autozone and Napa sell them. They don't have a ground wire, but work with LED's.

.
White '94 YJ 2.5L 5 speed, 35" BFGs KM2's, 5" lift, Mark VII 2 speed fan, Milemarker PE8000, Front Aussie Locker, Power steering conversion, '98 Cavalier seats, MORE Boomerangs in front, 136 amp ZJ alternator, JB conversions SYE, Tom Woods custom drive shaft, 8.8 with ARB, 4.88 gear ratio, Teralow

My Jeep

Member:The Wrecking Crew

Ham license:
KB6(tooeasytosearch)

Everyone is Welcome
www.rubiconramblers.com

Quote:
Originally Posted by Major Sanderson
You have no respect for excessive authority or obsolete traditions. You're dangerous and depraved, and you ought to be taken outside and shot!
Quote:
Originally Posted by Beefstew
I may have proven that I am in fact an idiot, by all of your standards...
Quote:
Originally Posted by ritjobbie View Post
Mr.B's post gets you as close to Buddha as you can get on JF...
Mr.B is offline  
post #9 of 15 Old 01-25-2016, 09:43 PM
xjrjrx
Registered User
 
Join Date: Oct 2014
Posts: 172
Garage
They work with leds but they do not work when you run front(grill and side marker) and rear leds you might be able to have them work without your headlights on but once they are on with that flasher they will not work I had that problem along with dozens of other guys here putting leds front and rear
xjrjrx is offline  
post #10 of 15 Old 01-25-2016, 11:40 PM
Mr.B
Wot's...uh The Deal?
 
Mr.B's Avatar
1994 YJ Wrangler 
 
Join Date: Nov 2005
Location: Roseville, Ca.
Posts: 4,154
Quote:
Originally Posted by xjrjrx View Post
They work with leds but they do not work when you run front(grill and side marker) and rear leds you might be able to have them work without your headlights on but once they are on with that flasher they will not work I had that problem along with dozens of other guys here putting leds front and rear
That sounds odd. The EL-12 is just a simple mechanical flasher, as far as I know. It should work no matter what you have plugged into it. But I only have rear LED's, so I never had that problem.

.
White '94 YJ 2.5L 5 speed, 35" BFGs KM2's, 5" lift, Mark VII 2 speed fan, Milemarker PE8000, Front Aussie Locker, Power steering conversion, '98 Cavalier seats, MORE Boomerangs in front, 136 amp ZJ alternator, JB conversions SYE, Tom Woods custom drive shaft, 8.8 with ARB, 4.88 gear ratio, Teralow

My Jeep

Member:The Wrecking Crew

Ham license:
KB6(tooeasytosearch)

Everyone is Welcome
www.rubiconramblers.com

Quote:
Originally Posted by Major Sanderson
You have no respect for excessive authority or obsolete traditions. You're dangerous and depraved, and you ought to be taken outside and shot!
Quote:
Originally Posted by Beefstew
I may have proven that I am in fact an idiot, by all of your standards...
Quote:
Originally Posted by ritjobbie View Post
Mr.B's post gets you as close to Buddha as you can get on JF...
Mr.B is offline  
post #11 of 15 Old 01-26-2016, 01:43 AM
timatoe
Registered User
 
timatoe's Avatar
1990 YJ Wrangler 
 
Join Date: Aug 2006
Location: Grass Valley California
Posts: 14,916
Quote:
Originally Posted by xjrjrx View Post
They work with leds but they do not work when you run front(grill and side marker) and rear leds you might be able to have them work without your headlights on but once they are on with that flasher they will not work I had that problem along with dozens of other guys here putting leds front and rear
Hmm, I have that same EL-12 flasher and my side marker LED's up front and the rear tail/stop/turn signals all work, even when the headlights are on.

Quote:
Originally Posted by George Orwell
We sleep safe in our beds because rough men stand ready in the night to visit violence on those who would do us harm.
timatoe is offline  
post #12 of 15 Old 01-26-2016, 07:29 AM
xjrjrx
Registered User
 
Join Date: Oct 2014
Posts: 172
Garage
I had that one in mine when I swapped the rear to LEDs and it worked then when I switched the grille lights it went hyper flash on me and looked like it was solid then I added side marker LEDs and the flasher with a ground and they all worked and I have read many other threads from others with the same problem maybe yours is a little different then the others but some flashers worked for some while they didn't for others those YJ's are weird
xjrjrx is offline  
post #13 of 15 Old 01-26-2016, 11:02 AM
timatoe
Registered User
 
timatoe's Avatar
1990 YJ Wrangler 
 
Join Date: Aug 2006
Location: Grass Valley California
Posts: 14,916
One thing is for sure, none of them are the same.

Quote:
Originally Posted by George Orwell
We sleep safe in our beds because rough men stand ready in the night to visit violence on those who would do us harm.
timatoe is offline  
post #14 of 15 Old 01-31-2016, 09:02 AM Thread Starter
bck4more
Registered User
1987 YJ Wrangler 
 
Join Date: May 2010
Location: springfield,Mo
Posts: 411
Well installed the Eflasher like the one in the OP post and they work till you turn park lamps on then they no longer flash.

1987 4.2 automatic, 33" Pro Comp, 2100MC, nuttered, SOA, SYE,TW driveshaft
bck4more is offline  
post #15 of 15 Old 01-31-2016, 08:30 PM
Drednot
Registered User
1991 YJ Wrangler 
 
Join Date: Aug 2005
Location: Phoenix
Posts: 3,289
Quote:
Originally Posted by bck4more View Post
Well installed the Eflasher like the one in the OP post and they work till you turn park lamps on then they no longer flash.
Did you ground that little wire?

Did you run ground wires from the rear housings to the front of the jeep/battery, or are you relying on the tub?

91 YJ Sahara, 4.0L, AX-15/NP231, D30/D35@3.07
12 Cherokee 4x4,3.7L,42RLE/MP1522, D30M/8.25@3.73
Emission test=YES
"Non Vi Sed, Arte"
Drednot is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome