post #1 of Old 12-16-2011, 10:59 AM Thread Starter
rustybeater
Registered User
1991 YJ Wrangler 
 
Join Date: May 2009
Location: lexington park
Posts: 172
jeep wont start

I have a 91 yj with the 2.5L I was driving home today and when I got in the drive way my jeep did a little weird idle/ missfire so I pushed the clutch in gave it a little rev and it seemed fine went to finish pulling up the drive was and it died and will not start well it started once but sounded like only one cylinder was firing. I checked the fuel at the rail it is 38 psi I checked the spark it seems like it only gets a spark every now and then. The motor still turns over but does not start. I have not really done anything to it recently on monday I put in a new optima battery (volts are good on the batt) and then this morning I changed the thermostat but that should not be able to affect it in any way and the jeep was running below 210 all day. I am about to go try to pull the coil any other ideas?

rustybeater is offline  
post #2 of Old 12-16-2011, 11:23 AM
moonshinefuel
Registered User
1995 YJ Wrangler 
 
Join Date: Feb 2009
Location: Los Angeles. California. United States.
Posts: 4,910
The crankshaft position sensor bolts to the bell housing. I would look at that, make sure the bolts are holding it into place securely. Also the sensor itself could be malfunctioning. It is possible.
moonshinefuel is offline  
post #3 of Old 12-16-2011, 12:33 PM
Que89YJ
Web Wheeler
1989 YJ Wrangler 
 
Join Date: Apr 2008
Location: Detroit
Posts: 20,787
Crank position sensor, Distributor Pickup sensor, bad coil/ or wire. Check your codes;
http://www.jeepforum.com/forum/f12/h...codes-1257145/

x2 with moonshinefuel but since you were messing with the Tstat I would check the plug to the distributor.
Que89YJ is online now  
post #4 of Old 12-16-2011, 01:13 PM Thread Starter
rustybeater
Registered User
1991 YJ Wrangler 
 
Join Date: May 2009
Location: lexington park
Posts: 172
yea I will have to check that in the morning had to go to work. The engine light did not come on.
rustybeater is offline  
post #5 of Old 12-16-2011, 02:21 PM
Que89YJ
Web Wheeler
1989 YJ Wrangler 
 
Join Date: Apr 2008
Location: Detroit
Posts: 20,787
The cel didn't light then check the power on pins 3 and 9 on the ecu with the key switch on. Check the dome fuse. It supplies power to the ecu.
Que89YJ is online now  
post #6 of Old 12-16-2011, 03:33 PM Thread Starter
rustybeater
Registered User
1991 YJ Wrangler 
 
Join Date: May 2009
Location: lexington park
Posts: 172
thanks for the info I checked the fuses under the hood and some of the ones inside. Not sure if I checked the dome one I will check it when I get home thanks for the info. I dont get out of work till 1130pm so i will give an update in the a.m.
rustybeater is offline  
post #7 of Old 12-17-2011, 08:31 AM Thread Starter
rustybeater
Registered User
1991 YJ Wrangler 
 
Join Date: May 2009
Location: lexington park
Posts: 172
replaced the coil and it starts right up thanks for the help everyone.
rustybeater is offline  
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
jeep wont stay running, now wont start 89General YJ Wrangler Technical Forum 5 02-11-2011 05:57 AM
Jeep Wont Start!!! NEWJeeper10 TJ Wrangler Technical Forum 7 01-03-2010 07:10 PM
help me A.S.A.P jeep wont start zitzka666 TJ Wrangler Technical Forum 3 10-04-2009 02:05 PM
Jeep wont start advice on where to start? vangosu TJ Wrangler Technical Forum 6 08-25-2008 08:28 AM
Jeep wont start black99jeep TJ Wrangler Technical Forum 4 03-31-2005 11:19 AM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome