jeep won't start need help - JeepForum.com

Reply
 
LinkBack Thread Tools
post #1 of 23 Old 10-27-2013, 03:53 PM Thread Starter
Jimbo58
Registered User
1994 YJ Wrangler 
 
Join Date: Sep 2010
Location: Sarnia
Posts: 176
jeep won't start need help

I need help with my Jeep it cranks but won't start. It's a 94yj with 2.5 5speed only mod is remove air box and replace with cold air intake, this was done many years ago. Yesterday on the way home from work at highway speed the motor stumbled and almost quick a couple of times then it recovered and seemed to be fine for the rest of the drive home which is about a 25 mile trip each way. I knew that the o2 sensor needed replace via codes from check earlier in the week. So I changed the o2 sensor and fired up the heep and it ran for about a minute and shut down, and now it will crank but not start. There is fuel at the rail and from what I can tell there is no spark.
From my search here every says cps but I don't have a one around and no one has one in stock. It is my dd and need it to get to work is there any other cps compatible

Others said computer, which I have a spare, change it and same thing. So went back to original and now I can not get any codes to see what the heck is going on I am stumped any help would be great and deeply appreciated.



Thanks Jim

Jimbo58 is offline  
Sponsored Links
Advertisement
 
post #2 of 23 Old 10-27-2013, 04:37 PM
jokerchief462
Registered User
1989 YJ Wrangler 
 
Join Date: Nov 2010
Location: Sin City
Posts: 2,881
CPS, coil or ICM.

Sent from underneath my Jeep

89YJ 2.5L TBI, AX-5, NP231 SYE, Ford 8.8, Yukon Grizzly, Tom Woods Shaft, 33" BFG T/As, 4" lift, Warn VR10000s.

AF Jeep Club Tail #184
jokerchief462 is offline  
post #3 of 23 Old 10-27-2013, 05:03 PM Thread Starter
Jimbo58
Registered User
1994 YJ Wrangler 
 
Join Date: Sep 2010
Location: Sarnia
Posts: 176
thanks ill check getting cold out there. no garage to work in now
Jimbo58 is offline  
post #4 of 23 Old 10-27-2013, 06:40 PM
scraper
Registered User
1995 YJ Wrangler 
 
Join Date: Jul 2013
Location: Minerva
Posts: 214
I would check for spark as far as you can to eliminate some sensors. So check for spark at the distributor, then coming out of the coil, then going into the coil. Chances are it's somewhere in there. If there is no spark going to the coil then chances are its the CPS. Definitely trouble shoot the electric before you go randomly replacing stuff.
scraper is offline  
post #5 of 23 Old 10-27-2013, 07:29 PM Thread Starter
Jimbo58
Registered User
1994 YJ Wrangler 
 
Join Date: Sep 2010
Location: Sarnia
Posts: 176
thanks for the advice I will have wait for daylight now
and you are right I don't want to put anymore money into this yj I have another one that I have rebuilt and almost ready for the road.

Thanks Jim
Jimbo58 is offline  
post #6 of 23 Old 10-28-2013, 10:42 AM
Que89YJ
Web Wheeler
1989 YJ Wrangler 
 
Join Date: Apr 2008
Location: Detroit
Posts: 21,766
If you are in Sarnia you can get a crank position sensor. Hell, I could probably throw one across the Blue Water to you. I dont think that is what is going on, at least not now. If you arent getting any codes at all; that means no 12,33, or 55 when you check using the key method, then you need to run this threads checks:
http://www.jeepforum.com/forum/f12/9...lained-490788/
If you arent getting codes you have probably got a blown fuse. This thread should help.
Que89YJ is online now  
post #7 of 23 Old 10-28-2013, 06:37 PM Thread Starter
Jimbo58
Registered User
1994 YJ Wrangler 
 
Join Date: Sep 2010
Location: Sarnia
Posts: 176
Thanks for the link I am willing to try anything. The thing is that I have a spare computer and have changed it and still no start, so l will have to check for power lose somewhere.

Thanks Jim
Jimbo58 is offline  
post #8 of 23 Old 10-28-2013, 07:09 PM
Que89YJ
Web Wheeler
1989 YJ Wrangler 
 
Join Date: Apr 2008
Location: Detroit
Posts: 21,766
The post walks you through power and ground checks. Follow the post. Sentinel made one of the best electrical post ever. Read it and post back what you find.
Que89YJ is online now  
post #9 of 23 Old 10-28-2013, 07:37 PM Thread Starter
Jimbo58
Registered User
1994 YJ Wrangler 
 
Join Date: Sep 2010
Location: Sarnia
Posts: 176
Quote:
Originally Posted by Que89YJ View Post
The post walks you through power and ground checks. Follow the post. Sentinel made one of the best electrical post ever. Read it and post back what you find.
Thanks and I will when get some day light no garage.

Jimbo58 is offline  
post #10 of 23 Old 10-29-2013, 06:55 AM
pasinbuy
Registered User
1994 YJ Wrangler 
 
Join Date: Feb 2007
Location: florida
Posts: 3,902
A easy quick check for cps is to unplug it for a minute. The plug it back it. If she starts your cps is bad.
pasinbuy is offline  
post #11 of 23 Old 10-29-2013, 09:52 AM
Que89YJ
Web Wheeler
1989 YJ Wrangler 
 
Join Date: Apr 2008
Location: Detroit
Posts: 21,766
Que89YJ is online now  
post #12 of 23 Old 10-29-2013, 07:32 PM Thread Starter
Jimbo58
Registered User
1994 YJ Wrangler 
 
Join Date: Sep 2010
Location: Sarnia
Posts: 176
up date

I know how to get the cel codes from the jeep from help from the forum when I first got my jeep, but thanks anyway. That being said, when I tried to check for codes all I get is a solid cel no codes at all. What's up with that, always been able to get codes.
Next after following Sentinal02's test procedures using an analog meter . I get voltage on number 1, and no voltage on fuse number 4 the orange 40 amp fuse, but I have voltage at the fuse box dome light and Ign-Lps, I have not checked the ignition switch yet, but if I am reading it right something is screwy or I made a mistake somewhere.
Just a little more info, at the power distribution centre the only fuse that has power with or without the key is number 1


Thanks Jim
Jimbo58 is offline  
post #13 of 23 Old 10-30-2013, 08:20 AM
Que89YJ
Web Wheeler
1989 YJ Wrangler 
 
Join Date: Apr 2008
Location: Detroit
Posts: 21,766
Do you have power on pins 3&9 on the ecu with the key on?
Que89YJ is online now  
post #14 of 23 Old 10-30-2013, 05:55 PM Thread Starter
Jimbo58
Registered User
1994 YJ Wrangler 
 
Join Date: Sep 2010
Location: Sarnia
Posts: 176
Quote:
Originally Posted by Que89YJ View Post
Do you have power on pins 3&9 on the ecu with the key on?
I just got home from work and it is too dark out side now I will check tomorrow after work and post findings then.
Thank you for your help I am getting frustrated but then again that's part of owning an older jeep. lol



Thanks Jim
Jimbo58 is offline  
post #15 of 23 Old 11-01-2013, 06:42 PM Thread Starter
Jimbo58
Registered User
1994 YJ Wrangler 
 
Join Date: Sep 2010
Location: Sarnia
Posts: 176
Quote:
Originally Posted by Que89YJ View Post
Do you have power on pins 3&9 on the ecu with the key on?
I checked it today when got home from work and there is no power there.

Jim
Jimbo58 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome