Jeep won't cut off - JeepForum.com

 
LinkBack Thread Tools
post #1 of 11 Old 04-22-2013, 01:50 PM Thread Starter
lbhutch03
Registered User
1989 YJ Wrangler 
 
Join Date: Aug 2012
Location: Olive Branch, MS
Posts: 30
Jeep won't cut off

I have a 4.0 in my jeep. When I turn the key off the motor keeps running for another 10 to 15 seconds. It seems to keep running until it runs out of fuel. Any idea what could be causing this and how to fix this problem?

lbhutch03 is offline  
Sponsored Links
Advertisement
 
post #2 of 11 Old 04-22-2013, 02:29 PM
Siva283
Registered User
1995 YJ Wrangler 
 
Join Date: May 2011
Location: Falling Waters
Posts: 3,755
Are you sure its not the 4.2? Was the engine swapped? Your year came with the 4.2 if i am not mistaken

1995 YJ. 2 inch BDS Spring lift. 1 inch shackle lift. 1.25 inch JKS Body Lift 33x12.5x15's. Engo 10,000 pound winch.

Quote:
Originally Posted by Magnum View Post
I gave the Jeep the required offering of $$, sweat, and blood, and everything works fine now. -- Jim
Quote:
Originally Posted by ldso View Post
. It started with a $200 axle, and a few thousand dollars later I was done :)
Quote:
Originally Posted by Luuca View Post
diagnose the real issue before you start going all Obama on it - spending mad cash you'll need for other important things.

Ask me how I know...
Quote:
Originally Posted by Overhead View Post
this is also my second set of RC springs this year. I'd rather spend the money again and get something that will last.
Siva283 is offline  
post #3 of 11 Old 04-22-2013, 02:39 PM Thread Starter
lbhutch03
Registered User
1989 YJ Wrangler 
 
Join Date: Aug 2012
Location: Olive Branch, MS
Posts: 30
Yeah the motor was switched to a 4.0.
lbhutch03 is offline  
post #4 of 11 Old 04-22-2013, 02:41 PM
Siva283
Registered User
1995 YJ Wrangler 
 
Join Date: May 2011
Location: Falling Waters
Posts: 3,755
I got nothing for this issue with the 4.0. I am sure Que or Pete will be along shortly. They will get you straightened out.

1995 YJ. 2 inch BDS Spring lift. 1 inch shackle lift. 1.25 inch JKS Body Lift 33x12.5x15's. Engo 10,000 pound winch.

Quote:
Originally Posted by Magnum View Post
I gave the Jeep the required offering of $$, sweat, and blood, and everything works fine now. -- Jim
Quote:
Originally Posted by ldso View Post
. It started with a $200 axle, and a few thousand dollars later I was done :)
Quote:
Originally Posted by Luuca View Post
diagnose the real issue before you start going all Obama on it - spending mad cash you'll need for other important things.

Ask me how I know...
Quote:
Originally Posted by Overhead View Post
this is also my second set of RC springs this year. I'd rather spend the money again and get something that will last.
Siva283 is offline  
post #5 of 11 Old 04-22-2013, 02:47 PM
roadyrob
Registered User
1987 YJ Wrangler 
 
Join Date: Apr 2007
Location: west palm beach fl
Posts: 1,980
couple of questions, is the 4.0 carbed or FI? when you say keeps running does it run smooth or rough? dieseling will do what you discribe but it won't be running smoothly. its caused by carbon build up in the motor.

Do everything with a positive attitude, it won't always work but you'll piss enough people off to make it worthwhile.

the voices aren't real but they sure have good ideas.
roadyrob is offline  
post #6 of 11 Old 04-22-2013, 04:00 PM Thread Starter
lbhutch03
Registered User
1989 YJ Wrangler 
 
Join Date: Aug 2012
Location: Olive Branch, MS
Posts: 30
It is fuel injected. Once I turn the key off, it will run smooth for about 5 seconds. Then I will start running a little rough until it dies.
lbhutch03 is offline  
post #7 of 11 Old 04-23-2013, 11:36 AM Thread Starter
lbhutch03
Registered User
1989 YJ Wrangler 
 
Join Date: Aug 2012
Location: Olive Branch, MS
Posts: 30
And if it is carbon build up, what causes this and how do I fix it?
lbhutch03 is offline  
post #8 of 11 Old 04-23-2013, 11:46 AM
roadyrob
Registered User
1987 YJ Wrangler 
 
Join Date: Apr 2007
Location: west palm beach fl
Posts: 1,980
carbon build up is caused by a rich condition, usually doesn't happen to FI motors unless they have had a problem. what happens is the carbon gets hot and keeps igniting the fuel after shutdown. easiest cure is seafoam. heres a thread that tells you how to do it.
http://www.jeepforum.com/forum/f11/sea-foam-99405/

Do everything with a positive attitude, it won't always work but you'll piss enough people off to make it worthwhile.

the voices aren't real but they sure have good ideas.
roadyrob is offline  
post #9 of 11 Old 04-23-2013, 11:55 AM
NonRubicon
Registered User
1990 YJ Wrangler 
 
Join Date: Nov 2009
Location: The southern armpit of California
Posts: 2,098
Check for any codes too. They'll alert you to any problems known to the computer.
NonRubicon is offline  
post #10 of 11 Old 05-12-2013, 04:38 PM Thread Starter
lbhutch03
Registered User
1989 YJ Wrangler 
 
Join Date: Aug 2012
Location: Olive Branch, MS
Posts: 30
Ok, after some digging around I found that I still have spark once I turn the key to the off position.. I found that if I pull the coil plug right after I turn the key off, the jeep dies. I put a test light on both wires going to the coil, and they are hot with the ignition off. Any ideas what is causing this?
lbhutch03 is offline  
post #11 of 11 Old 05-13-2013, 10:29 AM
Que89YJ
Web Wheeler
1989 YJ Wrangler 
 
Join Date: Apr 2008
Location: Detroit
Posts: 22,190
Yes, you need the diode across the alternator. I bet you are using the internally regulated alternator with the fuel injected system.

http://www.jeepforum.com/forum/f12/9...36-amp-610349/
Que89YJ is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome