post #1 of Old 02-05-2002, 03:01 PM Thread Starter
FishWagon
Registered User
 
Join Date: Feb 2002
Location: Georgia
Posts: 1
Jeep sputtering when cold

Hello all,
My 88 Wrangler 4.2 has a problem. When engine is cold, I get really bad sputtering at about 2k rpm, and black smoke coming out of the exhaust.

When engine warms up, problem goes away, and engine runs fine.

I figured this is carb related, but could it be the O2 sensor also? The carb is brand new, but could something be holding the choke in the wrong position? I just finished giving the engine a full tune-up.

Thanks!!


FishWagon
88 Wrangler 4.2 5spd
33X11.50's, 3" lift.
Many exterior mods..
FishWagon is offline  
post #2 of Old 02-05-2002, 04:26 PM
Bob K
Registered User
 
Bob K's Avatar
 
Join Date: Nov 2001
Location: New Bedford, MA
Posts: 987
Yes, sounds like the choke is running too rich during warm-up. If the coil spring is not adjustable you might be able to adjust it by bending the arm. I recommend the JuiceBox ignition system to anyone with a pre-'91 YJ or CJ. Best $130 you could ever spend on your Jeep.

'87 Wrangler YJ 4.2 I6 (sorry, sold)
JuiceBox ignition
2 1/2" ProComp Lift
31" BFG A/T's
K&N Filter
Custom Rock Guards
Turbo Muffler
Rear Track Bar in the shed
Other Tricks I won't tell to just anybody!

'99 Grand Cherokee 4.7 V8
Towing Package
K&N FIPK
ProComp MX6 shocks
Borla Exhaust
Tow Hooks
Alpine CD with Infinity+iPod connect
Just getting started!

If you're not living on the edge...
you're taking up too much space.
Bob K is offline  
post #3 of Old 02-05-2002, 10:49 PM
Johnny'sJeepen
Registered User
 
Join Date: Dec 2001
Location: New York
Posts: 27
I have the same problem with MY 89 YJ. I was thinking about the juicebox. Do you happen to have a picture of it? Are there different models that i should be aware of?? Any advice would be great.
Thanks
J
Johnny'sJeepen is offline  
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
rough cold starts, and sputtering at 1/4 throttle lancer27 YJ Wrangler Technical Forum 0 01-02-2010 09:34 PM
Sputtering Jeep grinwa TJ Wrangler Technical Forum 1 09-16-2009 07:14 PM
sputtering when cold emilior TJ Wrangler Technical Forum 1 09-08-2007 04:10 PM
WARM starting/ sputtering when cold jeepcj7 TJ Wrangler Technical Forum 3 05-25-2007 02:55 PM
Jeep Sputtering eastwood1972 TJ Wrangler Technical Forum 4 10-25-2004 07:55 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome