Jeep shuts off while driving, HELP PLEASE! Huge mystery! - Page 7 - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Wrangler Forums > YJ Wrangler Technical Forum > Jeep shuts off while driving, HELP PLEASE! Huge mystery!

Rampage Bowless Soft Top Oconee offroadAlloy USA Still AvailableAdvance Adapters SYE Kits

Reply
Unread 03-13-2014, 08:34 PM   #91
sccarr54
Registered User
1995 XJ Cherokee 
 
Join Date: Mar 2014
Location: San Jose, Ca
Posts: 6
HELP I have a big problem with my 95 Jeep XJ

Hey guys, I'm new on here not sure how this works but here I go. I'm having a problem. I have a 95 jeep cherokee xj. So here's the problem. I have crank/no start sometimes and sometimes it will run for awhile then stall. I have replaced the CPS,coil,wires,cap,rotor and spark plugs. I still had the same problem so I went and got the PCM/CMU and put it in. Now it will run for a minute and then stall again. Can anyone help me!!!! PLEASE!!!!

sccarr54 is offline   Reply With Quote Quick reply to this message
Unread 03-13-2014, 10:47 PM   #92
Opihi59
from here it gets rough
 
Opihi59's Avatar
1993 YJ Wrangler 
 
Join Date: Dec 2007
Location: Beyond Honolulu
Posts: 4,098
Quote:
Originally Posted by sccarr54 View Post
Hey guys, I'm new on here not sure how this works but here I go. I'm having a problem. I have a 95 jeep cherokee xj. So here's the problem. I have crank/no start sometimes and sometimes it will run for awhile then stall. I have replaced the CPS,coil,wires,cap,rotor and spark plugs. I still had the same problem so I went and got the PCM/CMU and put it in. Now it will run for a minute and then stall again. Can anyone help me!!!! PLEASE!!!!
I can see you've tried to do some research into your problem; it appears unique enough that you should start a brand new thread for this, and I am sure you will get a lot of help.

Welcome to the forum.
__________________
....I'm not smart, but I can lift heavy things.......

Fill out your PROFILE, and don't forget to look in the FAQ for writeups

I'm stuck on da Rock http://kamfamily.wordpress.com/2009/...waiian-limpet/

Quote:
Originally Posted by Brian4.2 View Post
We will be going Metric every inch of the way.
Quote:
Originally Posted by 40dog View Post
yes I'm a some guy and have always put gasket sealer on my surfaces before mating
Quote:
Originally Posted by Virjeep View Post
You should go to Pirate. I hear they are real smart over there. You'd fit right in.
Opihi59 is offline   Reply With Quote Quick reply to this message
Unread 03-14-2014, 07:26 AM   #93
Que89YJ
Web Wheeler
1989 YJ Wrangler 
 
Join Date: Apr 2008
Location: Detroit, Michigan
Posts: 15,485
Sccarr it is usually the crank position sensor. Check your fault codes. See what diagnostics gives you.
Que89YJ is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.