Jeep shuts off.. - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Wrangler Forums > YJ Wrangler Technical Forum > Jeep shuts off..

FS: 2007-2013 Jeep Wrangler "HALO" Angel Eye KitTHE NEW! VANCO DUAL MODE 15/16″ Big Brake Kit w/BlaFS: Wranger BRIGHT License Plate LED! Just $3! Great value

Reply
Unread 05-31-2013, 11:56 AM   #1
Baja_driver
Registered User
1989 YJ Wrangler 
 
Join Date: May 2013
Location: chula vista, ca
Posts: 9
Jeep shuts off..

I saw this post when searching and I seem to have same issue, did anyone have a solution(new to site, redirected me if needed, thanks!)

Kinda late on this one guys but i have the same issue. Just got the jeep out from winter, put a charger on it cause the battery was dead then she started right up. Went fine for about 20 min then it just quit. I tried to start it again but it would just crank and crank but wouldn't start. I waited about 20 more mins then she finally started again. Any ideas? I checked the coolant and it seemed almost gunky like mud had gotten in there. Any suggestions would be awesome thanks!!!

Baja_driver is offline   Reply With Quote
Unread 05-31-2013, 12:25 PM   #2
Que89YJ
Web Wheeler
1989 YJ Wrangler 
 
Join Date: Apr 2008
Location: Detroit, Michigan
Posts: 14,547
You need to see if you are losing fuel or spark. Check for spark at the plugs and listen for the fuel pump to hum when you turn the key on and spray some starting fluid into the throttle body and see if it starts.
Que89YJ is offline   Reply With Quote
Unread 05-31-2013, 12:40 PM   #3
Baja_driver
Registered User
1989 YJ Wrangler 
 
Join Date: May 2013
Location: chula vista, ca
Posts: 9
felt like it ran out of gas, but rail had pressure, put more gas in and no start..after about 15-20 min put alittle gas on air filter and jeep fired right up and has worked every since..its done this three times...first two times I just waited after i could find no issue..15 min wait and would start back up..was thinking vapor lock..but had fuel at rail. intermitent is pretty difficult.
Baja_driver is offline   Reply With Quote
Unread 05-31-2013, 01:26 PM   #4
Que89YJ
Web Wheeler
1989 YJ Wrangler 
 
Join Date: Apr 2008
Location: Detroit, Michigan
Posts: 14,547
you need to check and see what rail pressure is. tbi should be 14 the pressure should hold for 20 min.
Que89YJ is offline   Reply With Quote
Unread 05-31-2013, 01:39 PM   #5
dailydrivenyj
Registered User
1991 YJ Wrangler 
 
Join Date: Mar 2013
Location: San Diego, CA
Posts: 26
it could be a clogged fuel filter, all the gunk settling after a long sitting period being stirred up and then pushed/pulled into the filter all at once clogging it. But like the other posters said, check fuel and spark. Good luck though.
dailydrivenyj is offline   Reply With Quote
Unread 05-31-2013, 02:44 PM   #6
1998zj
Registered User
1995 YJ Wrangler 
 
Join Date: Jul 2004
Location: Indiana
Posts: 1,848
My 89 would quit while I was driving down the road. Most times it would fire back up before it came to a stop. Sometimes it would have to sit for a few minutes before it would start again. My problem was was electrical and I never figured out what was causing it before I sold it.
__________________
"Our lady of blessed acceleration don't fail me now"
1998zj is offline   Reply With Quote
Unread 05-31-2013, 04:12 PM   #7
Que89YJ
Web Wheeler
1989 YJ Wrangler 
 
Join Date: Apr 2008
Location: Detroit, Michigan
Posts: 14,547
steel tank and sitting with a partially filled tank will cause rust and a clogged filter. fuel filter is a good thing to check.
Que89YJ is offline   Reply With Quote
Unread 06-04-2013, 01:26 PM   #8
Baja_driver
Registered User
1989 YJ Wrangler 
 
Join Date: May 2013
Location: chula vista, ca
Posts: 9
Quote:
Originally Posted by 1998zj View Post
My 89 would quit while I was driving down the road. Most times it would fire back up before it came to a stop. Sometimes it would have to sit for a few minutes before it would start again. My problem was was electrical and I never figured out what was causing it before I sold it.
thats exactly the same issue! I think I got your jeep! LOL, Kidding. but it does just that ..back fire a bit..surge then stall. its done it twice. so real hard to find if i cant get it to fail. going to put a gauge on the fuel rail also.
Baja_driver is offline   Reply With Quote
Unread 06-04-2013, 03:30 PM   #9
1998zj
Registered User
1995 YJ Wrangler 
 
Join Date: Jul 2004
Location: Indiana
Posts: 1,848
Mine was black, wish I could give you some more help.

My brother used to live in Chula Vista, just off of H street near the El Pollo Loco when he was in the Navy.
__________________
"Our lady of blessed acceleration don't fail me now"
1998zj is offline   Reply With Quote




Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.