Issues with 4cyl. - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Wrangler Forums > YJ Wrangler Technical Forum > Issues with 4cyl.

Dana 30 Truss for your TJ, LJ, ZJ, and XJFS: 2007-2013 Jeep Wrangler "HALO" Angel Eye KitFS: Wranger BRIGHT License Plate LED! Just $3! Great value

Reply
Unread 05-16-2012, 08:54 AM   #1
4kidsxj
Registered User
1999 XJ Cherokee 
 
Join Date: Feb 2012
Location: Clifton, Colorado
Posts: 27
Issues with 4cyl.

This little YJ is receiving way to much gas or maybe it has more than what the eye can read, the 4cyl. has gas mixed in with oil. With little mechanical knowledge, way to much gas is going in the combustion chambers and not enough is getting burnt! We(In-laws and I) thought the O2 sensor was bad, so I replaced it last night. Before replacing the O2 sensor, the jeep ran real crappy, it had a low idle and when it would pick up it sound like an old John Deere tractor....

4kidsxj is offline   Reply With Quote
Unread 05-16-2012, 09:13 AM   #2
Xpress
Registered User
1989 YJ Wrangler 
 
Join Date: Dec 2010
Location: The Great Big Box, California
Posts: 5,805
Check all of your vacuum lines, replace them if they're more than a few years old (all of them). Check your MAP sensor as well, ontop of that make sure there's no exhaust leaks before the cat, because it can throw everything off and cause your computer to think its running lean, thus dumping more gas into the intake. Replace all of your spark plugs, plug wires, distributor, rotor, even things like changing air filters and fuel filters can help.

Basically, do a full tuneup. These are high maintenance vehicles, they like to be loved.
__________________
[URL="http://www.jeepforum.com/forum/f12/another-5-2l-yj-thread-1503048/"]My 5.2L Build thread[/URL]

-1989 Jeep Wrangler 2.5L, soon to be 5.2L
-1996 Jeep Grand Cherokar 5.2L, donor and rainy day driver
-2004 Kawasaki KLR650 sunny day driver
[QUOTE=mudsweatNgearz;21162729]Leave em off and weld an I beam on. Bumperetts just scream homo.[/QUOTE]
"A well regulated Militia, being necessary to the security of a free State, the [B][I]RIGHT[/I][/B] of the people to keep and bear Arms, [B][I]SHALL NOT BE INFRINGED[/I][/B]."
Xpress is offline   Reply With Quote
Unread 05-16-2012, 09:31 AM   #3
Que89YJ
Web Wheeler
1989 YJ Wrangler 
 
Join Date: Apr 2008
Location: Detroit, Michigan
Posts: 14,796
When you replace any sensor you need to do a battery disconnect to clear the computer calibration and fault codes. Disconnect it for a long 10 count. It seems like your post was cut off. How is it running now?

Check for codes:
http://www.jeepforum.com/forum/f12/h...codes-1257145/
Que89YJ is offline   Reply With Quote
Unread 05-22-2012, 05:05 PM   #4
4kidsxj
Registered User
1999 XJ Cherokee 
 
Join Date: Feb 2012
Location: Clifton, Colorado
Posts: 27
The darn jeep won't start now! I changed the spark plugs, waiting to replace the spark plug wires and inspect the cap & rotor, maybe the map sensor needs replaced also
4kidsxj is offline   Reply With Quote




Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.